Reply to topic

Hard Drive Disappears

Xplorer4x4
Registered Member
Posts
199
Karma
0
OS

Hard Drive Disappears

Wed Jan 09, 2013 9:20 pm
Wasn't sure where to put this, but this section would apply to the type of tools needed to test the HDD so I thought this was the best place.

I suspect my HDD is dieing. I had problems with bad super blocks, So I followed this tutorial but the bad blocks kept happening. So I backed up the data, but not before the HDD disappeared. I unplugged the power from the HDD for a few minuets, and it survived long enough to make a back up of the data, but it is back to disappearing again and the only way to get it to show up is disconect the power and reconnect it a few min later.

I checked dmesg and here is part of the out put as it failed during rsync to back up the data:
[ 1393.001546] ata1.00: link offline, clearing class 1 to NONE
[ 1393.017526] ata1: EH complete
[ 1393.036265] ata1: exception Emask 0x10 SAct 0x0 SErr 0x4040000 action 0xe frozen
[ 1393.036272] ata1: irq_stat 0x00000040, connection status changed
[ 1393.036276] ata1: SError: { CommWake DevExch }
[ 1393.036317] ata1: limiting SATA link speed to 1.5 Gbps
[ 1393.036322] ata1: hard resetting link
[ 1393.811215] ata1: SATA link down (SStatus 0 SControl 310)
[ 1393.811219] ata1.00: link offline, clearing class 1 to NONE
[ 1393.814633] EXT4-fs error (device sda1): ext4_find_entry:1209: inode #150994945: comm rsync: reading directory lblock 0
[ 1393.827167] ata1: EH complete
[ 1393.844777] ata1: exception Emask 0x10 SAct 0x0 SErr 0x4040000 action 0xe frozen
[ 1393.844782] ata1: irq_stat 0x00000040, connection status changed
[ 1393.844785] ata1: SError: { CommWake DevExch }
[ 1393.844792] ata1: limiting SATA link speed to 1.5 Gbps
[ 1393.844796] ata1: hard resetting link
[ 1394.620959] ata1: SATA link down (SStatus 0 SControl 310)
[ 1394.620966] ata1.00: link offline, clearing class 1 to NONE
[ 1394.636852] ata1: EH complete
[ 1394.654212] ata1: exception Emask 0x10 SAct 0x0 SErr 0x4040000 action 0xe frozen
[ 1394.654215] ata1: irq_stat 0x00000040, connection status changed
[ 1394.654216] ata1: SError: { CommWake DevExch }
[ 1394.654220] ata1: limiting SATA link speed to 1.5 Gbps
[ 1394.654222] ata1: hard resetting link
[ 1395.042340] EXT4-fs error (device sda1): ext4_find_entry:1209: inode #150994945: comm rsync: reading directory lblock 0
[ 1395.042363] EXT4-fs error (device sda1): ext4_find_entry:1209: inode #150994945: comm rsync: reading directory lblock 0
[ 1395.042418] EXT4-fs error (device sda1): ext4_find_entry:1209: inode #150994945: comm rsync: reading directory lblock 0
[ 1395.042438] EXT4-fs error (device sda1): ext4_find_entry:1209: inode #150994945: comm rsync: reading directory lblock 0
[ 1395.042476] EXT4-fs error (device sda1): ext4_find_entry:1209: inode #150994945: comm rsync: reading directory lblock 0
[ 1395.042502] EXT4-fs error (device sda1): ext4_find_entry:1209: inode #150994945: comm rsync: reading directory lblock 0
[ 1395.042521] EXT4-fs error (device sda1): ext4_find_entry:1209: inode #150994945: comm rsync: reading directory lblock 0
[ 1395.430589] ata1: SATA link down (SStatus 0 SControl 310)
[ 1395.430595] ata1.00: link offline, clearing class 1 to NONE
[ 1395.446538] ata1: EH complete
[ 1395.463638] ata1: exception Emask 0x10 SAct 0x0 SErr 0x4040000 action 0xe frozen
[ 1395.463641] ata1: irq_stat 0x00000040, connection status changed
[ 1395.463642] ata1: SError: { CommWake DevExch }
[ 1395.463647] ata1: limiting SATA link speed to 1.5 Gbps
[ 1395.463649] ata1: hard resetting link
[ 1396.240275] ata1: SATA link down (SStatus 0 SControl 310)
[ 1396.240281] ata1.00: link offline, clearing class 1 to NONE
[ 1396.256215] ata1: EH complete
[ 1396.272104] ata1: exception Emask 0x10 SAct 0x0 SErr 0x4040000 action 0xe frozen
[ 1396.272106] ata1: irq_stat 0x00000040, connection status changed
[ 1396.272108] ata1: SError: { CommWake DevExch }
[ 1396.272112] ata1: limiting SATA link speed to 1.5 Gbps
[ 1396.272113] ata1: hard resetting link
[ 1397.045972] ata1: SATA link down (SStatus 0 SControl 310)
[ 1397.045977] ata1.00: link offline, clearing class 1 to NONE
[ 1397.061912] ata1: EH complete


I think it is pretty certain the HDD is dieing, but am I missing any further testing before submitting a warranty replacement?


Intel Core i7 2600K CPU
MSI P67A-G45 Mobo
2x4GB Corsair Vengance RAM
Sapphire Raedon 4890HD Vapor-X GPU
1x180 GB Intel 330 SSD
1x80GB Intel X25-M G2 SSD
2x1TB Western Digital HDDs
2x2TB Wester Digital HDDS
Corsair HX520W PSU
Thermaltake Mozart TX Case
Xplorer4x4
Registered Member
Posts
199
Karma
0
OS

Re: Hard Drive Disappears

Thu Jan 10, 2013 5:22 am
More info:
xplorer4x4@xplorer4x4-MS-7673:~$ sudo smartctl -d ata -H /dev/sda
smartctl 5.43 2012-06-30 r3573 [x86_64-linux-3.5.0-21-generic] (local build)
Copyright (C) 2002-12 by Bruce Allen, http://smartmontools.sourceforge.net

=== START OF READ SMART DATA SECTION ===
SMART overall-health self-assessment test result: PASSED

xplorer4x4@xplorer4x4-MS-7673:~$ sudo smartctl --attributes --log=selftest /dev/sda
smartctl 5.43 2012-06-30 r3573 [x86_64-linux-3.5.0-21-generic] (local build)
Copyright (C) 2002-12 by Bruce Allen, http://smartmontools.sourceforge.net

=== START OF READ SMART DATA SECTION ===
SMART Attributes Data Structure revision number: 16
Vendor Specific SMART Attributes with Thresholds:
ID# ATTRIBUTE_NAME FLAG VALUE WORST THRESH TYPE UPDATED WHEN_FAILED RAW_VALUE
1 Raw_Read_Error_Rate 0x002f 200 200 051 Pre-fail Always - 0
3 Spin_Up_Time 0x0027 253 143 021 Pre-fail Always - 3550
4 Start_Stop_Count 0x0032 100 100 000 Old_age Always - 58
5 Reallocated_Sector_Ct 0x0033 200 200 140 Pre-fail Always - 0
7 Seek_Error_Rate 0x002e 100 253 000 Old_age Always - 0
9 Power_On_Hours 0x0032 099 099 000 Old_age Always - 1440
10 Spin_Retry_Count 0x0032 100 253 000 Old_age Always - 0
11 Calibration_Retry_Count 0x0032 100 253 000 Old_age Always - 0
12 Power_Cycle_Count 0x0032 100 100 000 Old_age Always - 58
192 Power-Off_Retract_Count 0x0032 200 200 000 Old_age Always - 52
193 Load_Cycle_Count 0x0032 196 196 000 Old_age Always - 12286
194 Temperature_Celsius 0x0022 116 108 000 Old_age Always - 36
196 Reallocated_Event_Count 0x0032 200 200 000 Old_age Always - 0
197 Current_Pending_Sector 0x0032 200 200 000 Old_age Always - 0
198 Offline_Uncorrectable 0x0030 200 200 000 Old_age Offline - 0
199 UDMA_CRC_Error_Count 0x0032 200 200 000 Old_age Always - 0
200 Multi_Zone_Error_Rate 0x0008 200 200 000 Old_age Offline - 0

SMART Self-test log structure revision number 1
Num Test_Description Status Remaining LifeTime(hours) LBA_of_first_error
# 1 Short offline Completed without error 00% 1424 -
# 2 Short offline Completed without error 00% 44 -
# 3 Short offline Aborted by host 50% 44 -


Intel Core i7 2600K CPU
MSI P67A-G45 Mobo
2x4GB Corsair Vengance RAM
Sapphire Raedon 4890HD Vapor-X GPU
1x180 GB Intel 330 SSD
1x80GB Intel X25-M G2 SSD
2x1TB Western Digital HDDs
2x2TB Wester Digital HDDS
Corsair HX520W PSU
Thermaltake Mozart TX Case
Xplorer4x4
Registered Member
Posts
199
Karma
0
OS

Re: Hard Drive Disappears

Thu Jan 10, 2013 5:41 am
xplorer4x4@xplorer4x4-MS-7673:~$ sudo fsck.ext4 -v /dev/sda1
e2fsck 1.42.5 (29-Jul-2012)
Music3TB: clean, 499/183148544 files, 12093273/732566272 blocks


Intel Core i7 2600K CPU
MSI P67A-G45 Mobo
2x4GB Corsair Vengance RAM
Sapphire Raedon 4890HD Vapor-X GPU
1x180 GB Intel 330 SSD
1x80GB Intel X25-M G2 SSD
2x1TB Western Digital HDDs
2x2TB Wester Digital HDDS
Corsair HX520W PSU
Thermaltake Mozart TX Case
User avatar bcooksley
Administrator
Posts
18607
Karma
83
OS

Re: Hard Drive Disappears

Thu Feb 07, 2013 9:48 am
The only other thing to check is that the drive is getting sufficient power from the PSU - checking another line and cable (if modular), or another power supply if possible should be able to rule this out however.


System Settings and Device Actions KCM maintainer
Image

 
Reply to topic

Bookmarks



Who is online

Registered users: alake, Baidu [Spider], bcooksley, Bing [Bot], cylverbak, Exabot [Bot], garthecho, Google [Bot], ken300, koriun, lazyit, Majestic-12 [Bot], Naproxeno, nezumi, normcross, Sogou [Bot], valoriez, vascobasque, whatthefunk, Yahoo [Bot]