Reply to topic

Partitions aren't automounted

murrayheck
Registered Member
Posts
8
Karma
0

Partitions aren't automounted

Tue Feb 19, 2013 3:07 pm
Hello

I'd like to give non-power users USB keydrives with the light Slackware-based Slax distro, so that they can work even if their Windows host isn't available. Slax uses KDE 4 as its desktop.

I'd like to have Linux/KDE automount all the partitions on all the available mass storage devices, so that users don't have to learn how to mount partitions themselves.

However, even with the options checked in KDE's System Settings > Hardware > Removable Devices, the partitions aren't automounted:

  • CHECKED Enable automatic mounting of removable media
  • CHECKED Mount all removable media at login
  • CHECKED Automatically mount removable media when attached
  • CHECKED (for all partitions) Automount on Login + Automount on Attach

FWIW, I can manually mount the partitions.

Has someone experienced the same issue and knows how to solve it?

Thank you.
User avatar bcooksley
Administrator
Posts
18669
Karma
83
OS

Re: Partitions aren't automounted

Wed Feb 20, 2013 2:14 am
Can you please make sure that "Removable Device Automounter" is checked in System Settings > Startup & Shutdown > Service Manager?
Also, is your system using HAL / UDisks / UDisks2? One of those is required in order for KDE to be able to enumerate and mount devices such as removable media.


System Settings and Device Actions KCM maintainer
Image
murrayheck
Registered Member
Posts
8
Karma
0

Re: Partitions aren't automounted

Wed Feb 20, 2013 11:25 am
Thanks for the help.

Yes, "Removable Device Automounter" is checked by default.

I didn't know what "HAL / UDisks / UDisks2" were, so googled for it. Apparently, they're three solutions to detect hardware. I don't know what Slax uses.

How could I investigate why KDE isn't automounting the partitions?

Code: Select all
root@slax:~# fdisk -l

Disk /dev/sda: 320.1 GB, 320072933376 bytes
255 heads, 63 sectors/track, 38913 cylinders, total 625142448 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x000dde89

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *        2048   102402047    51200000   83  Linux
/dev/sda2       309694464   561821695   126063616   83  Linux
/dev/sda3       617334858   625142447     3903795   82  Linux swap

root@slax:~# mount
aufs on / type aufs (rw,relatime,si=ed07e574)
proc on /proc type proc (rw)
sysfs on /sys type sysfs (rw)
tmpfs on /dev/shm type tmpfs (rw)
murrayheck
Registered Member
Posts
8
Karma
0

Re: Partitions aren't automounted

Wed Feb 20, 2013 11:45 am
Maybe it uses other apps as well, but it includes udisks:

Code: Select all
root@slax:~# udisks --enumerate

(udisks:2242): udisks-WARNING **: Couldn't enumerate devices: The name org.freedesktop.UDisks was not provided by any .service files

root@slax:~# udisks --dump

(udisks:2243): udisks-WARNING **: Couldn't enumerate devices: The name org.freedesktop.UDisks was not provided by any .service files
User avatar bcooksley
Administrator
Posts
18669
Karma
83
OS

Re: Partitions aren't automounted

Wed Feb 20, 2013 10:44 pm
What is the output of the following command?
Code: Select all
solid-hardware list


System Settings and Device Actions KCM maintainer
Image
murrayheck
Registered Member
Posts
8
Karma
0

Re: Partitions aren't automounted

Fri Feb 22, 2013 2:54 pm
Here it is:

Code: Select all
QStringList Solid::Backends::UDisks::UDisksManager::allDevicesInternal()  error:  "org.freedesktop.DBus.Error.ServiceUnknown"
virtual QStringList Solid::Backends::UPower::UPowerManager::allDevices()  error:  "org.freedesktop.DBus.Error.ServiceUnknown"
udi = '/org/kde/solid/udev/sys/devices/LNXSYSTM:00/LNXCPU:00'
udi = '/org/kde/solid/udev/sys/devices/pci0000:00/0000:00:1a.7/usb1/1-2/1-2:1.0/video4linux/video0'
udi = '/org/kde/solid/udev/sys/devices/pci0000:00/0000:00:1b.0/sound/card0/adsp'
udi = '/org/kde/solid/udev/sys/devices/pci0000:00/0000:00:1b.0/sound/card0/audio'
udi = '/org/kde/solid/udev/sys/devices/pci0000:00/0000:00:1b.0/sound/card0/dsp'
udi = '/org/kde/solid/udev/sys/devices/pci0000:00/0000:00:1b.0/sound/card0/hwC0D0'
udi = '/org/kde/solid/udev/sys/devices/pci0000:00/0000:00:1b.0/sound/card0/hwC0D2'
udi = '/org/kde/solid/udev/sys/devices/pci0000:00/0000:00:1b.0/sound/card0/mixer'
udi = '/org/kde/solid/udev/sys/devices/pci0000:00/0000:00:1b.0/sound/card0/pcmC0D0c'
udi = '/org/kde/solid/udev/sys/devices/pci0000:00/0000:00:1b.0/sound/card0/pcmC0D0p'
udi = '/org/kde/solid/udev/sys/devices/pci0000:00/0000:00:1b.0/sound/card0/pcmC0D1p'
udi = '/org/kde/solid/udev/sys/devices/pci0000:00/0000:00:1b.0/sound/card0/pcmC0D3p'
udi = '/org/kde/solid/udev/sys/devices/pci0000:00/0000:00:1b.0/sound/card0/controlC0'
udi = '/org/kde/solid/udev/sys/devices/pci0000:00/0000:00:1c.2/0000:02:00.0/net/eth0'
udi = '/org/kde/solid/udev/sys/devices/platform/serial8250/tty/ttyS0'
udi = '/org/kde/solid/udev/sys/devices/platform/serial8250/tty/ttyS1'
udi = '/org/kde/solid/udev/sys/devices/platform/serial8250/tty/ttyS2'
udi = '/org/kde/solid/udev/sys/devices/platform/serial8250/tty/ttyS3'
udi = '/org/kde/solid/udev/sys/devices/virtual/net/lo'
udi = '/org/kde/solid/udev/sys/devices/virtual/sound/seq'
udi = '/org/kde/solid/udev/sys/devices/virtual/sound/sequencer'
udi = '/org/kde/solid/udev/sys/devices/virtual/sound/sequencer2'
udi = '/org/kde/solid/udev/sys/devices/virtual/sound/timer'
udi = '/org/freedesktop/UDisks'
udi = '/org/kde/fstab'
User avatar bcooksley
Administrator
Posts
18669
Karma
83
OS

Re: Partitions aren't automounted

Sat Feb 23, 2013 3:35 am
Code: Select all
QStringList Solid::Backends::UDisks::UDisksManager::allDevicesInternal()  error:  "org.freedesktop.DBus.Error.ServiceUnknown"
virtual QStringList Solid::Backends::UPower::UPowerManager::allDevices()  error:  "org.freedesktop.DBus.Error.ServiceUnknown"


This explains the issue - KDE is unable to contact UDisks and is therefore unable to enumerate or mount the disks. You need to ensure that UDisks is installed and being started either before KDE startup (for manual starting of UDisks) or during KDE startup (if using D-Bus automatic startup for UDisks).

If these machines are potentially laptops, you should also ensure that UPower is functional, otherwise information regarding the battery, as well as suspend and hibernate actions will be unavailable. It can be started in a similar manner to UDisks.


System Settings and Device Actions KCM maintainer
Image
murrayheck
Registered Member
Posts
8
Karma
0

Re: Partitions aren't automounted

Sat Feb 23, 2013 10:02 am
Thanks for the info. I'll investigate how to solve this.
murrayheck
Registered Member
Posts
8
Karma
0

Re: Partitions aren't automounted

Mon Mar 04, 2013 3:00 pm
No help so far.

Udisks is available:
Code: Select all
# which udisks
/usr/bin/udisks


But it can't find devices:
Code: Select all
# udisks --dump
(udisks:2501): udisks-WARNING **: Couldn't enumerate devices: The name org.freedesktop.UDisks was not provided by any .service files


How can make sure Udisks is launched before KDE? I assume KDE is not responsible for this, but it's up to Linux itself to take care of this?

Thank you.
User avatar bcooksley
Administrator
Posts
18669
Karma
83
OS

Re: Partitions aren't automounted

Tue Mar 05, 2013 8:01 am
Correct, it is up to the distribution itself to ensure that UDisks is launched either before KDE is started - or is able to start itself automatically (via D-Bus autolaunching).

I suggest checking with your distribution why either of the above two methods is not working.

On my system, the process "/usr/lib/udisks/udisks-daemon" runs the actual UDisks service...


System Settings and Device Actions KCM maintainer
Image
murrayheck
Registered Member
Posts
8
Karma
0

Re: Partitions aren't automounted

Tue Mar 12, 2013 2:42 pm
Thanks for the help.

When I launch the following manually...
Code: Select all
# /usr/libexec/polkitd &
# /usr/libexec/udisks-daemon &

... the KDE Dolphin filemanager automounts and grants me access to the two (ext4 and NTFS) partitions on the SATA drive ;D

Provided launching the above two daemons is all it takes for KDE to automount all the available partitions (from both fixed and removable devices), what is the recommended way to do this? By adding something in /etc/rc.d/ or somewhere in KDE when the user logs in?
User avatar bcooksley
Administrator
Posts
18669
Karma
83
OS

Re: Partitions aren't automounted

Wed Mar 13, 2013 7:26 am
Those two daemons should both be autolaunched by D-Bus when KDE requests their services I believe, so I do not know why they are not being automatically launched.

I suggest asking your distribution about this, they are probably not shipping the D-Bus automatic launch files for some reason.

In any instance, ensuring those processes are launched prior to the startup of KDE (for which /etc/init.d/ would work fine) should fix this issue.


System Settings and Device Actions KCM maintainer
Image
murrayheck
Registered Member
Posts
8
Karma
0

Re: Partitions aren't automounted

Wed Mar 13, 2013 10:03 am
Thank you. That clears things up. I'll go ask how to launch D-Bus automatic launch files.
User avatar bcooksley
Administrator
Posts
18669
Karma
83
OS

Re: Partitions aren't automounted

Thu Mar 14, 2013 8:01 am
On my system, I can find three files, named "org.freedesktop.PolicyKit1.service", "org.freedesktop.UDisks.service", "org.freedesktop.UPower.service" in /usr/share/dbus-1/system-services/ which contain the details necessary to trigger the automatic launching.

The org.freedesktop.UPower.service file has the following contents for instance:
Code: Select all
[D-BUS Service]
Name=org.freedesktop.UPower
Exec=/usr/lib/upower/upowerd
User=root


System Settings and Device Actions KCM maintainer
Image

 
Reply to topic

Bookmarks



Who is online

Registered users: alake, Baidu [Spider], Bing [Bot], bjoernbalazs, braystacey, Dimitrios, edmael, einar, Exabot [Bot], flotho, Google [Bot], google01103, ivan, Joif, ken300, maarten, Majestic-12 [Bot], mmistretta, nezumi, peje, rdong, SecretCode, skywolfblue, stephans, Steve T, TheraHedwig, tienhung, Yahoo [Bot]