Reply to topic

Bluetooth problem

User avatar mauricioandresg
Registered Member
Posts
9
Karma
0
OS

Bluetooth problem

Tue Mar 19, 2013 4:32 am
Hello to the community, I have a problem with my bluetooth on my Acer V5-571p using Kubuntu 12.10

The problem is that even that KDE shows my bluetooth and I can turn it on or off, is useless because other devices can't discover my notebook, also I can't discover any devices.

I really use bluetooth, and I want to use it on Kubuntu, any ideas?

lsusb prompt:
mauricio@mauricio-Aspire-V5-571P:~$ lsusb
Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 003 Device 002: ID 152d:2339 JMicron Technology Corp. / JMicron USA Technology Corp. JM20339 SATA Bridge
Bus 003 Device 003: ID 04f3:0023 Elan Microelectronics Corp.
Bus 003 Device 004: ID 064e:e330 Suyin Corp.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 003: ID 046d:c52b Logitech, Inc. Unifying Receiver
Bus 001 Device 004: ID 04ca:3006 Lite-On Technology Corp.



hcitool dev prompt:
mauricio@mauricio-Aspire-V5-571P:~$ hcitool dev
Devices:
hci0 20:68:9D:DB:22:71


Specs:

KDE 4.9.5
Linux kernel 3.5.0-17 (because my webcam doesn't work on newest kernels)
Kubuntu 12.10
User avatar mauricioandresg
Registered Member
Posts
9
Karma
0
OS

Re: Bluetooth problem

Wed Mar 20, 2013 5:08 am
No body can help?

Sereusly...is this a community?
User avatar bcooksley
Administrator
Posts
18586
Karma
83
OS

Re: Bluetooth problem

Wed Mar 20, 2013 5:57 am
Please be patient, it may take a little while to reply in some instances.

If you right click on the Bluetooth menu item presented by KDE in the System Tray, is "Discoverable" checked?
Also, does running the following return any results with discoverable devices in the vicinity?
Code: Select all
hcitool scan


System Settings and Device Actions KCM maintainer
Image
User avatar mauricioandresg
Registered Member
Posts
9
Karma
0
OS

Re: Bluetooth problem

Wed Mar 20, 2013 1:59 pm
bcooksley wrote:Please be patient, it may take a little while to reply in some instances.

If you right click on the Bluetooth menu item presented by KDE in the System Tray, is "Discoverable" checked?
Also, does running the following return any results with discoverable devices in the vicinity?
Code: Select all
hcitool scan


Yes is visible, I tried what you said and thi is the result:

Code: Select all
hcitool scan
Scanning ...

then nothing happens :-\
User avatar bcooksley
Administrator
Posts
18586
Karma
83
OS

Re: Bluetooth problem

Fri Mar 22, 2013 9:28 am
This means that the underlying Bluetooth stack in Linux cannot discover any devices. Assuming you have discoverable devices in range, this means that your system is having trouble operating the bluetooth adapter.

Can you please check the out the output of "dmesg" to see if anything relating to bluetooth is mentioned? Messages relating to firmware are particularly relevant.


System Settings and Device Actions KCM maintainer
Image
User avatar mauricioandresg
Registered Member
Posts
9
Karma
0
OS

Re: Bluetooth problem  Topic is solved

Wed Mar 27, 2013 10:34 pm
bcooksley wrote:This means that the underlying Bluetooth stack in Linux cannot discover any devices. Assuming you have discoverable devices in range, this means that your system is having trouble operating the bluetooth adapter.

Can you please check the out the output of "dmesg" to see if anything relating to bluetooth is mentioned? Messages relating to firmware are particularly relevant.

I'm sorry for the late reply, for the moment I can't use Linux any more, since my external hard drive died and my laptop has the UEFI system, so I can't boot Linux safelty

Thanks for the help anyway, you can close this topic.
User avatar bcooksley
Administrator
Posts
18586
Karma
83
OS

Re: Bluetooth problem

Fri Mar 29, 2013 8:37 am
Sad to hear that, i've marked this as solved for now.


System Settings and Device Actions KCM maintainer
Image

 
Reply to topic

Bookmarks



Who is online

Registered users: Alexa [Bot], Baidu [Spider], Bing [Bot], claydoh, Exabot [Bot], Google [Bot], koriun, Majestic-12 [Bot], mmistretta, MSNbot Media, scummos, Wiz, Yahoo [Bot]