Reply to topic

kate lost default highligth syntax

herve
Registered Member
Posts
7
Karma
0
OS

kate lost default highligth syntax

Fri Apr 05, 2013 7:40 pm
Hi,
Today my Kubuntu 12.04 restart after a crash of my system, and at this time, kate was open. After restartint the PC. Kate lost default highligth syntax. for exemple when i write a javascript code the syntax '<script' is not in black like since or html tag lost its color.
I reinstall kate but nothing change. i purge with apt-get purge kate and reinstall it, i found the solution. i install kwrite which is not on mys computer. But i has also the same behavior. I don't understand.
Can you help me to com back the default highligth syntax ?
User avatar bcooksley
Administrator
Posts
18669
Karma
83
OS
Does this work under a new user?
I'm suspecting corruption in your user Kate configuration (which is easy enough to fix if this is the case).


System Settings and Device Actions KCM maintainer
Image
herve
Registered Member
Posts
7
Karma
0
OS
i try it with an other the user but it is the same bug. I put an exemple here. html tag lost its black bold color http://sv.edorh.com/capture.png
User avatar bcooksley
Administrator
Posts
18669
Karma
83
OS
The syntax files for highlighting, etc. are provided by 'katepart' and so therefore may not be in the 'kate' package itself. Can you check to see which package provides /usr/share/kde4/apps/katepart/syntax/html.xml and reinstall it?


System Settings and Device Actions KCM maintainer
Image
herve
Registered Member
Posts
7
Karma
0
OS
i have done it since yesterday. i replace my syntax folder with another katepart syntax folder of another distribution of linux. But nothing change
User avatar bcooksley
Administrator
Posts
18669
Karma
83
OS
Does this occur with other HTML files?


System Settings and Device Actions KCM maintainer
Image
herve
Registered Member
Posts
7
Karma
0
OS
yes all file lost here hightlight syntax, when i use javascript file for exemple, "<script" tag which will be normaly in black bold is normal. All file i use lost a part of highlight syntax. It is not the file the problem. Kate is the problem, there is a way of remove completely, i use apt-get purge kate, but nothing happened. I very like kate, but if i don't find a solution quickly i will use other editor
User avatar bcooksley
Administrator
Posts
18669
Karma
83
OS
Javascript files don't have <script> tags, HTML files do.
In any case, have you tried reinstalling "katepart" (if it is a separate package, it may not be) and "kwrite"?
You might also want to try reinstalling "kdelibs5" and it's associated -data / -doc / etc packages.

As another consideration - have you tried opening other HTML / Javascript files which were not open at the time, and which are located elsewhere on your system?


System Settings and Device Actions KCM maintainer
Image
dhaumann
Registered Member
Posts
4
Karma
0
Maybe you have the wrong highlighting enabled? What does Tools > Highlighting say?

 
Reply to topic

Bookmarks



Who is online

Registered users: Alastair, apater, Baidu [Spider], Bing [Bot], Exabot [Bot], garthecho, ggael, Google [Bot], google01103, Horus, jitseniesen, Joif, kde-jriddell, ken300, La Ninje, Mamarok, mmistretta, Nuc!eoN, psbot [Picsearch], rbruce, renatoatilio, sacarde, sinclair, stephans, TheraHedwig, tienhung, wolfi323, Yahoo [Bot]