Reply to topic

How to mount Samba Share?

User avatar fakd
Registered Member
Posts
176
Karma
0
OS

How to mount Samba Share?

Tue May 07, 2013 12:07 pm
Hello,
I have a NAS here which (unfortunately) provides the folder only the window way, i.e. as samba share under linux.

So when I want to work with them from KDE, support isn't so good. For instance you can't see thumbnails in dolphin on samba shares and I couldn't upload stuff from there (e.g. you are on a website, then it says upload pic or whatever and you choose file, then it doesn't work from smb).
From Windows I also know there are some limitations (not those from KDE, tho :-\ ) and you could avoid them by mounting the network folder as a network drive. Which was really simple.

So how do I do this in KDE? If I go on network, there is a link to "Add network drive" with support for DAV and other stuff, but not smb. I have a path like this:
smb://myNAS/folder1/folder2...
Where / how can I add this from the GUI?
User avatar bcooksley
Administrator
Posts
18592
Karma
83
OS

Re: How to mount Samba Share?

Wed May 08, 2013 9:40 am
If you are using a web browser which uses KDE technology, such as Rekonq or Konqueror, then you should be able to upload files from Samba shares (accessed via smb://) without problems. Firefox and Chrome will not support this however.

In regards to thumbnails, these are disabled on slow disks and above certain sizes on network shares to improve performance, as generating them involves a high amount of disk/network traffic. You can try increasing the remote file size maximum limit in Dolphin > Settings > Configure Dolphin > General > Previews.

In regards to mounting into the file system, you need to use distribution tools to do this I'm afraid. KDE does not support mounting shares into the system itself at this time.


System Settings and Device Actions KCM maintainer
Image
User avatar fakd
Registered Member
Posts
176
Karma
0
OS

Re: How to mount Samba Share?

Fri May 10, 2013 2:31 pm
bcooksley wrote:If you are using a web browser which uses KDE technology, such as Rekonq or Konqueror, then you should be able to upload files from Samba shares (accessed via smb://) without problems. Firefox and Chrome will not support this however.
I use Qupzilla (Qt based) and it doesn't work either.

bcooksley wrote:In regards to mounting into the file system, you need to use distribution tools to do this I'm afraid. KDE does not support mounting shares into the system itself at this time.
There is no such tool in my distro, how do I do this from CL?
wolfi323
Registered Member
Posts
230
Karma
0
OS

Re: How to mount Samba Share?

Fri May 10, 2013 6:42 pm
fakd wrote:
bcooksley wrote:In regards to mounting into the file system, you need to use distribution tools to do this I'm afraid. KDE does not support mounting shares into the system itself at this time.
There is no such tool in my distro, how do I do this from CL?

On CLI you would use "mount".
But there is a graphical tool available which can browse shares and even mount them: smb4k
See http://chakra-linux.org/packages/index. ... pkg.tar.xz
User avatar fakd
Registered Member
Posts
176
Karma
0
OS

Re: How to mount Samba Share?

Sat May 11, 2013 7:00 pm
wolfi323 wrote:On CLI you would use "mount".
And how? Tried with:
"sudo mount smb://server/folder1/ name1"
mount: mount point name1 does not exist ... ?

wolfi323 wrote:But there is a graphical tool available which can browse shares and even mount them: smb4k
See http://chakra-linux.org/packages/index. ... pkg.tar.xz
Do you use it? It doesn't work here at all (several errors)... :(
wolfi323
Registered Member
Posts
230
Karma
0
OS

Re: How to mount Samba Share?

Sat May 11, 2013 10:42 pm
fakd wrote:
wolfi323 wrote:On CLI you would use "mount".
And how? Tried with:
"sudo mount smb://server/folder1/ name1"
mount: mount point name1 does not exist ... ?

Well, name1 should be a directory that already exists. If not, create it first.
And you don't need the 'smb:'. This should do:
Code: Select all
sudo mount //server/folder1 name1

The share's content is then accessible in the directory name1.

wolfi323 wrote:But there is a graphical tool available which can browse shares and even mount them: smb4k
See http://chakra-linux.org/packages/index. ... pkg.tar.xz
Do you use it? It doesn't work here at all (several errors)... :(

Yes I do use it without problems. But I'm running openSUSE.
What errors do you get?
User avatar fakd
Registered Member
Posts
176
Karma
0
OS

Re: How to mount Samba Share?

Sun May 12, 2013 7:36 pm
wolfi323 wrote:Well, name1 should be a directory that already exists. If not, create it first.
And you don't need the 'smb:'. This should do:
Code: Select all
sudo mount //server/folder1 name1

The share's content is then accessible in the directory name1.
Thank you, but it doesn't work yet:
"sudo mount //LINKSTATION/downloads /home/richard/smb4k/LINKSTATION/downloads/
Password for root@//LINKSTATION/downloads:
mount error(13): Permission denied
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)"
1. I have no pw's set on LINKSTATION, anyone can read and write on any shared folder.
2. If I just hit enter it doesn't work.
3. Even if I enter the root pw (which I use to access the admin web-interface), it still doesn't work.


wolfi323 wrote:[smb4k] ...What errors do you get?
First direct on start:
"Retrieving the list of available domains failed:
Can't load /etc/samba/smb.conf - run testparm to debug it" I get this message three times.
Then in tab "Network Neighborhood", I can browse to my NAS, but I can't browse IT. I.e. I can't see the shared folders - no errors thou.
When I search for the shares in the tab "Network Search" I can find all of them, however mounting fails:
"Mounting the share //LINKSTATION/downloads failed:
Unable to find suitable address."

Notice:
I don't have set any passwords on my NAS, anyone can read and write. Also I don't have any problems to access it with dolphin on KDE or on Windows with Explorer.
wolfi323
Registered Member
Posts
230
Karma
0
OS

Re: How to mount Samba Share?

Sun May 12, 2013 9:19 pm
Both works just fine here.
fakd wrote:Thank you, but it doesn't work yet:
"sudo mount //LINKSTATION/downloads /home/richard/smb4k/LINKSTATION/downloads/
Password for root@//LINKSTATION/downloads:
mount error(13): Permission denied
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)"

Ok, could be caused by the fact that because of "sudo" the username "root" is used to mount the share.
You could try to specify another username:
Code: Select all
sudo mount -o username=richard //LINKSTATION/downloads /home/richard/smb4k/LINKSTATION/downloads/


First direct on start:
"Retrieving the list of available domains failed:
Can't load /etc/samba/smb.conf - run testparm to debug it" I get this message three times.
There seem to be errors in your /etc/samba/smb.conf. But I guess this can be ignored if you can browse to your NAS.

Then in tab "Network Neighborhood", I can browse to my NAS, but I can't browse IT. I.e. I can't see the shared folders - no errors thou.
When I search for the shares in the tab "Network Search" I can find all of them, however mounting fails:
"Mounting the share //LINKSTATION/downloads failed:
Unable to find suitable address."
Maybe this has the same cause? You could try to activate "Settings"->"Configure Smb4K..."->"Authentication"->"Use a default login" and specify your username.

And can you preview the share? (right-click on it and select "Preview" in the context menu)
User avatar fakd
Registered Member
Posts
176
Karma
0
OS

Re: How to mount Samba Share?

Mon May 13, 2013 9:27 am
wolfi323 wrote:Ok, could be caused by the fact that because of "sudo" the username "root" is used to mount the share.
You could try to specify another username:
Code: Select all
sudo mount -o username=richard //LINKSTATION/downloads /home/richard/smb4k/LINKSTATION/downloads/
Ahh, thanks a lot this works flawlessly!

wolfi323 wrote:
Then in tab "Network Neighborhood", I can browse to my NAS, but I can't browse IT. I.e. I can't see the shared folders - no errors thou.
When I search for the shares in the tab "Network Search" I can find all of them, however mounting fails:
"Mounting the share //LINKSTATION/downloads failed:
Unable to find suitable address."
Maybe this has the same cause? You could try to activate "Settings"->"Configure Smb4K..."->"Authentication"->"Use a default login" and specify your username.
Well, I'm not running it as sudo/root. However I tried, but it didn't change.

wolfi323 wrote:And can you preview the share? (right-click on it and select "Preview" in the context menu)
No, its greyed out.
wolfi323
Registered Member
Posts
230
Karma
0
OS

Re: How to mount Samba Share?

Mon May 13, 2013 6:43 pm
fakd wrote:
wolfi323 wrote:Ok, could be caused by the fact that because of "sudo" the username "root" is used to mount the share.
You could try to specify another username:
Code: Select all
sudo mount -o username=richard //LINKSTATION/downloads /home/richard/smb4k/LINKSTATION/downloads/
Ahh, thanks a lot this works flawlessly!

Good! :)

fakd wrote:
wolfi323 wrote:
Then in tab "Network Neighborhood", I can browse to my NAS, but I can't browse IT. I.e. I can't see the shared folders - no errors thou.
When I search for the shares in the tab "Network Search" I can find all of them, however mounting fails:
"Mounting the share //LINKSTATION/downloads failed:
Unable to find suitable address."
Maybe this has the same cause? You could try to activate "Settings"->"Configure Smb4K..."->"Authentication"->"Use a default login" and specify your username.
Well, I'm not running it as sudo/root. However I tried, but it didn't change.

No, but smb4k has to use sudo or similar to mount it, too... (only root can mount things that are not specified in fstab with the "user" mount option)
So I really think it is the same problem, esp. as "mount" works if you specify a username.

Well, I'm not sure what you could try then, because I don't have this problem.
Maybe try to authenticate first by right clicking on the host and choosing "Authentication...", enter "richard" as username and then select "Scan Computer"...

fakd wrote:
wolfi323 wrote:And can you preview the share? (right-click on it and select "Preview" in the context menu)
No, its greyed out.

It's greyed out when you are right-clicking on the host, that's normal. But it should be selectable when you right-click on a share. Sorry, I forgot that you don't see any shares... 8)

 
Reply to topic

Bookmarks



Who is online

Registered users: Alexa [Bot], apater, Baidu [Spider], bcooksley, Bing [Bot], eagleton, Exabot [Bot], Google [Bot], google01103, GreatEmerald, hmethorst, khsien, koriun, La Ninje, lazyit, Majestic-12 [Bot], SecretCode, Sentynel, Steve T, urgo, Yahoo [Bot]

cron