Reply to topic

start a konsole with a command at startup

contremaitre
Registered Member
Posts
34
Karma
0
Hi,

I created a script which start a new konsole and launch a command, like this :
Code: Select all
#!/bin/sh
konsole -e command


It works fine, but when I add it to "systemsettings -> startup & shutdown -> autostart " it won't start my konsole.
Why ?

Thanks.
User avatar bcooksley
Administrator
Posts
18582
Karma
83
OS
Which phase / type of startup are you using there?


System Settings and Device Actions KCM maintainer
Image
contremaitre
Registered Member
Posts
34
Karma
0
Not sure in english because I have it in french.
There is two stections : scripts and applications.
I tried both.

But I solved my issue. I have to add the "--noclose" option to konsole.
Don't know why it works without it when I start it directly by clicking on my script, but not when it's in the kde startup applications.
User avatar bcooksley
Administrator
Posts
18582
Karma
83
OS
Thanks for posting the solution. One possibility is that invoking Konsole from within Konsole automatically implies the --noclose option.


System Settings and Device Actions KCM maintainer
Image

 
Reply to topic

Bookmarks



Who is online

Registered users: alake, Alexa [Bot], Baidu [Spider], Bing [Bot], blue_bullet, chicken2jail, claydoh, colomar, Exabot [Bot], garthecho, ghevan, Google [Bot], google01103, Hans, inhiway, kainz.a, koriun, La Ninje, lazyit, Majestic-12 [Bot], mmistretta, nezumi, pedrorodriguez, private_lock, robinh, scummos, Tuukka, urgo, Uri_Herrera, wolfi323, Yahoo [Bot]