Reply to topic

0.6.80 empty contact list...

sinclair
Registered Member
Posts
158
Karma
0
OS

0.6.80 empty contact list...

Wed Sep 25, 2013 4:52 am
Using 0.6.80 from the daily ppa on Kubuntu. It was installed this morning and after a reboot I get a very very empty contact list...

though the plasmoid / widget works so I can see my contacts, just not in the Contact List.. KPeople was installed, I am not sure if that is the problem as I dont think my system uses it in any other application?

Regards
Sinclair
david_edmundson
KDE Developer
Posts
202
Karma
1
OS

Re: 0.6.80 empty contact list...

Wed Sep 25, 2013 2:59 pm
Thanks for telling us.

I've just checked in a virtual machine.
It's a packaging problem, where it misses some (crucial!) files. I've sent a patch to our Kubuntu packagers, we'll get a build sometime soon hopefully.
sinclair
Registered Member
Posts
158
Karma
0
OS

Re: 0.6.80 empty contact list...

Thu Sep 26, 2013 4:03 am
david_edmundson wrote:Thanks for telling us.

I've just checked in a virtual machine.
It's a packaging problem, where it misses some (crucial!) files. I've sent a patch to our Kubuntu packagers, we'll get a build sometime soon hopefully.


Thanks, sounds good! Until then I will work around it by using the desktop widget
david_edmundson
KDE Developer
Posts
202
Karma
1
OS

Re: 0.6.80 empty contact list...

Thu Sep 26, 2013 12:45 pm
Could you upgrade everything and try again.
jstephenson
Registered Member
Posts
4
Karma
0

Re: 0.6.80 empty contact list...

Fri Sep 27, 2013 12:48 am
I am having the same problem. everything is updated to the latest version from the telepathy daily ppa. ktp seems to sign on but contact list is blank. I compiled ktp-ssh-contacts and personviewer from git and I can see contacts in those for some reason, just not the regular contact list.
david_edmundson
KDE Developer
Posts
202
Karma
1
OS

Re: 0.6.80 empty contact list...

Fri Sep 27, 2013 12:59 am
Even IM presences in the personviewer?

Do you get people in the contact list when you show offline contacts?
jstephenson
Registered Member
Posts
4
Karma
0

Re: 0.6.80 empty contact list...

Fri Sep 27, 2013 1:18 am
david_edmundson wrote:Even IM presences in the personviewer?

Do you get people in the contact list when you show offline contacts?


Personviewer as far as I can tell, it (at least the version I cloned and compiled from git anyway) seems pretty barebones at this time. Two panes, left pane is the list of contacts with a search box at the bottom, right pane shows only the name and picture of a highlighted contact and not much else. There is an status indicator next to each name when it is highlighted in the right pane, but none of them show as being online.

and no, enabling "show offline contacts" doesn't make any different in the main conatact list, still blank.
david_edmundson
KDE Developer
Posts
202
Karma
1
OS

Re: 0.6.80 empty contact list...

Fri Sep 27, 2013 1:28 am
Could be that it's showing akonadi contacts in personviewer, and KTp contacts aren't being fed in.

Do you have nepomukshell?
If so can you go to query and type this:

"select ?uri where {?uri a nco:PersonContact. ?uri nco:hasIMAccount ?imAccount}"

or if nepomukcmd (http://techbase.kde.org/Development/Tut ... sAndTricks)

nepomukcmd query "select ?uri where {?uri a nco:PersonContact. ?uri nco:hasIMAccount ?imAccount}"
jstephenson
Registered Member
Posts
4
Karma
0

Re: 0.6.80 empty contact list...

Fri Sep 27, 2013 1:55 am
david_edmundson wrote:Could be that it's showing akonadi contacts in personviewer, and KTp contacts aren't being fed in.

Do you have nepomukshell?
If so can you go to query and type this:

"select ?uri where {?uri a nco:PersonContact. ?uri nco:hasIMAccount ?imAccount}"

or if nepomukcmd (http://techbase.kde.org/Development/Tut ... sAndTricks)

nepomukcmd query "select ?uri where {?uri a nco:PersonContact. ?uri nco:hasIMAccount ?imAccount}"



I'm getting zero results both ways. So is possible that my particular problem is just needing to get my contact info in a nepomuk ready form? If so, how?
david_edmundson
KDE Developer
Posts
202
Karma
1
OS

Re: 0.6.80 empty contact list...

Fri Sep 27, 2013 2:05 am
We ship a Nepomuk plugin (nepomuktelepathyservice) that takes all your contacts and feeds them into nepomuk.

It appears in "ps aux" as
nepomukservicestub nepomuktelepathyservice
Is it listed?


It must think it's started running, otherwise the contact list would fall back to legacy mode.

Could you try invoking it manually:
run nepomukservicestub nepomuktelepathyservice

It should be part of libktpcommoninternalsprivate6 (or some silly name like that) which is from the source package ktp-common-internals.

Thanks for the debugging help so far.
sinclair
Registered Member
Posts
158
Karma
0
OS

Re: 0.6.80 empty contact list...

Fri Sep 27, 2013 6:47 am
was offline yesterday, I now see that others are also having this issue.

when I grep for nepomuk I see no "telepathy" service. How can I start it, I have no nepomukshell, whatever that is
sinclair
Registered Member
Posts
158
Karma
0
OS

Re: 0.6.80 empty contact list...

Fri Sep 27, 2013 6:51 am
sinclair wrote:was offline yesterday, I now see that others are also having this issue.

when I grep for nepomuk I see no "telepathy" service. How can I start it, I have no nepomukshell, whatever that is


I should maybe say that command "run nepomukservice..." just gives me suggestions of varieties of run that I might install
david_edmundson
KDE Developer
Posts
202
Karma
1
OS

Re: 0.6.80 empty contact list...

Fri Sep 27, 2013 8:15 am
sorry, my fault. Ignore the "run" just:

Code: Select all
nepomukservicestub nepomuktelepathyservice
sinclair
Registered Member
Posts
158
Karma
0
OS

Re: 0.6.80 empty contact list...

Fri Sep 27, 2013 2:38 pm
david_edmundson wrote:sorry, my fault. Ignore the "run" just:

Code: Select all
nepomukservicestub nepomuktelepathyservice


tells me the service is running but the contact list is still as empty as ever. The plasmoid/widget still working though
jstephenson
Registered Member
Posts
4
Karma
0

Re: 0.6.80 empty contact list...

Fri Sep 27, 2013 7:28 pm
sinclair wrote:
david_edmundson wrote:sorry, my fault. Ignore the "run" just:

Code: Select all
nepomukservicestub nepomuktelepathyservice


tells me the service is running but the contact list is still as empty as ever. The plasmoid/widget still working though


same here. its says the service is running but it clearly isn't working.

 
Reply to topic

Bookmarks



Who is online

Registered users: Alexa [Bot], asevens, Baidu [Spider], Bing [Bot], binro, brand, doublerainbow64, Exabot [Bot], Google [Bot], google01103, inksi, jgrulich, koriun, lazyit, Majestic-12 [Bot], metzman, MSNbot Media, Murz, random_fan, rfinley, Sentynel, toad, Vindex17, whatthefunk, Yahoo [Bot], yurchor, zhou13