Reply to topic

Opening a magnet link is staying in the tray notifications

User avatar latebeat
Registered Member
Posts
70
Karma
0
Hi guys,

I'm having this issue with magnet links and ktorrent. When I click to open a magnet link it does open in ktorrent however, the tray notification keeps spinning forever. It will not timeout and will keep spinning until I click to open it and then click stop.
How can I prevent this from happening?
Also as a side note, before ktorrent I was using qbittorent and this was not an issue. Magnet links would open right away, I would get a notification at the tray and it would stop/timeout right away while in ktorrent no matter how long I leave it, it will be spinning in the notification circle forever


thank you
User avatar bcooksley
Administrator
Posts
18669
Karma
83
OS
Which application icon is shown as being responsible for this file job? (Plasma, KTorrent, etc)


System Settings and Device Actions KCM maintainer
Image
User avatar latebeat
Registered Member
Posts
70
Karma
0
bcooksley wrote:Which application icon is shown as being responsible for this file job? (Plasma, KTorrent, etc)


I'm not sure I undertand what you mean. The link is going opened in ktorrent. That part works fine. It's the kde notification icon in the panel that keeps spinning (not ktorrents icon).
User avatar bcooksley
Administrator
Posts
18669
Karma
83
OS
If you press the spinner in the system tray it should popup and display the name of the application and it's icon which should allow you to identify which application initiated this.


System Settings and Device Actions KCM maintainer
Image
User avatar latebeat
Registered Member
Posts
70
Karma
0
bcooksley wrote:If you press the spinner in the system tray it should popup and display the name of the application and it's icon which should allow you to identify which application initiated this.


Ok I just realized this is happening only with chrome. It's not happening with firefox.
So with firefox it skips the spinner and goes straight to ktorrent. With chrome for some reason a pop-up comes up saying examining job.
Then in the spinner it stays forever a notification saying File: manget://blablabla
There's no application icon. Just a question mark on the top left and a stop and pause on the right. The title is examining.
So in order for it to stop I need to go and press either the stop or the pause button and the spinner stops

thank you,
User avatar bcooksley
Administrator
Posts
18669
Karma
83
OS
When Chrome triggers this, is it still passed over to KTorrent correctly, or does that never happen?
I suspect Chrome itself may not be handling things properly here... or a bug in the XDG -> KDE -> KTorrent connection exists...


System Settings and Device Actions KCM maintainer
Image
User avatar latebeat
Registered Member
Posts
70
Karma
0
bcooksley wrote:When Chrome triggers this, is it still passed over to KTorrent correctly, or does that never happen?
I suspect Chrome itself may not be handling things properly here... or a bug in the XDG -> KDE -> KTorrent connection exists...


Yeah it's passed correctly to ktorrent.
I also checked and rekonq works fine too.
User avatar latebeat
Registered Member
Posts
70
Karma
0
latebeat wrote:
bcooksley wrote:When Chrome triggers this, is it still passed over to KTorrent correctly, or does that never happen?
I suspect Chrome itself may not be handling things properly here... or a bug in the XDG -> KDE -> KTorrent connection exists...


Yeah it's passed correctly to ktorrent.
I also checked and rekonq works fine too.


thanks for the help! I can't believe it didnt even occur to me to try a different browser!
User avatar bcooksley
Administrator
Posts
18669
Karma
83
OS
Okay, this is probably a interaction bug between Chrome and KDE/KTorrent then. Not sure how to debug that to determine where the fault actually lies however, so hard to file a bug (as one can't determine where it belongs).


System Settings and Device Actions KCM maintainer
Image
User avatar ronnoc
Registered Member
Posts
33
Karma
0
OS
Just updating this thread here a little. The issue with Chrome and KTorrent when clicking a magnet link still persists. Using Chrome 26, KTorrent 4.1.3, and KDE 4.10.2 (via Kubuntu 12.04). One related note that may help trace the cause; if KTorrent is already running the magnet link get passed correctly. However if it is not currently running, it will not start. In either scenario as stated earlier the KDE notification area will spin indefinitely with the "examining..." message as outlined above by the O.P.

Just a heads-up.


___________________
The Blue Mint
___________________

 
Reply to topic

Bookmarks



Who is online

Registered users: alake, Baidu [Spider], Bing [Bot], bjoernbalazs, braystacey, Dimitrios, edmael, einar, Exabot [Bot], flotho, Google [Bot], google01103, ivan, Joif, ken300, maarten, Majestic-12 [Bot], nezumi, peje, rdong, SecretCode, skywolfblue, stephans, Steve T, TheraHedwig, tienhung, Yahoo [Bot]