Reply to topic

Installing KTorrent 4.3 and libktorrent 1.3 on Ubuntu 12.04

dxk3355
Registered Member
Posts
5
Karma
0
I'm running a new Ubuntu 12.04 LTS machine that's my general file server. I previously installed Ubuntu's Ktorrent package which had version 4.1.3 and I want to upgrade to 4.3 because of stability issues that I'm seeing. My unix experience is hit or miss. I downloaded the tar packages from the Ktorrent front page and executed the mkdir for the build and got the following error. I did some google searches to see if there was a solution but I didn't understand what anyone else did to resolve this so far. It's obvious to me I need some type of library but beyond that I'm not sure which one. I ran apt-get build-dep ktorrent as well but that didn't affect anything.
Code: Select all
/libktorrent-1.3.0/src/build$ cmake -DCMAKE_INSTALL_PREFIX=$(kde4-config --prefix) ..
-- Found Qt-Version 4.8.1 (using /usr/bin/qmake)
-- Found X11: /usr/lib/i386-linux-gnu/libX11.so
-- Found KDE 4.8 include dir: /usr/include
-- Found KDE 4.8 library dir: /usr/lib
-- Found the KDE4 kconfig_compiler preprocessor: /usr/bin/kconfig_compiler
-- Found automoc4: /usr/bin/automoc4
CMake Error at /usr/share/kde4/apps/cmake/modules/FindPackageHandleStandardArgs.cmake:198 (MESSAGE):
  Could NOT find GMP (missing: GMP_INCLUDE_DIR GMP_LIBRARIES)
Call Stack (most recent call first):
  /usr/share/kde4/apps/cmake/modules/FindGMP.cmake:21 (FIND_PACKAGE_HANDLE_STANDARD_ARGS)
  CMakeLists.txt:5 (find_package)


-- Configuring incomplete, errors occurred!


Can someone provide a next step?
User avatar google01103
Manager
Posts
4956
Karma
17
OS
do you have gmp-dev installed?


OpenSuse 13.1 x64, KDE 4.12.x

Problem solved? Please click on Image below the post with the best answer to mark your topic as solved.
dxk3355
Registered Member
Posts
5
Karma
0
I don't even know how to check for that
User avatar google01103
Manager
Posts
4956
Karma
17
OS
how did install the Ktorrent package? the same tool should be able to search for packages and display if installed or not

you can do in Konsole: apt-get install gmp-dev

you need to familiarize yourself with package management in Mint, search their site for a tutorial. this looks helpful http://helpsite.org/install-software-in-linux/


OpenSuse 13.1 x64, KDE 4.12.x

Problem solved? Please click on Image below the post with the best answer to mark your topic as solved.
dxk3355
Registered Member
Posts
5
Karma
0
libgmp-dev was already installed so that didn't solve the issue

Code: Select all
~/libktorrent-1.3.0/src/build$ sudo apt-get install libgmp-dev
Reading package lists... Done
Building dependency tree       
Reading state information... Done
libgmp-dev is already the newest version.
The following packages were automatically installed and are no longer required:
  language-pack-zh-hans language-pack-kde-en linux-headers-3.2.0-29
  language-pack-kde-zh-hans language-pack-kde-en-base kde-l10n-engb
  linux-headers-3.2.0-29-generic-pae kde-l10n-zhcn language-pack-zh-hans-base
  language-pack-kde-zh-hans-base
Use 'apt-get autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 14 not upgraded.
User avatar bcooksley
Administrator
Posts
18556
Karma
83
OS
Have you tried using "apt-get build-dep" to install the dependencies which apt-get knows about for KTorrent? This may make your task a little easier here...


System Settings and Device Actions KCM maintainer
Image
dxk3355
Registered Member
Posts
5
Karma
0
Yes, it was in my first post
I ran apt-get build-dep ktorrent as well but that didn't affect anything.
. I later ran it for libtorrent to see if that would add anything.
User avatar google01103
Manager
Posts
4956
Karma
17
OS
Sometime there are others with the same need who have already done this kind of thing and Googling or searching/posting on the distro's forum may provide instructions or a package in a private ppa, in your case see https://launchpad.net/~alexey-ivanov/+archive/ktorrent

note: as private ppa's are not official *buntu's there may (or not) be risks in their use


OpenSuse 13.1 x64, KDE 4.12.x

Problem solved? Please click on Image below the post with the best answer to mark your topic as solved.
stoeptegel
Registered Member
Posts
1074
Karma
0
If you still want to compile, try
http://ktorrent.org/wiki/index.php/FAQ# ... Torrent.3F
, and see how far you get.
Be aware, a lot of trackers do have black and whitelists for versions of BitTorrent clients. And because this version is a non-released version yet, it might be banned for using it there.

Otherwise add the repo with, i think it was:
sudo add-apt-repository ppa:alexey-ivanov/ktorrent
sudo apt-get update
sudo apt-get upgrade

 
Reply to topic

Bookmarks



Who is online

Registered users: Andreas Mair, Baidu [Spider], Bing [Bot], capslock, einar, Exabot [Bot], Google [Bot], Hans, koriun, Majestic-12 [Bot], rainbowgoblin, raymondsarver, rulet111, tparrott, urgo, Uri_Herrera, Yahoo [Bot]