Reply to topic

New Wintab Support

User avatar nezumi
Registered Member
Posts
210
Karma
0
OS

Re: New Wintab Support

Tue Oct 01, 2013 5:09 pm
First of all - do you want me to actually REPORT all the bugs I saw or mentioning it here is enough?

- On wacom intuos 3 menu with favorite brushes that should appear on "right click" it does on button set to "middle click". On a mouse though it appears on RMB as it should.

- My previouse brushes tags are there but just listed - everything is melted together, showing up all brushes. Like Artmessiah said - this is really annoying and real drawback. Specially when now icons are standarized and I have no clue what was originally with Krita and what I added from David for example. It really shouldnt loose it to make that option usable.

- OpenGL isnt working. I descibed it in detail on separate thread on subject.

- using filters in latest build krita_x64_2.7.8.20 is NOT giving me any problems.
User avatar PixelSprite
Registered Member
Posts
37
Karma
0
OS

Re: New Wintab Support

Tue Oct 01, 2013 5:17 pm
With 2.7.8.20, I can confirm the problem with importing layers. Presses made in the explorer are registered on the canvas and it crashes Krita anyway. I also tested some filters and noted that it was filters with dialog options that crashed Krita and, even then, only if pressure sensitivity had been used. When I used my trackpad to scratch something out to test, things worked fine until I made a stroke with a stylus. The next filter crashed Krita. Filters such as invert and desaturate that don't have further options work regardless.

I also noticed that the pop-up menu's gone back to existing only when the right-mouse button is held. No problems with OpenGL here. Lastly, the canvas seems to default to wraparound mode (but without infinite tiling) before the 'w' key is ever pressed and reverts to normal after the wraparound tool has been properly started and stopped.

Hopefully, this is helpful to you.
User avatar boudewijn
KDE Developer
Posts
1380
Karma
7
OS

Re: New Wintab Support

Tue Oct 01, 2013 5:32 pm
Just mention bugs here. I'm mostly just interested in bugs with tablet handling -- though other issues can be mentioned as well.
User avatar boudewijn
KDE Developer
Posts
1380
Karma
7
OS

Re: New Wintab Support

Tue Oct 01, 2013 5:33 pm
nezumi wrote:First of all - do you want me to actually REPORT all the bugs I saw or mentioning it here is enough?
- OpenGL isnt working. I descibed it in detail on separate thread on subject.

- using filters in latest build krita_x64_2.7.8.20 is NOT giving me any problems.


The opengl code didn't change at all... And the filters crash only happens when pressing the OK button with the tablet stylus.
User avatar nezumi
Registered Member
Posts
210
Karma
0
OS

Re: New Wintab Support

Tue Oct 01, 2013 6:43 pm
boudewijn wrote:The opengl code didn't change at all...

As much as I believe you - trust me it doesnt work ;)
Panz
Registered Member
Posts
15
Karma
0

Re: New Wintab Support

Tue Oct 01, 2013 10:09 pm
So i tried 2.7.8.20 on helix for a while,

opengl seems to be ok so far
filters crash if i hit the ok button with stylus, but haven't tested enough to be certain
minimizing krita, or running it alongside another program (eg chrome), causes the pc to be unresponsive and is propably restored after i put the stylus back in it's slot(maybe the wacom service stops, i don't know)
also had the canvas default in the wraparound mode, couldn't disable,

still the stylus button works as middle mouse button on canvas and right click on the rest of krita's interface

sometimes if i open helix and krita withoutt getting the stylus out, even though the stylus works fine afterwards, it won't work on the canvas (wacom tablet pc version 11-16, latest june version)
User avatar Zafio
Registered Member
Posts
11
Karma
0
OS

Re: New Wintab Support

Wed Oct 02, 2013 2:42 pm
While moving the save dialog, the brush keeps painting in the background:
Image
link

P.S.: Not sure if this is normal, but the open/save dialog window takes like 6 seconds to open.
Chris Jones
Registered Member
Posts
72
Karma
0

Re: New Wintab Support

Thu Oct 03, 2013 12:30 pm
I just hit Save As, and that sent it into one of its thrashing hard drive episodes, bringing the whole system to its knees for about 5 minutes before the save dialog opened.


User avatar boudewijn
KDE Developer
Posts
1380
Karma
7
OS

Re: New Wintab Support

Thu Oct 03, 2013 12:40 pm
The new solid backend code for discovering drives is actually supposed to prevent that from happening... Nothing changed in that code compared to the regular releases that we have on the download page. Does it happen with those as well?
Chris Jones
Registered Member
Posts
72
Karma
0

Re: New Wintab Support

Thu Oct 03, 2013 12:43 pm
Not when saving, as far as I can recall. I'll test again once I build up the nerve..


Chris Jones
Registered Member
Posts
72
Karma
0

Re: New Wintab Support

Thu Oct 03, 2013 1:05 pm
Must have been a one-off bit of weirdness, I just tried again and it went to the save dialog without all the fuss. Now it takes several seconds first time after opening Krita, with subsequent times being around a second.

Edit: Still happens when selecting the Text tool though.


dimula73
Registered Member
Posts
4
Karma
0

Re: New Wintab Support

Mon Oct 07, 2013 5:51 pm
Hi, All!

We have prepared an updated package which *might probably* fix the offset Bug #298144 for many people using Cintiq and Intuos4. We have no such hardware, so we need testing!

Here is the package:
http://www.valdyas.org/~boud/krita_x64_2.7.8.21.msi

If this fixes your offset bug, please tell us ;)
If it doesn't fix the bug, please report us the following debugging information:

1) Calibrate your screen, so that the cursor appears with some offset from the stylus
2) Open DebugView (http://technet.microsoft.com/en-us/sysi ... 10%29.aspx)
3) Start Krita
4) Press Ctrl+Shift+T to start logging of the tablet events
5) Paint (note whether the offset in Krita is the same as in other applications)
6) And then save the resulting log here

If you have a bit of time, please also prepare the same log with the tablet calibration reset to defaults.
Panz
Registered Member
Posts
15
Karma
0

Re: New Wintab Support

Mon Oct 07, 2013 7:16 pm
Just tried krita 2.7.8.21 with a win7 64bit pc hooked up with an intuos 4 and when krita opens there is no canvas, only the gray background in the work area. Plus, there is no pointer indication when hovering above work area with either mouse or intuos.
i can post log if you like, but it will be a long post. (Is there some kind of spoiler function or attachment, so i can keep this post short? soz, can't find it)
User avatar boudewijn
KDE Developer
Posts
1380
Karma
7
OS

Re: New Wintab Support

Tue Oct 08, 2013 8:19 am
Hm, no, that doesn't sound to useful. You must have run into some other problem. However, on the linked bug report stipend reports that for him the offset is indeed gone. Now all we have to do is fix the issue with dialogs (crashing or painting underneath) and we should be able to merge and create a new installer for real.
User avatar stipend
Registered Member
Posts
13
Karma
0

Re: New Wintab Support

Wed Oct 09, 2013 4:27 am
boudewijn wrote:Hm, no, that doesn't sound to useful. You must have run into some other problem. However, on the linked bug report stipend reports that for him the offset is indeed gone. Now all we have to do is fix the issue with dialogs (crashing or painting underneath) and we should be able to merge and create a new installer for real.

Hi Boudewijn,
The offset only appears gone when calibration is reset and prompts to calibrate are ignored.
When calibrated there's still an offset, it's just in the opposite direction now as indicated by comment #41. (sorry)
Image

 
Reply to topic

Bookmarks



Who is online

Registered users: Alastair, apater, Baidu [Spider], Bing [Bot], Exabot [Bot], garthecho, ggael, Google [Bot], google01103, Horus, jitseniesen, Joif, kde-jriddell, ken300, La Ninje, Mamarok, mmistretta, Nuc!eoN, psbot [Picsearch], rbruce, renatoatilio, sacarde, sinclair, stephans, TheraHedwig, tienhung, wolfi323, Yahoo [Bot]