Reply to topic

OpenGL doesn't work

User avatar Zafio
Registered Member
Posts
11
Karma
0
OS

OpenGL doesn't work

Mon Sep 30, 2013 1:45 pm
Hi,

Not sure if it is a bug, but with a GF 650 and latest Nvidia Drivers (327.23) on Win7 64, turning OpenGL on results on an empty canvas.

Regards.
Chris Jones
Registered Member
Posts
72
Karma
0

Re: OpenGL doesn't work

Tue Oct 01, 2013 1:55 pm
Same thing here when I updated to 327.23 (Win 8 64, Geforce 9600 GT). I had to revert to 320.49.


User avatar nezumi
Registered Member
Posts
210
Karma
0
OS

Re: OpenGL doesn't work

Tue Oct 01, 2013 4:47 pm
Unfortunately thats true - Open GL does not work for me either on Win7, GTX 550 Ti, driver 327.23.
Funny enough if I turn Open GL on canvas turns grey and if I try to paint on it nothing will show up HOWEVER I am actually painting. I can see layer icon is updating and if I turn off Open GL everything I did is appearing.
User avatar boudewijn
KDE Developer
Posts
1380
Karma
7
OS

Re: OpenGL doesn't work

Tue Oct 01, 2013 6:48 pm
Chris Jones wrote:Same thing here when I updated to 327.23 (Win 8 64, Geforce 9600 GT). I had to revert to 320.49.


Argh... That does sound as if NVidia broke Krita :-(. I mean, my code didn't change... And I still don't have any NVidia card to play with and debug :-(
mixolydian
Registered Member
Posts
10
Karma
0

Re: OpenGL doesn't work

Sat Oct 05, 2013 6:59 am
For me(Geforce gtx 560 ti) on windows 7 64 opengl works really well,except the redrawing problem I mentioned in the thread I started.
Maybe are newer drivers that create problems(I use old drivers, 311.06)
User avatar nezumi
Registered Member
Posts
210
Karma
0
OS

Re: OpenGL doesn't work

Sat Oct 05, 2013 6:37 pm
mixolydian wrote:For me(Geforce gtx 560 ti) Maybe are newer drivers that create problems(I use old drivers, 311.06)

Most probably.
User avatar boudewijn
KDE Developer
Posts
1380
Karma
7
OS

Re: OpenGL doesn't work

Tue Oct 08, 2013 8:32 am
One thing to play with might be the Use Texture Buffer setting. That's about the most advanced opengl feature Krita uses...
User avatar nezumi
Registered Member
Posts
210
Karma
0
OS

Re: OpenGL doesn't work

Tue Oct 22, 2013 10:18 am
Just installed newest Nvidia drivers - 331.58. Problem with OpenGL persists. What I noticed though is that Krita is filling all canvas space with color that we are setting in "canvas border". So I guess here may be the problem.
Can you please take a look at it? I would love to use Krita again with OpenGL...

Here screenshot that may help - I set the color to pink so it will be more obvious:

Image
User avatar boudewijn
KDE Developer
Posts
1380
Karma
7
OS

Re: OpenGL doesn't work

Tue Oct 22, 2013 11:02 am
Does it make a difference whether you enable texture buffering?
User avatar nezumi
Registered Member
Posts
210
Karma
0
OS

Re: OpenGL doesn't work

Tue Oct 22, 2013 12:37 pm
Sadly no, it doesnt.

Image
User avatar boudewijn
KDE Developer
Posts
1380
Karma
7
OS

Re: OpenGL doesn't work

Tue Oct 22, 2013 12:41 pm
Then there's nothing much I can do... If nvidia breaks their drivers from version to version, I'm sunk.
User avatar nezumi
Registered Member
Posts
210
Karma
0
OS

Re: OpenGL doesn't work

Tue Oct 22, 2013 12:54 pm
Dont be so harsh - they didnt broke it from last time much more then it was already :(

So what - Krita on windows without OpenGL from now on? Which makes rotating canvas virtually unusable? Damnit... Damn you Nvidia ;)

To be completely honest I KNOW that you are upset at Nvidia but I am also sure you can fixed. I am sorry but you showed so much skill in latest months (I still remember how you were not sure if you can adjust UI on windows and look at Krita now - looks awesome!). And no, this isnt try to use some reverse psychology on you to convince you to work on it. You will not fixed it if you dont want to. Its a simple compliment.
User avatar Zafio
Registered Member
Posts
11
Karma
0
OS

Re: OpenGL doesn't work

Tue Oct 22, 2013 1:52 pm
@boudewijn: Would it help to have an Nvidia card then? I would be willing to spare some money to help fix this. Anyone else?
User avatar boudewijn
KDE Developer
Posts
1380
Karma
7
OS

Re: OpenGL doesn't work

Tue Oct 22, 2013 5:29 pm
Yes, sure! Supporting the Krita foundation with hardware like that would help a lot. I've got a desktop I can slot in a video card (unless the power draw is extreme...). I've also had another report of this issue, with this hardware: Nvidea Geforce GT 620 CPU E820
User avatar nezumi
Registered Member
Posts
210
Karma
0
OS

Re: OpenGL doesn't work

Tue Oct 22, 2013 6:09 pm
Sadly I am in very tight with money - as far as I remember I always was :P If there would be enough of us even few bucks would do though - all I can do is like $10. Sorry guys, being honest here. As long as you dont think about Titan this could be doable if enough people chipped in.

 
Reply to topic

Bookmarks



Who is online

Registered users: Atalanttore, Baidu [Spider], Bing [Bot], einar, Exabot [Bot], flya, Google [Bot], google01103, kdeuserk, koriun, Majestic-12 [Bot], pedrorodriguez, sashcroft, scottpetrovic, scummos, SecretCode, Sogatori, vascobasque, Yahoo [Bot]