Reply to topic

Crash after configuration changes

Banshee
Registered Member
Posts
4
Karma
0

Crash after configuration changes

Mon Nov 04, 2013 2:40 pm
Hello !
First Sorry for my Engrish nazi gramma é.è

I don't know if it's the right place to ask about my problem here but I will try.
I used Krita for a few days but today I had a big problem, i run it on a Win7 64 with the 2.7.8.22 (for my cintiq offset issue) and it ran correctly but just now I wanted to change an option about the zoom option in "only canvas setting" or something like that, I had clicked on "apply" but the software crashed.
I tried to launch the file, create new etc... but when i click on "create" or "load" Krita shutdown.. I tried to uninstall, reinstall, install the 2.7.8.23 but i have the same problem... There is an option to reset Krita configuration ? How can i uninstall completely Krita to re-install ? or there is a solution already ? I deleted krita directories, used glary utilities to cleaning but it's like the configuration is still the same and not the default one :/

Did anyone had a solution to help me please ?
thank in advance ! :)
User avatar boudewijn
KDE Developer
Posts
1380
Karma
7
OS
Please check c:\Users\YOURUSER\AppData\Local and c:\Users\YOURUSER\AppData\Roaming. Remove any folder called .kde, kde or .krita in there. That should reset Krita to default.
Banshee
Registered Member
Posts
4
Karma
0
Oh ! Thank you ! really, an answer fast and efficient, it works !
Thank you again :)
Seikatsukan
Registered Member
Posts
1
Karma
0
OS

Re: Crash after configuration changes

Mon Nov 18, 2013 12:11 am
I have a similar problem, in that it can only be solved by completely erasing Krita's configuration files in AppData\Roaming\Krita. I broke my head against this one because I like to configure every part of the software I use to my liking, and I think I finally found the culprit.

This bug can be consistently reproduced in my system by erasing the fifth default brush, the one called "Basic_circle". Starting from a clean installation, remove this brush from the "Choose brush preset" menu, close Krita, re-start Krita. The "new document" window appears, but upon trying to create a new image or open an existent one, Krita crashes unceremoniously.
Changing other configurations such as hotkeys, tablet pressure curve, UI colors, creating new brushes, dockers layout and the like does not cause this bug in my system. Erasing all default brushed did. I had to find the particular brush causing this via binary search and program restart, erasing the config folder each time. I then supposed the problem resides in that this is the particular brush Krita tries to load at startup, and not finding it makes it panic, so I tried erasing all default brushes and creating a single custom one called "Basic_circle" with different options than the default one. Afterwards, Krita loads normally and chooses this custom brush as if nothing had happened, so I think we have the origin of the bug right here.

My system:
OS: Windows 7 Ultimate 64bit SP1
Proc: AMD Phenom II X4 960T (3.00 GHz)
RAM: 4x Kingston DDR3 667 MHz 4 GiB (16 GiB total)
Vid: nVidia GeForce GTS 450 (1.0 GiB), driver version 331.65

Running Krita 64 bit 2.7.8.25, downloaded from the "New release ready for testing" thread.
It's running from the default installation folder, Program Files (x86), but moving to the regular Program Files makes no difference, as expected, and Windows Task Manager says it's running as 64bit either case.

I hope this information is of use to everyone, for the users to prevent this bug... and for the devs to fix it ;)
User avatar boudewijn
KDE Developer
Posts
1380
Karma
7
OS
Aw... Right... That is one brush you really shouldn't remove, because it's the one we use on startup... I'll harden the code a bit. Thanks for the investigation -- great work and very helpful.

 
Reply to topic

Bookmarks



Who is online

Registered users: alake, Baidu [Spider], Bing [Bot], bjoernbalazs, braystacey, Dimitrios, edmael, einar, Exabot [Bot], flotho, Google [Bot], google01103, ivan, Joif, ken300, maarten, Majestic-12 [Bot], nezumi, peje, rdong, SecretCode, skywolfblue, stephans, Steve T, TheraHedwig, tienhung, Yahoo [Bot]