Reply to topic

FreeBSD 9.0 amd64 KDE4.8.4 can not run dbus as regular users

binyo66
Registered Member
Posts
33
Karma
0
OS
How to do it? login as root in a window manager, and then run kde4 as user?
When I tried from user login prompt startx > 1.txt, 1.txt contained
Code: Select all
GOT SIGHUP
User avatar bcooksley
Administrator
Posts
18601
Karma
83
OS
Try logging in as your normal user, selecting some form of "Failsafe" (not "KDE Failsafe") session from KDM. It may also be called "XTerm" or similar - the exact name does depend upon the distribution I believe. Then run "startkde" from there.


System Settings and Device Actions KCM maintainer
Image
binyo66
Registered Member
Posts
33
Karma
0
OS
I picked pure fail-safe. and end up with a single x-term. Running startkde showed nothing... not even a dialog box. Just hang there.
User avatar bcooksley
Administrator
Posts
18601
Karma
83
OS
Can you try running it as follows to see where it hangs?
Code: Select all
bash -x $(which startkde)


System Settings and Device Actions KCM maintainer
Image
binyo66
Registered Member
Posts
33
Karma
0
OS
from xterm? I type bash-x$(which startkde) ?

Last edited by binyo66 on Fri Feb 08, 2013 10:23 am, edited 1 time in total.
User avatar bcooksley
Administrator
Posts
18601
Karma
83
OS
Yes.


System Settings and Device Actions KCM maintainer
Image
binyo66
Registered Member
Posts
33
Karma
0
OS
I type
Code: Select all
(which startkde)

shows nothing... just back to the prompt
Code: Select all
(which startkde4)

same results.
Right now, I am still in single x-term safe mode. with running firefox &.

Edit:
Funny.. after running firefox... I got :
(firefox:1521) : Glib-GIO-CRITICAL ** : g_dbus_connection_add_filter: assertion 'G_IS_DBUS_CONNECTION (connection)' failed.

Last edited by binyo66 on Fri Feb 08, 2013 10:36 am, edited 1 time in total.
User avatar bcooksley
Administrator
Posts
18601
Karma
83
OS
Is your KDE installation in $PATH?


System Settings and Device Actions KCM maintainer
Image
binyo66
Registered Member
Posts
33
Karma
0
OS
the user .xinitrc has
Code: Select all
PATH=/usr/local/kde4/bin:$PATH
export PATH
exec startkde
User avatar bcooksley
Administrator
Posts
18601
Karma
83
OS
Please add /usr/local/kde4/bin to PATH in your xterm, then try the bash -x invocation again.


System Settings and Device Actions KCM maintainer
Image
binyo66
Registered Member
Posts
33
Karma
0
OS
OK, it showed
Code: Select all
(which startkde)
/usr/local/kde4/bin/startkde
User avatar bcooksley
Administrator
Posts
18601
Karma
83
OS
Did bash show anything being executed? The -x switch should cause it to show the numerous steps it is carrying out...
If it is showing nothing, can you please pastebin the content of /usr/local/kde4/bin/startkde?


System Settings and Device Actions KCM maintainer
Image
binyo66
Registered Member
Posts
33
Karma
0
OS
ok.. sorry... i just type (which startkde), not all... it attempted to run KDE4, and back with a lot of message. I tried to run x-term, so can do copy and paste
binyo66
Registered Member
Posts
33
Karma
0
OS
Here the results
Code: Select all
[irfan@irfan-pc /usr/home/irfan]$ bash -x $(which startkde)
+ test x = x--failsafe
+ trap 'echo GOT SIGHUP' HUP
+ kcheckrunning
+ kcheckrunning_result=1
+ test 1 -eq 0
+ test 1 -eq 2
+ unset DYLD_FORCE_FLAT_NAMESPACE
++ echo /usr/local/kde4/bin/startkde
++ sed -n 's,^\(/.*\)/[^/][^/]*$,\1,p'
+ bindir=/usr/local/kde4/bin
+ '[' -n /usr/local/kde4/bin ']'
++ /usr/local/kde4/bin/kde4-config --qt-binaries
+ qbindir=/usr/local/bin
+ '[' -n /usr/local/bin ']'
+ case $PATH in
+ case $PATH in
+ kdehome=/home/irfan/.kde4
+ test -n ''
+ mkdir -m 700 -p /home/irfan/.kde4
+ mkdir -m 700 -p /home/irfan/.kde4/share
+ mkdir -m 700 -p /home/irfan/.kde4/share/config
+ cat
+ kstartupconfig4
+ returncode=0
+ test 0 -ne 0
+ '[' -r /home/irfan/.kde4/share/config/startupconfig ']'
+ . /home/irfan/.kde4/share/config/startupconfig
++ kcminputrc_mouse_cursortheme=Oxygen_White
++ kcminputrc_mouse_cursorsize=
++ ksplashrc_ksplash_theme=Default
++ ksplashrc_ksplash_engine=KSplashX
++ krandrrc_display_applyonstartup=false
++ krandrrc_display_startupcommands=
++ kcmfonts_general_forcefontdpi=0
++ kdeglobals_locale_language=
++ klocale_languages=en_US
+ test -n Oxygen_White -o -n ''
+ XCURSOR_PATH='/usr/local/kde4/share/icons::~/.icons:/usr/local/share/icons:/usr/local/share/pixmaps:/usr/local/lib/X11/icons'
+ export XCURSOR_PATH
+ kapplymousetheme Oxygen_White ''
+ test 0 -eq 10
+ test -n Oxygen_White
+ XCURSOR_THEME=Oxygen_White
+ export XCURSOR_THEME
+ test -n ''
+ . krandrstartup
++ test false = true
+ test 0 -ne 0
+ dl=
+ unset DESKTOP_LOCKED
+ ksplash_pid=
+ test -z ''
+ KLOCALE_LANGUAGES=en_US
+ export KLOCALE_LANGUAGES
+ case "$ksplashrc_ksplash_engine" in
++ ksplashx Default --pid
+ ksplash_pid=1663
+ unset KLOCALE_LANGUAGES
++ kde4-config --path lib
++ tr : '\n'
+ libpath='/usr/home/irfan/.kde4/lib/
/mnt/other2/usr/local/kde4/lib/'
++ echo '/usr/home/irfan/.kde4/lib/
/mnt/other2/usr/local/kde4/lib/'
++ sed -n -e 's,/lib[^/]*/,/env/,p'
+ for prefix in '`echo "$libpath" | sed -n -e '\''s,/lib[^/]*/,/env/,p'\''`'
+ for file in '"$prefix"*.sh'
+ test -r '/usr/home/irfan/.kde4/env/*.sh'
+ for prefix in '`echo "$libpath" | sed -n -e '\''s,/lib[^/]*/,/env/,p'\''`'
+ for file in '"$prefix"*.sh'
+ test -r /mnt/other2/usr/local/kde4/env/nepomuk-env.sh
+ . /mnt/other2/usr/local/kde4/env/nepomuk-env.sh
++ '[' /usr/local/kde4 '!=' /usr/local ']'
++ STRIGI_PLUGIN_PATH=:/usr/local/kde4/lib/strigi:/usr/local/lib/strigi
++ export STRIGI_PLUGIN_PATH
+ for file in '"$prefix"*.sh'
+ test -r /mnt/other2/usr/local/kde4/env/perl-kdebindings-env.sh
+ . /mnt/other2/usr/local/kde4/env/perl-kdebindings-env.sh
++ '[' /usr/local/kde4 '!=' /usr/local ']'
++ PERL5LIB=:/usr/local/kde4/lib/perl5/site_perl/5.12.4/mach:
++ /usr/local/kde4/lib/perl5/site_perl/5.12.4
/mnt/other2/usr/local/kde4/env/perl-kdebindings-env.sh: line 4: /usr/local/kde4/lib/perl5/site_perl/5.12.4: Is a directory
++ export PERL5LIB
+ for file in '"$prefix"*.sh'
+ test -r /mnt/other2/usr/local/kde4/env/ruby-kdebindings-env.sh
+ . /mnt/other2/usr/local/kde4/env/ruby-kdebindings-env.sh
++ '[' /usr/local/kde4 '!=' /usr/local ']'
++ RUBYLIB=:/usr/local/kde4/lib/ruby/site_ruby/1.8:/usr/local/kde4/lib/ruby/site_ruby/1.8/amd64-freebsd9
++ export RUBYLIB
+ for file in '"$prefix"*.sh'
+ test -r /mnt/other2/usr/local/kde4/env/xdg-env.sh
+ . /mnt/other2/usr/local/kde4/env/xdg-env.sh
++ XDG_CONFIG_DIRS=:/etc/xdg:/usr/local/etc/xdg:/usr/local/etc/xdg/xfce4
++ '[' /usr/local/kde4 '!=' /usr/local ']'
++ XDG_CONFIG_DIRS=/usr/local/kde4/etc/xdg::/etc/xdg:/usr/local/etc/xdg:/usr/local/etc/xdg/xfce4
++ export XDG_CONFIG_DIRS
++ XDG_DATA_DIRS=:/usr/share:/usr/local/share:/usr/local/share/gnome
++ '[' /usr/local/kde4 '!=' /usr/local ']'
++ XDG_DATA_DIRS=/usr/local/kde4/share::/usr/share:/usr/local/share:/usr/local/share/gnome
++ export XDG_DATA_DIRS
++ kde4-config --path qtplugins
+ QT_PLUGIN_PATH=/usr/home/irfan/.kde4/lib/kde4/plugins/:/mnt/other2/usr/local/kde4/lib/kde4/plugins/
+ export QT_PLUGIN_PATH
+ usr_odir=/home/irfan/.fonts/kde-override
+ usr_fdir=/home/irfan/.fonts
+ test -n ''
+ sys_odir=/share/fonts/override
+ sys_fdir=/share/fonts
+ test -d /share/fonts/override
+ test -d /home/irfan/.fonts/kde-override
+ test -d /home/irfan/.fonts
+ test -d /share/fonts
+ xset fp rehash
+ xsetroot -cursor_name left_ptr
+ test -n ''
+ GS_LIB=/home/irfan/.fonts
+ export GS_LIB
++ kde4-config --path exe --locate lnusertemp
+ lnusertemp=/mnt/other2/usr/local/kde4/lib/kde4/libexec/lnusertemp
+ test -z /mnt/other2/usr/local/kde4/lib/kde4/libexec/lnusertemp
+ for resource in tmp cache socket
+ /mnt/other2/usr/local/kde4/lib/kde4/libexec/lnusertemp tmp
+ :
+ for resource in tmp cache socket
+ /mnt/other2/usr/local/kde4/lib/kde4/libexec/lnusertemp cache
+ :
+ for resource in tmp cache socket
+ /mnt/other2/usr/local/kde4/lib/kde4/libexec/lnusertemp socket
+ :
+ echo 'startkde: Starting up...'
startkde: Starting up...
+ test -z /usr/local/kde4/share::/usr/share:/usr/local/share:/usr/local/share/gnome
+ test -z ''
++ dbus-uuidgen --get
+ uuid=76ed94af597f41a942586bb300000d09
++ dbus-launch --sh-syntax --exit-with-session --autolaunch 76ed94af597f41a942586bb300000d09
+ eval 'DBUS_SESSION_BUS_ADDRESS='\''unix:path=/tmp/dbus-rXg01x6ZAf,guid=c3b937786c4d7d9bffd7d80700000498'\'';' export 'DBUS_SESSION_BUS_ADDRESS;' 'DBUS_SESSION_BUS_PID=1683;' 'DBUS_SESSION_BUS_WINDOWID=12582913;'
++ DBUS_SESSION_BUS_ADDRESS=unix:path=/tmp/dbus-rXg01x6ZAf,guid=c3b937786c4d7d9bffd7d80700000498
++ export DBUS_SESSION_BUS_ADDRESS
++ DBUS_SESSION_BUS_PID=1683
++ DBUS_SESSION_BUS_WINDOWID=12582913
+ qdbus
+ echo 'startkde: Could not start D-Bus. Can you call qdbus?'
startkde: Could not start D-Bus. Can you call qdbus?
+ test -n 1663
+ kill 1663
+ xmessage -geometry 500x100 'Could not start D-Bus. Can you call qdbus?'
+ exit 1

User avatar bcooksley
Administrator
Posts
18601
Karma
83
OS
Hm, damn. It does seem that D-Bus is being started successfully however. What happens when you run "qdbus" in your xterm session?
I suspect the tool may not be installed, or is having issues somehow.


System Settings and Device Actions KCM maintainer
Image

 
Reply to topic

Bookmarks



Who is online

Registered users: Alexa [Bot], Baidu [Spider], Bing [Bot], bshah, cylverbak, dehnhardt, Exabot [Bot], ggael, Google [Bot], HmpfCBR, ivan, ken300, koriun, Majestic-12 [Bot], nezumi, ooker, oskaras, paulus3005, rulet111, Schoelje, TheraHedwig, Tuukka, valoriez, VulpesVulpes, Yahoo [Bot]