Reply to topic

KDM doesn't start automatically after upgrade to KDE 4.10

User avatar skadinna
Registered Member
Posts
8
Karma
0
OS
I've had this problem for almost two weeks now; been searching high and low for some kind of a solution. Now I'm getting really desperate :'( . That's why I decided to open a new topic - hopefully someone here can help me. I was thinking of reporting a bug, but I'm not sure whether this actually is a bug or just a problem with my configuration.

Here's some general info about my system:

KDE 4.10.00
Kernel: Linux 3.2.0-37-generic (i686)
Distribution: Linux Mint 13 Maya
X.Org X Server 1.11.3
Laptop: Dell Inspiron 6400
ATI Radeon Mobility X1400 (using radeon driver)
Intel Pentium Dual-Core processor
1506 MB DDR2 RAM

The problem: after upgrading to KDE 4.10, KDM does not start automatically anymore, be it after a reboot or a cold boot.

The system boots into console mode, where I can normally log in. From there I can:
+ type sudo service restart kdm, which works - KDM loads as it normally should, I log in and KDE starts
+ type startx, which previously did nothing, but I edited .xsession and .xinitrc files in /home so now it loads KDE
- type startkde, which returns a "$DISPLAY not set" error and does, well, nothing :(

There are similar problems all over the Internet, but people who had it have nVidia graphics, while I have ATI - they fixed it by installing the new or different driver, but I can't do that. The proprietary ATI driver (fglrx) does not support my graphics card anymore and it doesn't work properly when I try to install it.

I found a seemingly identical problem on Linux Mint forums (here's my post), but I somehow feel I'd sooner see a new version of KDE SC than a solution (or any kind of response, really) written there, so instead I'm asking here.

How I tried to fix this?

Googled, found some bugs concerning lightdm but with identical symptoms so I tried to apply some of the suggested fixes.

I edited /etc/init/kdm.conf and removed 'card0' from the PRIMARY_DEVICE_FOR_DISPLAY line; added 'and stopped udevtrigger'; added 'sleep 10' before kdm is executed; added respawn before 'emits login-session-start'. Nothing changed.

I checked the logs and found that KDM was started from both /etc/init and /etc/init.d folders, which resulted in the following line in boot.log:
Rather than invoking init scripts through /etc/init.d, use the service(8) utility, e.g. service S20kdm start

I deleted it from init.d, but this didn't help either. Sure, the quoted line didn't appear anymore - until I reinstalled KDM. Reinstalling KDM created that file in init.d again and it didn't fix the main problem. I also tried to reconfigure KDM via both dpkg and genkdmconf, but nothing helped.

I also deleted /var/tmp/kdecache-user and kdecache-kdm folders, but it didn't fix the problem.

Then I edited the kdmrc file and increased OpenTimeout, ServerTimeout and ServerAttempts values. This seemed to help, because after that KDM started automatically, but only once. On next boot I was again forced to login via console. Now KDM occassionally starts automatically, but it's like once in 5 or more boots.

I'm all out of ideas and don't know what else to do :'( . I was thinking of either doing dpkg-reconfigure --all or reinstalling KDE (maybe even the entire system), but I don't know if that's a good idea. Also, I would like to know what's the cause of this problem, why does it happen, instead of just blindly reinstalling the system. I've uploaded some of my logs; if necessary, I'll provide more - just say which ones.

Thanks in advance to anyone who at least reads this topic. If anyone has any ideas or advice, please let me know. Also feel free to move this topic if I'm posting it in the wrong place (and sorry about that).

Logs:
boot.log
kdm.log
Xorg.log
User avatar google01103
Manager
Posts
4965
Karma
17
OS
have you considered up'ing to Mint 14?


OpenSuse 13.1 x64, KDE 4.12.x

Problem solved? Please click on Image below the post with the best answer to mark your topic as solved.
User avatar google01103
Manager
Posts
4965
Karma
17
OS
what about using ldm instead of kdm?


OpenSuse 13.1 x64, KDE 4.12.x

Problem solved? Please click on Image below the post with the best answer to mark your topic as solved.
User avatar skadinna
Registered Member
Posts
8
Karma
0
OS
google01103 wrote:have you considered up'ing to Mint 14?


No, I don't want to do that unless absolutely necessary. Mint 13 is LTS, I'm planning to stay on it as long as it's supported.

google01103 wrote:what about using ldm instead of kdm?


I actually tried to install it, but it didn't work properly (some greeter files were missing). Of course, I could try again and ditch KDM if it works, but that would just be taking the easy way out, and it wouldn't solve the problem. Thanks for your input, tho ;D
User avatar google01103
Manager
Posts
4965
Karma
17
OS
the greeter files missing could be from the package lightdm-kde-greeter (or something similar)


OpenSuse 13.1 x64, KDE 4.12.x

Problem solved? Please click on Image below the post with the best answer to mark your topic as solved.
User avatar skadinna
Registered Member
Posts
8
Karma
0
OS
google01103 wrote:the greeter files missing could be from the package lightdm-kde-greeter (or something similar)


I think you're right; this package wasn't even installed by default. So lightdm should work once I have this. Thank you. :)

Still, I don't know what to do about this KDM problem :| I suppose if I install lightdm and the same thing happens with it (i.e. it doesn't start automatically), then I can report that I have the same bug as the one I linked in the first post? Though that would probably mean that the bug is in Upstart and not in any of the display managers...
User avatar bcooksley
Administrator
Posts
18657
Karma
83
OS
Just checking - KDM is configured to be started when your system reaches run level 5 correct?
(This is usually distribution specific unfortunately, Debian based ones use update-rc.d I believe).


System Settings and Device Actions KCM maintainer
Image
User avatar skadinna
Registered Member
Posts
8
Karma
0
OS
bcooksley wrote:Just checking - KDM is configured to be started when your system reaches run level 5 correct?
(This is usually distribution specific unfortunately, Debian based ones use update-rc.d I believe).

I never changed those settings or messed about with runlevels, so it should all be as it was by default.
This is from /etc/init/kdm.conf:

Code: Select all
           
start on ((filesystem
           and runlevel [!06]
      and started dbus
           and stopped udevtrigger
      and (drm-device-added *card0 PRIMARY_DEVICE_FOR_DISPLAY=1
           or stopped udev-fallback-graphics))
          or runlevel PREVLEVEL=S)

stop on runlevel [016]


Now, the scripts in /etc/rc*.d folders do seem a bit confusing. There's a kdm script in every one; obviously, it's disabled in runlevels/folders 0, 1 and 6. However, in 2, 3, 4 and 5 it's named S20kdm, which means that it should be started. (???)

I'm guessing I should change it to K20kdm in all folders (runlevels) except in rc5.d, so that it starts from runlevel 5?
User avatar bcooksley
Administrator
Posts
18657
Karma
83
OS
That configuration looks fine. Are you able to find any indication in /var/log/kdm.log or /var/log/Xorg.0.log as to why KDM would be failing to start?


System Settings and Device Actions KCM maintainer
Image
User avatar skadinna
Registered Member
Posts
8
Karma
0
OS
bcooksley wrote:Are you able to find any indication in /var/log/kdm.log or /var/log/Xorg.0.log as to why KDM would be failing to start?


This, I suppose (from kdm.log):
Code: Select all
klauncher(1841) kdemain: No DBUS session-bus found. Check if you have started the DBUS server.
kdeinit4: Communication error with launcher. Exiting!
kdmgreet(1833)/kdecore (K*TimeZone*): KSystemTimeZones: ktimezoned initialize() D-Bus call failed:  "Not connected to D-Bus server"


Other than that, I really have no idea :(
I've posted links to the logs in the first post hoping that someone else might discover something that would be useful (and that I overlooked). :|
User avatar bcooksley
Administrator
Posts
18657
Karma
83
OS
You may wish to check your xorg.conf / ATI driver installation - it seems the appropriate module is not being found.
Code: Select all
[    71.384] (EE) Failed to load module "fglrx" (module does not exist, 0)


System Settings and Device Actions KCM maintainer
Image
User avatar skadinna
Registered Member
Posts
8
Karma
0
OS
Well yeah, the proprietary (fglrx) driver is not installed at all, because it messes up the graphics when I install it :-\

Should I install it anyway?
User avatar bcooksley
Administrator
Posts
18657
Karma
83
OS
You do not need to install it - just make sure all references to it have been purged from your X11 configuration (xorg.conf).


System Settings and Device Actions KCM maintainer
Image
User avatar skadinna
Registered Member
Posts
8
Karma
0
OS
No luck. :'(

I don't even have the xorg.conf file, and when I try to generate it using the Xorg -configure command, I get the following error:
Number of created screens does not match number of detected devices

I also tried to reinstall and reconfigure xserver-xorg and related packages, but it didn't help. Neither did blacklisting that (non-existing) fglrx module in /etc/modprobe.d/blacklist.conf.

I don't know what else to do. :(
Do you think it would work if I manually wrote a new xorg.conf file?

Anyone else has any other ideas?
User avatar bcooksley
Administrator
Posts
18657
Karma
83
OS
I find it rather unusual that "sudo service restart kdm" when executed manually starts KDM without problems, while it fails to start on system boot.
Are you able to check your init system log to double check it is actually being started up?


System Settings and Device Actions KCM maintainer
Image

 
Reply to topic

Bookmarks



Who is online

Registered users: alake, Alexa [Bot], Baidu [Spider], Bing [Bot], bobo01, einar, Exabot [Bot], Google [Bot], Hei Ku, joshaughnessy, Marand, mgraesslin, nezumi, orbmiser, TheraHedwig, Yahoo [Bot]