Reply to topic

My KDE desktop is so slow but my VMs aren't!

User avatar latebeat
Registered Member
Posts
70
Karma
0
Ok guys, this is a weird one.
First of all a bit of background. I'm running kubuntu 12.04 on a core i7 laptop with 8gigs of ram and a fast ssd. The gpu has 1gb of vram and I'm using the nvidia binaries.
Now about the problem... Since day one my plasma desktop has been kinda choppy. My system is not slow by any means but all the desktop animations are choppy! It's weird to explain but for the lack of a better/non-cliche metaphor... desktop animations are definitely not buttery smooth. I've tried different scaling methods in the desktop effects, tried disabling vsync too. I've also tried both opengl / xrender and native/raster.

Now, In the past week I've been working on a project of mine and I haven't been rebooting my system and the animations were becoming slower and slower. Meaning I would minimize a window and I would see it happen frame by frame. Maximizing same. Now since I was working on my laptop I thought that's probably how it is and my system is not fast enough or something. I didn't have time to investigate further so I left it like that even though it was annoying the cr*p out of me.
Yesterday I downloaded pear linux and elementaryos to check them out to see what all the hype was about. I run the live versions in vmware workstation 8 which supports gpu acceleration. What happened made me scratch my head and made me finally write this post to ask for help as to what can it be.
Both vms were running soo smooth I couldn't believe it. All the desktop and window animations were incredibly buttery smooth as they say. That was the same laptop that hadn't been rebooted for a week, with the native kde being so choppy. For a few minutes all I did was maximize, minimize and unminimize windows just to enjoy the smoothness of the animation. How can that be possible? A vm exhibiting "better" performance than the actual system? Out of curiosity I downloaded an iso of kubuntu as well and run it too in a vm. Window animations were smooth there too! I am scratching my head.
How can that be? Where should I start to troubleshoot this issue? I have the latest nvidia binaries, open gl acceleration is enabled yet I have this.

Any thoughts would be greatly appreciated!

Thank you,

Last edited by latebeat on Fri Nov 30, 2012 11:18 am, edited 1 time in total.
relaxis
Registered Member
Posts
4
Karma
0
You should switch to the raster graphics system. You can find it in the system settings.
User avatar bcooksley
Administrator
Posts
18607
Karma
83
OS
I would recommend searching out the Nvidia graphics driver thread in this forum - there have been known instances where the Nvidia binary drivers have been problematic.

I suspect the reason why the virtual machine is working well is because the VMWare layer is causing KDE to use a lower level of desktop effects (likely XRender) which is not triggering the slow code paths in the Nvidia driver.


System Settings and Device Actions KCM maintainer
Image
User avatar latebeat
Registered Member
Posts
70
Karma
0
bcooksley wrote:I would recommend searching out the Nvidia graphics driver thread in this forum - there have been known instances where the Nvidia binary drivers have been problematic.
I suspect the reason why the virtual machine is working well is because the VMWare layer is causing KDE to use a lower level of desktop effects (likely XRender) which is not triggering the slow code paths in the Nvidia driver.


Thanks for the reply bcooksley. I will try there too.
In the meantime I purged the drivers and reinstalled the new version and did some basic "testing". I tried different combos OpenGL/Xrender with Native/Raster.
Everytime I was changing the settings I would constantly minimize and unminimize an instance of konsole and note down the cpu usage.

Here's my results

Compositing type: OpenGL
qt graphics system: Native
scale method: Smooth

Animation: very choppy
CPU usage: Kwin 28%, Xorg 20%
----
Compositing type: OpenGL
qt graphics system: Raster
scale method: Smooth

Animation: best overall feeling of "smoothness"
CPU usage: Kwin 27%, Xorg 16%
----
Compositing type: Xrender
qt graphics system: Native
scale method: Smooth

Animation: smooth (although 21 effects could not be enabled)
CPU usage: Xorg 17%, Kwin 14%

So as far as the smoothest effects go, I got the best overall feeling of smoothness with OpenGL/Raster, VSync disabled an OpenGL 2 shaders disabled and the smooth scale method. However, for an i7 and a good gpu card aren't those numbers on the high side JUST for minimizing and unminizing a simple konsole window?

Also if a have a lot of windows open, a lot of chrome tabs open (35+), my system slows down a lot because the Xorg process climbs to something like 60% cpu usage momentarily whenever I do any sort of window action (like new tab, minimize, maximize etc). Note that memory doesn't seem to be a problem as I'm never swapping and I have at least 2gigs free always.

PS: I tried the other scaling methods too, but I felt smooth was producing the best overall feeling irrespective of the cpu usage. Besides crisp wasn't any faster or less stressful on the cpu

Last edited by latebeat on Sat Dec 08, 2012 10:03 am, edited 1 time in total.
User avatar bcooksley
Administrator
Posts
18607
Karma
83
OS
Which version of the Nvidia graphics drivers are you using? Please make sure they are the newest you can use as some of the older versions are known to be quite underperformant in certain tasks - especially moving windows.

While this thread is now quite ancient, if you are stuck with old Nvidia drivers, it may help - viewtopic.php?f=17&t=6971&p=7727


System Settings and Device Actions KCM maintainer
Image

 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], Bing [Bot], Dimitrios, Exabot [Bot], Google [Bot], hagabaka, Hans, koriun, La Ninje, Majestic-12 [Bot], mohali, msdobrescu, Steve Guilford, vascobasque, whatthefunk, Yahoo [Bot]