Reply to topic

KDE4 slow login process.

firewalker
Registered Member
Posts
45
Karma
0
OS

KDE4 slow login process.

Tue Jan 15, 2013 10:30 am
My KDE-4 login process is fairly slow. It takes about a minute or so on a Core i3-2350M CPU @ 2.30GHz with 4 Gbyte of RAM. I face this problem for quite some time now but I wasn't able to solve it.

The biggest amount of time is taken by the "Big K" icon. Does any one knows what gets loaded during that time?

I have tried to disable Strigi, Nepomuk, Desktop effects, Composition and other services.

I face the same problem with another pc (Pentium4 CPU @ 3.20GHz with 2 Gbytes RAM and nVidia gpu).

http://www.youtube.com/watch?v=pxKWJfkV7cQ

How can I debug it? Monitor the process?

Monitoring .xsession-errors I can locate a 24 secs "gap".

12:12:30 kwin(2491) KWin::ShaderManager::initShaders: Ortho Shader is valid
12:12:30 kwin(2491) KWin::ShaderManager::initShaders: Generic Shader is valid
12:12:30 kwin(2491) KWin::ShaderManager::initShaders: Color Shader is valid
12:12:30 kwin(2491) KWin::SceneOpenGL::SceneOpenGL: DB: true , Direct: true
12:12:31 kwin(2491) KWin::currentRefreshRate: Vertical Refresh rate 60 Hz
12:12:31 kwin(2491) KWin::EffectsHandlerImpl::loadEffect: Trying to load "kwin4_effect_desktopgrid"
12:12:31 kwin(2491) KWin::EffectsHandlerImpl::loadEffect: Trying to load "kwin4_effect_presentwindows"
12:12:31 kwin(2491) KWin::EffectsHandlerImpl::loadEffect: Trying to load "kwin4_effect_logout"
12:12:31 kwin(2491) KWin::EffectsHandlerImpl::loadEffect: Trying to load "kwin4_effect_minimizeanimation"
12:12:33 QDBusConnection: session D-Bus connection created before QCoreApplication. Application may misbehave.
12:12:33 QDBusConnection: session D-Bus connection created before QCoreApplication. Application may misbehave.
12:12:33 QDBusConnection: session D-Bus connection created before QCoreApplication. Application may misbehave.
12:12:33 QDBusConnection: session D-Bus connection created before QCoreApplication. Application may misbehave.
12:12:34 QDBusObjectPath: invalid path ""
12:12:34 QDBusObjectPath: invalid path ""
12:12:35 QDBusConnection: name 'org.kde.kglobalaccel' had owner '' but we thought it was ':1.6'
12:12:35 kded(2418)/kdecore (KConfigSkeleton) KCoreConfigSkeleton::writeConfig:
12:12:35 Object::connect: No such signal QDBusAbstractInterface::StateChanged(uint)
12:12:59 Object::connect: No such signal QDBusAbstractInterface::ActiveChanged(bool)

12:12:59 QGraphicsLinearLayout::insertItem: cannot insert null item
12:12:59 QGraphicsLinearLayout::insertItem: cannot insert null item
12:13:03 Connecting to deprecated signal QDBusConnectionInterface::serviceOwnerChanged(QString,QString,QString)
12:13:03 krunner(2597)/libakonadi Akonadi::AgentManagerPrivate::createDBusInterface: AgentManager failed to get a valid AgentManager DBus interface. Error is: 1 "org.freedesktop.DBus.Error.NameHasNoOwner" "Could not get owner of name 'org.freedesktop.Akonadi.Control': no such name"
12:13:03 krunner(2597)/libakonadi Akonadi::SessionPrivate::socketError: Socket error occurred: "QLocalSocket::connectToServer: Invalid name"
12:13:03 "/usr/bin/kdeinit4(2597)" Soprano: "Could not connect to server at /tmp/ksocket-firewalker/nepomuk-socket (No such file or directory)"
12:13:03 "/usr/bin/kdeinit4(2597)" Soprano: "Could not connect to server at /tmp/ksocket-firewalker/nepomuk-socket (No such file or directory)"
12:13:03 "/usr/bin/kdeinit4(2597)" Soprano: "Could not connect to server at /tmp/ksocket-firewalker/nepomuk-socket (No such file or directory)"
12:13:03 "/usr/bin/kdeinit4(2597)" Soprano: "Could not connect to server at /tmp/ksocket-firewalker/nepomuk-socket (No such file or directory)"


Sometimes between the gap is a kded(2451)/kdecore (KConfigSkeleton) KCoreConfigSkeleton::writeConfig: message.

OS: ArchLinux.

kde4-config --version
Qt: 4.8.4
KDE Development Platform: 4.9.5
kde4-config: 1.0
User avatar einar
Administrator
Posts
2268
Karma
5
OS

Re: KDE4 slow login process.

Wed Jan 16, 2013 10:54 pm
12:13:03 "/usr/bin/kdeinit4(2597)" Soprano: "Could not connect to server at /tmp/ksocket-firewalker/nepomuk-socket (No such file or directory)"


Did you disable Nepomuk, or did you leave it as defaults?


"Violence is the last refuge of the incompetent."
Image
Plasma FAQ maintainer - Plasma programming with Python
firewalker
Registered Member
Posts
45
Karma
0
OS

Re: KDE4 slow login process.

Thu Jan 17, 2013 7:03 am
It is disabled (It should be).

nepomukserverrc
[$Version]
update_info=nepomukstrigiservice-migrate.upd:nepomukstrigiservice-migrate

[Basic Settings]
Start Nepomuk=false

[Service-nepomukfileindexer]
autostart=false

[main Settings]
Maximum memory=50
Storage Dir[$e]=$HOME/.kde4/share/apps/nepomuk/repository/main/
Used Soprano Backend=virtuosobackend
User avatar bcooksley
Administrator
Posts
18562
Karma
83
OS

Re: KDE4 slow login process.

Fri Feb 08, 2013 7:09 am
If you are able, can you connect to your computer from another computer using SSH, and observe the processes which appear to be using disk and cpu most heavily during this process?

I suspect the delay is due to Plasma starting up - which could be made longer if you have added applets which access the network, or if you have added a large number of applets.


System Settings and Device Actions KCM maintainer
Image

 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], bcooksley, Bing [Bot], brand, capslock, djarvie, Exabot [Bot], Google [Bot], GreatEmerald, jensreuterberg, jgrulich, jitseniesen, korakios, koriun, Kver, lazyit, lueck, Majestic-12 [Bot], MiceAreVeryNice, NickElliott, TheraHedwig, Tuukka, Yahoo [Bot]