Reply to topic

Third level choser (Alt-Gr) outputs wrong characters

aburak
Registered Member
Posts
14
Karma
0
In every other DE (+ Ubuntu) "Alt-Gr Key" works expectedly, but not in Kubuntu or Ubuntu Minimal + KDE-full.

"Alt-Gr 8" produces "•" instead of "[" for example, same for the other keys. Again, I've edited the /usr/share/X11/xkb/symbols/tr file (and have deleted all the *.xkm files in /var/lib/xkb) to get "—" by pressing "Alt-Gr -", but I get "≠" instead.

Can you help?

(System language US English, locale Turkey, keyboard layout Turkish f variant.)

Edit: Seems there's no solution for this. Absence of such a basic thing in the richest DE with all its (SSD killing, resource hungry and mostly useless and hated) features (akonadi, nepomuk, activities, strigi...) is very ironic.
User avatar bcooksley
Administrator
Posts
18599
Karma
83
OS
If you set the keyboard layout manually (using the appropriate X tools), does the Alt-Gr key function as you expect?
This could be a bug in the keyboard layout management included in KDE.


System Settings and Device Actions KCM maintainer
Image
aburak
Registered Member
Posts
14
Karma
0
bcooksley wrote:If you set the keyboard layout manually (using the appropriate X tools), does the Alt-Gr key function as you expect?
This could be a bug in the keyboard layout management included in KDE.


Thanks for the reply. No. But in login (kdm) window it works. Yes, KDE does something wrong. Have googled for hours and found the same issue again and again without any solution. Am using .Xcompose now (though Alt-Gr is easier).
User avatar bcooksley
Administrator
Posts
18599
Karma
83
OS
If you disable KDE keyboard layout handling (in System Settings > Input Devices > Keyboard, making sure both "Configure layouts" and "Configure keyboard options" are disabled) then does this have any impact?

Also, try disabling just one or the other to see if it has any effect.


System Settings and Device Actions KCM maintainer
Image
aburak
Registered Member
Posts
14
Karma
0
bcooksley wrote:If you disable KDE keyboard layout handling (in System Settings > Input Devices > Keyboard, making sure both "Configure layouts" and "Configure keyboard options" are disabled) then does this have any impact?

Also, try disabling just one or the other to see if it has any effect.


Agggrrrr! Why couldn't I think of this before?!! Yes, disabling "Configure keyboard options" solves the issue (and I've deleted the files inside /var/lib/xkb/ as usual). Thanks a lot.

For others: Since the compose key you set in the KDE settings are disabled as well, you need to manually set the compose key in terminal with this command (for Debian based distros):

sudo dpkg-reconfigure keyboard-configuration

 
Reply to topic

Bookmarks



Who is online

Registered users: apater, Azzart, Baidu [Spider], Bing [Bot], Exabot [Bot], GentooSimon, Google [Bot], HmpfCBR, irisuser, koriun, La Ninje, lazyit, Majestic-12 [Bot], mmistretta, navalgupte, onesandzeros, Sentynel, Yahoo [Bot]