Reply to topic

Customization kickoff upper icon

md02
Registered Member
Posts
5
Karma
0

Customization kickoff upper icon

Sat Feb 16, 2013 8:35 am
??? well, since a lot of time im looking how to change the upper icon Imagethe blue and grey banner placed on top when click kickoff menu, i kinda searched everywhere but i didnt found how change it, also when i click that icon it links me to "www.kde.org" i want to know where is the icon location, where i can disable the link to "www.kde.org" or remove icon and remove link
Image
User avatar bcooksley
Administrator
Posts
18607
Karma
83
OS

Re: Customization kickoff upper icon

Sat Feb 16, 2013 10:29 am
The image comes from the element "widgets/branding" in the current Plasma theme, and the link is the home page of that theme, as specified in it's metadata.


System Settings and Device Actions KCM maintainer
Image
md02
Registered Member
Posts
5
Karma
0
bcooksley wrote:The image comes from the element "widgets/branding" in the current Plasma theme, and the link is the home page of that theme, as specified in it's metadata.



thanks bcooksley!!!!
the images are at
/usr/share/kde4/apps/desktoptheme/default/widgets/branding.svgz
/usr/share/kde4/apps/desktoptheme/oxygen/widgets/branding.svgz
or
~/.kde/apps/desktoptheme/default/widgets/branding.svgz
when i saw at this images i didnt haved a svgz viewer then i didnt saw nothing till i installed inkscape at begining i was looking for a .png file

i changed the image and all was okay but... the image keeps link me to http://www.kde.org, i changed /usr/share/kde4/apps/desktoptheme/oxygen/metadata.desktop
X-KDE-PluginInfo-Website=http://www.testpage.com
but still liks to http://www.kde.org, originaly the "metadata.desktop" have this line: 'X-KDE-PluginInfo-Website=http://plasma.kde.org' and the link in branding icon links to a diferent url (http://www.kde.org)

any ideas where can i change the link?
User avatar bcooksley
Administrator
Posts
18607
Karma
83
OS
You need to add a section named "[Branding]" with a key of "homepage=http://example.org" below it to achieve the desired behaviour according to the code.

You can use the following command to verify it is done properly:
Code: Select all
kreadconfig --file /path/to/plasma/theme/metadata.desktop --group Branding --key homepage --default http://www.kde.org/


System Settings and Device Actions KCM maintainer
Image
md02
Registered Member
Posts
5
Karma
0
bcooksley wrote:You need to add a section named "[Branding]" with a key of "homepage=http://example.org" below it to achieve the desired behaviour according to the code.

You can use the following command to verify it is done properly:
Code: Select all
kreadconfig --file /path/to/plasma/theme/metadata.desktop --group Branding --key homepage --default http://www.kde.org/



i think i didnt got the idea....
but what i did its not working i did:
first add /usr/share/kde4/apps/desktoptheme/oxygen/metadata.desktop a line "homepage=http://example.org" and same at /usr/share/kde4/apps/desktoptheme/default/metadata.desktop also deleted "/usr/share/kde4/apps/desktoptheme/default/widgets/branding.svgz" and cleaned kde cache
and after
Code: Select all
root@test:~# kreadconfig --file /usr/share/kde4/apps/desktoptheme/default/metadata.desktop --group Branding --key homepage --default http://www.kde.org/

http://www.kde.org/

root@test:~# kreadconfig --file /usr/share/kde4/apps/desktoptheme/oxygen/metadata.desktop --group Branding --key homepage --default http://www.kde.org/

http://www.kde.org/


now i feel confused about what to do ??? i kinda looked in google about this subject but no one seems to know :O
md02
Registered Member
Posts
5
Karma
0
i forgot to mention after deleted "/usr/share/kde4/apps/desktoptheme/default/widgets/branding.svgz" and cleaned cache where is supposed to be the icon when i move mouse on hover and click it, still redirecting to kde.org, did a lots of reboots and cleaned cache and still nothing
User avatar bcooksley
Administrator
Posts
18607
Karma
83
OS
It appears that your modification of the file was not correct - please revert any changes you made and then run:
Code: Select all
kwriteconfig --file /usr/share/kde4/apps/desktoptheme/default/metadata.desktop --group Branding --key homepage <desired url>


This will ensure the change is made following the format of the file.


System Settings and Device Actions KCM maintainer
Image
md02
Registered Member
Posts
5
Karma
0
it worked tyvm!!!!!!!!!!!!!! ;D

 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], Bing [Bot], Dimitrios, Exabot [Bot], Google [Bot], hagabaka, Hans, koriun, La Ninje, Majestic-12 [Bot], mohali, msdobrescu, Steve Guilford, vascobasque, whatthefunk, Yahoo [Bot]