Reply to topic

kde-config-touchpad not starting

Fintan
Registered Member
Posts
88
Karma
0
OS

kde-config-touchpad not starting

Thu Feb 21, 2013 7:25 am
I have Kubuntu 12.10 and kde 4.10 installed on a friends vario laptop.

All I want to do is disable while typing. This should be easy.

kde-config-touchpad vers 0.8.1-1ubuntu2 just won't start.
It is in the systray but right or left clicking show now action.

Running in konsole shows:
fintan@fintanws2:~$ synaptiks
QDBusConnection: session D-Bus connection created before QCoreApplication. Application may misbehave.
QDBusConnection: session D-Bus connection created before QCoreApplication. Application may misbehave.
fintan@fintanws2:~$

Any help greatly appreciated
User avatar bcooksley
Administrator
Posts
18614
Karma
83
OS
Have you tried configuring it through the System Settings module instead? It should be at System Settings > Input Devices > Touchpad, if you have the software installed which I think you do..


System Settings and Device Actions KCM maintainer
Image
Fintan
Registered Member
Posts
88
Karma
0
OS
Yes, I have tried that. There is no option to disable keyboard when typing.

On my own laptop (HP pavilion dv6) System Settings > Input Devices > Touchpad crashes sytem settings. ???
User avatar bcooksley
Administrator
Posts
18614
Karma
83
OS
Is "synclient" installed, and does it produce valid output?


System Settings and Device Actions KCM maintainer
Image
Fintan
Registered Member
Posts
88
Karma
0
OS
On my laptop:
xserver-xorg-input-synaptics vers. 1.6.99+git20130104.ce7565ea-0ubuntu0sarvatt~quantal

intan@fintanws2:~$ synclient
Parameter settings:
LeftEdge = 1771
RightEdge = 5457
TopEdge = 1650
BottomEdge = 4626
FingerLow = 25
FingerHigh = 30
MaxTapTime = 180
MaxTapMove = 242
MaxDoubleTapTime = 180
SingleTapTimeout = 180
ClickTime = 100
EmulateMidButtonTime = 75
EmulateTwoFingerMinZ = 282
EmulateTwoFingerMinW = 7
VertScrollDelta = 110
HorizScrollDelta = 110
VertEdgeScroll = 0
HorizEdgeScroll = 0
CornerCoasting = 0
VertTwoFingerScroll = 1
HorizTwoFingerScroll = 0
MinSpeed = 1
MaxSpeed = 1.75
AccelFactor = 0.036324
TouchpadOff = 1
LockedDrags = 0
LockedDragTimeout = 5000
RTCornerButton = 0
RBCornerButton = 0
LTCornerButton = 0
LBCornerButton = 0
TapButton1 = 0
TapButton2 = 0
TapButton3 = 0
ClickFinger1 = 1
ClickFinger2 = 1
ClickFinger3 = 1
CircularScrolling = 0
CircScrollDelta = 0.1
CircScrollTrigger = 0
PalmDetect = 0
PalmMinWidth = 10
PalmMinZ = 200
CoastingSpeed = 20
CoastingFriction = 50
PressureMotionMinZ = 30
PressureMotionMaxZ = 160
PressureMotionMinFactor = 1
PressureMotionMaxFactor = 1
GrabEventDevice = 1
TapAndDragGesture = 1
AreaLeftEdge = 0
AreaRightEdge = 0
AreaTopEdge = 0
AreaBottomEdge = 0
HorizHysteresis = 8
VertHysteresis = 8
ClickPad = 0
fintan@fintanws2:~$

Disabling touchpad while typing works on my laptop.

I will have to check the vario later as it is not in front of me just now.
User avatar bcooksley
Administrator
Posts
18614
Karma
83
OS
Any status of the machine which is having the issue?


System Settings and Device Actions KCM maintainer
Image
colemickens
Registered Member
Posts
11
Karma
0

Re: kde-config-touchpad not starting

Sun Mar 10, 2013 11:45 am
I can disable my touchpad via `synclient PalmDetect=1`

I can also confirm that there is NOT an option for this feature in synaptiks, or I'm not finding it.
User avatar bcooksley
Administrator
Posts
18614
Karma
83
OS
If you would like to enable that on boot/login, you can place a executable script in ~/.config/autostart/ (with a .sh extension) and it will be executed by KDE as part of the general startup process.


System Settings and Device Actions KCM maintainer
Image
nickspacek
Registered Member
Posts
2
Karma
0
On Mint 14 synclient 1.6.2 I used: synclient TouchpadOff=1
User avatar bcooksley
Administrator
Posts
18614
Karma
83
OS

Re: kde-config-touchpad not starting

Sat Mar 16, 2013 12:21 am
Just a note that the options available will depend on your precise touch pad, and the drivers which your distribution shipped.
And to clarify, TouchpadOff=1 will always disable the touch pad, while PalmDetect=1 will only disable it when it detects a palm (ie. when you are typing on the keyboard).


System Settings and Device Actions KCM maintainer
Image

 
Reply to topic

Bookmarks



Who is online

Registered users: alake, anditosan, apater, Baidu [Spider], Bing [Bot], einar, Exabot [Bot], Google [Bot], google01103, koriun, La Ninje, lazyit, Majestic-12 [Bot], Mechatronic, mmistretta, paulus3005, pbCyanide, pedrorodriguez, random_fan, Robert Leleu, SeaJey, Sentynel, Sogatori, vascobasque, whatthefunk, Yahoo [Bot]