Reply to topic

[SOLVED] Ati - Problems with open drivers after fglrx remove

antoniusc
Registered Member
Posts
40
Karma
0
Hi,

I have ubuntu 12.04 and kde 4.10.1.

I have removed fglrx drivers 13.1 doing this:
Code: Select all
sudo     apt-get remove --purge fglrx fglrx_* fglrx-amdcccle* fglrx-dev*

I have also removed xorg.conf (it was in a guide)
Code: Select all
sudo rm /etc/X11/xorg.conf

and then I did
Code: Select all
sudo dpkg-reconfigure xserver-xorg

After reboot I have kde plasma-desktop crash every time and the Resolution is 1280x1024 but my maximum right resolution is 1920x1080 and I can't change it in kde settings menu.
Same resolution problem with any other desktop (unity 3d/2d and gnome classic).
I cannot use opengl in kde effects menu.

The output of glxinfo | grep render
Code: Select all
direct rendering: Yes
OpenGL renderer string: Gallium 0.4 on llvmpipe (LLVM 0x301)
    GL_NV_conditional_render, GL_AMD_draw_buffers_blend,

the output of:
glxinfo | grep -i opengl:
Code: Select all
OpenGL vendor string: VMware, Inc.
OpenGL renderer string: Gallium 0.4 on llvmpipe (LLVM 0x301)
OpenGL version string: 2.1 Mesa 9.0
OpenGL shading language version string: 1.20
OpenGL extensions:


here is my Xorg.0.log:
http://pastebin.com/raw.php?i=mPxeD99w

I have also added ppa "ubuntu-x-swat/x-updates" and upgrade my system, but it did not solve the problem.

My machine specs:
- gpu: msi/ati r6870 hawk
- cpu: i5-2500k sandy bridge
- motherboard: P8P67 PRO

Please help, thanks

Last edited by antoniusc on Tue Sep 10, 2013 2:00 pm, edited 1 time in total.
User avatar bcooksley
Administrator
Posts
18614
Karma
83
OS
From what I recall, llvmpipe is blacklisted for desktop effects usage because the CPU usage generated by llvmpipe are far outweighed by the benefits provided by Desktop Effects.

You need to use the appropriate driver for your graphics card to use Desktop Effects.

With regards to the Plasma Desktop crash, please provide the backtrace here.

Also, please provide the output of "xrandr" so we can diagnose the screen resolution issue.


System Settings and Device Actions KCM maintainer
Image
antoniusc
Registered Member
Posts
40
Karma
0
ok, I haeìve just tried to remove again my fglrx 13.1 in order to install new ones 13.4. After removing it starts crashing "/usr/bin/plasma-desktop"

I give you the latest lines from kern.log, don't know if it's helpful:
Code: Select all
Apr 27 09:51:32 user kernel: [  489.246720] fglrx_pci 0000:01:00.0: irq 64 for MSI/MSI-X
Apr 27 09:51:32 user kernel: [  489.247434] [fglrx] Firegl kernel thread PID: 2315
Apr 27 09:51:32 user kernel: [  489.247538] [fglrx] Firegl kernel thread PID: 2316
Apr 27 09:51:32 user kernel: [  489.247640] [fglrx] Firegl kernel thread PID: 2317
Apr 27 09:51:32 user kernel: [  489.247773] [fglrx] IRQ 64 Enabled
Apr 27 09:51:32 user kernel: [  489.335742] [fglrx] Gart USWC size:1228 M.
Apr 27 09:51:32 user kernel: [  489.335746] [fglrx] Gart cacheable size:487 M.
Apr 27 09:51:32 user kernel: [  489.335752] [fglrx] Reserved FB block: Shared offset:0, size:1000000
Apr 27 09:51:32 user kernel: [  489.335754] [fglrx] Reserved FB block: Unshared offset:fc26000, size:3da000
Apr 27 09:51:32 user kernel: [  489.335757] [fglrx] Reserved FB block: Unshared offset:3fff4000, size:c000

I don't know how to give you info about the plasma crash, if you tell me I'll give you more info.

and after reboot I have resolution problem, my maximum resolution is 1920x1080 but your command gives:
Code: Select all
xrandr: Failed to get size of gamma for output default
Screen 0: minimum 640 x 400, current 1280 x 1024, maximum 1280 x 1024
default connected 1280x1024+0+0 0mm x 0mm
   1280x1024       0.0*
   1280x960        0.0 
   1152x864        0.0 
   1024x768        0.0 
   800x600         0.0 
   640x480         0.0 
   720x400         0.0


Thanks
User avatar bcooksley
Administrator
Posts
18614
Karma
83
OS
The Xorg.0.log lines aren't helpful in this case unfortunately.
Can you please get a backtrace from the "Developer Information" section of the KDE Crash Assistant? You may need to install additional debugging packages in order for it to be able to generate a usable trace. Once it has done so, please post that here in quote tags.


System Settings and Device Actions KCM maintainer
Image
antoniusc
Registered Member
Posts
40
Karma
0
Hi,

Here is the error log from "Developer Information" section of the KDE Crash Assistant:
http://pastebin.com/raw.php?i=8stmVCky

I hope you can help me, I also purged virtualbox because I thought the virtualbox's driver was used after uninstalling fgrlx. But I have no fgrlx and the monitor resolution is still low (1280x1024) and it should be 1920x1080 and I still have plasma crash.

This is my xorg.conf:
http://pastebin.com/raw.php?i=D6MPUEZv

This is my Xorg.0.log:
http://pastebin.com/raw.php?i=dWDVe03t

I tried to add these following lines to "Monitor" section.:
Code: Select all
Modeline     "1920x1080_60.00"  173.00  1920 2048 2248 2576  1080 1083 1088 1120 -hsync +vsync
Option          "PreferredMode" "1920x1080_60.00"

and the following line to "Display" section:
Code: Select all
Modes   "1920x1080" "1280x1024" "1024x768"

but it didn't solve it.

I also upgraded to 13.04 and have kde 4.10.5.

Thanks
User avatar bcooksley
Administrator
Posts
18614
Karma
83
OS
I would suggest moving /etc/X11/xorg.conf out of the way - modern X is fully capable of automatically configuring itself.

The presence of "Gallium 0.4 on llvmpipe (LLVM 0x301)" in your previous output indicates that no native OpenGL capabilities are available - is the appropriate open source ATI driver installed? Also, have you rebooted since removing the fglrx driver, and has the fglrx kernel component been removed?

As for the crash - it is highly unusual, and is likely linked to a Python Plasma applet. Unfortunately as Plasma Desktop is totally unable to start, the only way to fix this is to move your Plasma Desktop configuration files elsewhere and fully reconfigure it. They can be found at ~/.kde4/share/config and are named "plasma-desktoprc" and "plasma-desktop-appletsrc".


System Settings and Device Actions KCM maintainer
Image
antoniusc
Registered Member
Posts
40
Karma
0
bcooksley wrote:I would suggest moving /etc/X11/xorg.conf out of the way - modern X is fully capable of automatically configuring itself.

The presence of "Gallium 0.4 on llvmpipe (LLVM 0x301)" in your previous output indicates that no native OpenGL capabilities are available - is the appropriate open source ATI driver installed? Also, have you rebooted since removing the fglrx driver, and has the fglrx kernel component been removed?

As for the crash - it is highly unusual, and is likely linked to a Python Plasma applet. Unfortunately as Plasma Desktop is totally unable to start, the only way to fix this is to move your Plasma Desktop configuration files elsewhere and fully reconfigure it. They can be found at ~/.kde4/share/config and are named "plasma-desktoprc" and "plasma-desktop-appletsrc".


ok no more problems with the crash, but also removing /etc/X11/xorg.conf did not solve the resolution problem: I still have lower resolution than maximum. I don't understand why.

fglrx is completely removed from ubuntu.
I'm not sure about having "the appropriate open source ATI driver installed", how can I check it?

Thanks
wolfi323
Registered Member
Posts
230
Karma
0
OS
antoniusc wrote:ok no more problems with the crash, but also removing /etc/X11/xorg.conf did not solve the resolution problem: I still have lower resolution than maximum. I don't understand why.

fglrx is completely removed from ubuntu.
I'm not sure about having "the appropriate open source ATI driver installed", how can I check it?

The radeon driver cannot be loaded because your kernel command line includes "nomodeset", probably as a left-over from your fglrx installation.
Remove that option and you should get the correct resolution again (and OpenGL effects).
antoniusc
Registered Member
Posts
40
Karma
0
wolfi323 wrote:
antoniusc wrote:ok no more problems with the crash, but also removing /etc/X11/xorg.conf did not solve the resolution problem: I still have lower resolution than maximum. I don't understand why.

fglrx is completely removed from ubuntu.
I'm not sure about having "the appropriate open source ATI driver installed", how can I check it?

The radeon driver cannot be loaded because your kernel command line includes "nomodeset", probably as a left-over from your fglrx installation.
Remove that option and you should get the correct resolution again (and OpenGL effects).


ok sorry but i don't know where to check that command and how can i remove it? thanks a lot

edit: ok maybe it's about grub: this is my /etc/default/grub:

Code: Select all
GRUB_TIMEOUT="10"
GRUB_DISTRIBUTOR="`lsb_release -i -s 2> /dev/null || echo Debian`"
GRUB_HIDDEN_TIMEOUT_QUIET="true"
GRUB_DEFAULT=saved
GRUB_GFXMODE=1920x1080
GRUB_SAVEDEFAULT="falseGRUB_BACKGROUND="
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset video=uvesafb:mode_option=1280x1024-24, mtrr=3, scroll=ywrap"
GRUB_CMDLINE_LINUX=""


I think I need nomodeset to use splash screen on start
wolfi323
Registered Member
Posts
230
Karma
0
OS
antoniusc wrote:I think I need nomodeset to use splash screen on start

Which splash screen?

Well, the radeon driver doesn't work at all with "nomodeset".
You are using the generic vesa driver now which causes the wrong resolution and missing OpenGL support.

Just try to remove "nomodeset", if you have problems then, you can always add it back again.

The other option would be to reinstall the fglrx driver, that one doesn't use KMS.
User avatar bcooksley
Administrator
Posts
18614
Karma
83
OS
With regards to removing nomodeset, this can usually be done on the fly at boot time as a one time operation for that boot.
To make the change permanent, it is usually necessary to edit /boot/grub/grub.cfg or /boot/grub/menu.lst (depending on the version of GRUB in use).


System Settings and Device Actions KCM maintainer
Image
antoniusc
Registered Member
Posts
40
Karma
0
bcooksley wrote:With regards to removing nomodeset, this can usually be done on the fly at boot time as a one time operation for that boot.
To make the change permanent, it is usually necessary to edit /boot/grub/grub.cfg or /boot/grub/menu.lst (depending on the version of GRUB in use).


I removed "nomodeset" option from /etc/default/grub and now I finally have the maximum resolution back. Now it is:
Code: Select all
GRUB_TIMEOUT="10"
GRUB_DISTRIBUTOR="`lsb_release -i -s 2> /dev/null || echo Debian`"
GRUB_HIDDEN_TIMEOUT_QUIET="true"
GRUB_DEFAULT=saved
GRUB_GFXMODE=1920x1080
GRUB_SAVEDEFAULT="falseGRUB_BACKGROUND="
GRUB_CMDLINE_LINUX_DEFAULT='quiet splash'
GRUB_CMDLINE_LINUX=""


The problem now is that when I decided to removed fglrx drivers to use open source drivers I wanted to use kernel 3.11 that has an optimization for open source radeon drivers, so after that I installed kernel 3.11 (my previous kernel was 3.8 ) and now I have resolution problem again, the /etc/default/grub is the new one from above but it does not work with kernel 3.11 like it was working with 3.8.

Do you know why? Thanks
User avatar bcooksley
Administrator
Posts
18614
Karma
83
OS
The /etc/default/grub file has little to do with it in this case. As mentioned, you need to customise the grub.cfg or menu.lst files.

If this issue has reappeared after installing a new kernel, it is probable that the fglrx driver has deposited files in /etc/grub (or changed them in place) which add "nomodeset" to your configuration entries every time the GRUB configuration is regenerated. Try checking there to see if anything is present. Files in this directory must be edited extremely carefully.


System Settings and Device Actions KCM maintainer
Image
antoniusc
Registered Member
Posts
40
Karma
0
bcooksley wrote:The /etc/default/grub file has little to do with it in this case. As mentioned, you need to customise the grub.cfg or menu.lst files.

If this issue has reappeared after installing a new kernel, it is probable that the fglrx driver has deposited files in /etc/grub (or changed them in place) which add "nomodeset" to your configuration entries every time the GRUB configuration is regenerated. Try checking there to see if anything is present. Files in this directory must be edited extremely carefully.


ok, I use grub2 so I would need to edit /boot/grub/grub.cfg, but I don't know how to edit it.

Yes the issue reappeared after installing new kernel, but I don't have fglrx driver anymore, I'm using open source drivers and /etc/default/grub is still the changed one so I can't see any modifications in it, I mean that there is no "nomodeset" option anymore in it.

thanks
User avatar bcooksley
Administrator
Posts
18614
Karma
83
OS
Any text editor should suffice to edit /boot/grub/grub.cfg although you will need root privileges to do so (ie. the text editor will need to be run as root using "kdesu" or "kdesudo").

Please be aware that incorrect editing may leave your computer unbootable. I would suggest opening it as a normal user first and simply searching for "nomodeset". If you have removed mentions of "nomodeset" from /etc/default/grub then all that is needed may be for the system to regenerate your GRUB configuration - more details on that can be found at https://wiki.debian.org/Grub


System Settings and Device Actions KCM maintainer
Image

 
Reply to topic

Bookmarks



Who is online

Registered users: Alexa [Bot], asevens, Baidu [Spider], Bing [Bot], binro, brand, doublerainbow64, Exabot [Bot], Google [Bot], google01103, inksi, jgrulich, koriun, lazyit, Majestic-12 [Bot], metzman, Murz, random_fan, rfinley, Sentynel, toad, Vindex17, whatthefunk, Yahoo [Bot], yurchor, zhou13