Reply to topic

Cannot type French accents

User avatar Dimitrios
Registered Member
Posts
639
Karma
0
OS

Cannot type French accents

Thu Jan 09, 2014 12:43 pm
I have a french keyboard with Greek localisation in KDE 4.10.5 and Mageia 3 64bit
Since many years i am not able to type accents for French letters in KDE/qt applications .
In Firefox and Libreoffice i am able to type accents without any problem
In Greek i can type accents without any problem
i installed the ibus-qt4 without succes, it did nt change anything in my problem
Exemple:
I can type the accents like:
^e ^u ^o

The same for the ¨ i type ¨ and after the letter but nothing happens (no output), i press a second time the letter and i see only the letter without the accent
In Libreoffice it works


«The magic continues...»
http://www.mageia.org
Image
luebking
Registered Member
Posts
923
Karma
7

Re: Cannot type French accents

Thu Jan 09, 2014 2:30 pm
http://userbase.kde.org/ComposeKey#Curr ... figuration

afaik the only deadkeys supported by XOrg would be grave, acute and circumflex - LO/OOo may have it's own key composition scheme based upon the used language, but since Ä would be composed by "+A, i assume this sucks as you'd to type '" A' to get '"A'?
User avatar Dimitrios
Registered Member
Posts
639
Karma
0
OS

Re: Cannot type French accents

Thu Jan 09, 2014 2:36 pm
No, i don't take any result when i type « ¨ + A »


«The magic continues...»
http://www.mageia.org
Image
luebking
Registered Member
Posts
923
Karma
7

Re: Cannot type French accents

Thu Jan 09, 2014 8:50 pm
I fear we're talking past each other.
To turn a key sequence into another (eg. diacretic) character, one requires a "compose key" - which does no longer exist on modern keyboards.
A reasonable approach is it to map it to the otherwise useless caps/lock key - by adding "compose:caps" to XkbOptions - i'm not aware of a key to generate the dicretic "¨" and the only xkb options i know in this regard are "deadgrave", "deadacute", "deadcircumflex".

I don't know about ibus behavior, but would suggest to just try "kwrite --noxim"
If that helps you, you can "export QT_NO_IM=1" in a ~/.kde/env scriptlet
User avatar Dimitrios
Registered Member
Posts
639
Karma
0
OS

Re: Cannot type French accents

Fri Jan 10, 2014 5:46 am
I tried from a new user and it works.
So it is a setting of my user
The "kwrite --noxim" did n't work
any idea where can be hidden this setting ?


«The magic continues...»
http://www.mageia.org
Image
luebking
Registered Member
Posts
923
Karma
7

Re: Cannot type French accents  Topic is solved

Fri Jan 10, 2014 7:25 am
kcmshell4 keyboard or qtconfig[-qt4], for the latter the default input method or xim style (Interface tab)
but that's just a very wild guess w/o an idea what's broken (since i apparently compose keys differently ;-)
User avatar Dimitrios
Registered Member
Posts
639
Karma
0
OS

Re: Cannot type French accents

Fri Jan 10, 2014 8:35 am
I launched the qtconfig, and in the tab interface, in the section 'Default input method' i chose 'ibus'
Now i can type accents normally!

I have a message in the terminal when launching qtconfig but i don't see any problem:

QInotifyFileSystemWatcherEngine::addPaths: inotify_add_watch failed: No such file or directory
QFileSystemWatcher: failed to add paths: /home/dglent/.config/ibus/bus
Bus::open: Can not get ibus-daemon's address.
IBusInputContext::createInputContext: no connection to ibus-daemon


Thanks :)


«The magic continues...»
http://www.mageia.org
Image

 
Reply to topic

Bookmarks



Who is online

Registered users: Alexa [Bot], asevens, Baidu [Spider], Bing [Bot], binro, brand, doublerainbow64, Exabot [Bot], Google [Bot], google01103, inksi, jgrulich, koriun, lazyit, Majestic-12 [Bot], metzman, Murz, random_fan, rfinley, Sentynel, toad, Vindex17, whatthefunk, Yahoo [Bot], yurchor, zhou13