Reply to topic

[SOLVED] Screen saver cannot be disabled. Aaargh!

User avatar zwede
Registered Member
Posts
29
Karma
0
OS
I have Kubuntu 8.10, KDE 4.2 on my HTPC. Since it's a HTPC I don't want a screen saver kicking in in the middle of watching a movie. But for some reason no matter what the screen saver kicks in every 15 minutes. MPlayer is supposed to disable it, but can't. I have set the screen saver to never come on, but it still does.

Here is the content of my .kde/shar/config/kscreensaverrc:

[ScreenSaver]
Enabled=false
Lock=false
LockGrace=60000
PlasmaEnabled=false
Saver=KClock.desktop
Timeout=60

It will come on after 15 minutes, AND requires a password to unlock. BTW, it is the clock screen saver that comes on, just like it says in the config file. I can change to another screen saver and it will honor that setting, but ignores all other settings in kscreensaverrc.

Any ideas as to what's going on and how I can stop it?


Gentoo Linux x64. Intel Core 2 Quad.
User avatar bcooksley
Administrator
Posts
18669
Karma
83
OS
KDE 4.2 stores its configuration in ~/.kde4 on most distros. "kscreensaverrc" is not used in KDE 4. I do not know where the configuration file is, but there are options for configuring the Screensaver in System Settings > Desktop.


System Settings and Device Actions KCM maintainer
Image
User avatar goltor
Registered Member
Posts
1
Karma
0
OS
This was driving me insane but I found the answer...

You need to disable this in System Settings -> Advanced -> Power Management. You then need to disable the "Lock screen on resume" option and also edit the profile. In the General Settings check which Profile you are using, go to Edit Profiles, select the relevant profile and change the "When the system is idle for more than" option.
User avatar zwede
Registered Member
Posts
29
Karma
0
OS
Thanks! I found the settings and hopefully that will be the last of the screen saver!


Gentoo Linux x64. Intel Core 2 Quad.
bkorb
Registered Member
Posts
46
Karma
0
goltor wrote:This was driving me insane but I found the answer...

You need to disable this in System Settings -> Advanced -> Power Management. You then need to disable the "Lock screen on resume" option and also edit the profile. In the General Settings check which Profile you are using, go to Edit Profiles, select the relevant profile and change the "When the system is idle for more than" option.


NO UI person should be so obtuse as to make such a simple, obvious, common, ordinary action be this difficult. That is plain crazy. What is the simple answer? I've been struggling and hating this silly thing for months.....Besides, I don't have "Lock screen on resume" checked and it still happens.

EDIT NOTE: I am just now trying something I had not found before:

power management -> edit profiles -> actions -> \
when the system is idle for more than <15 min> == *DO NOTHING*
(instead of "lock screen").

So, in summary, there seem to be *THREE* ways to have your screen automatically locked:

1. screen saver

2. power mangement -> general settings -> settings and profile --> \
Lock screen on resume

3. power management -> edit profiles -> actions -> \
when the system is idle for more than <15 min> == \
Lock screen

Question to KDE folks: What are you thinking? or: Are you thinking?

Sorry to be such a rude SOB, but if something is this difficult
and it causes so many people to struggle and stumble for so long,
surely you must recognize that there is a problem. You
really ought to do something about it. Yet the problem persists
and it seems as if it is considered a feature. So I have chosen
to reveal that I personally find it very irritating.

If this latest discovery does not fix the issue, then I'll be back,
otherwise it has finally been fixed.

 
Reply to topic

Bookmarks



Who is online

Registered users: apater, areid, Baidu [Spider], Bing [Bot], braystacey, edmael, einar, Exabot [Bot], garthecho, Google [Bot], google01103, ivan, jensreuterberg, joaob, jpwhiting, jstaniek, La Ninje, lazyit, Majestic-12 [Bot], mmistretta, MSN [Bot], pedrorodriguez, salvochea, scottpetrovic, scummos, SeaJey, SecretCode, slangkamp, slawekk, Sogou [Bot], SysGhost, TheraHedwig, tienhung, Tioz, VP1986, Yahoo [Bot], šumski