Reply to topic

Getting rid of printer-applet

User avatar Vortex375
Registered Member
Posts
102
Karma
0
OS

Getting rid of printer-applet

Mon Aug 16, 2010 12:59 am
I don't even have a printer, but KDE 4.5 starts the "Printer Applet" each time I log in. No matter how many times I close it, it always starts again when I log in. ;)

It's no big deal but it still wastes a small amount of memory and clutters my systray unnecessarily.

How can I disable the printer-applet?
User avatar bcooksley
Administrator
Posts
18586
Karma
83
OS

Re: Getting rid of printer-applet

Mon Aug 16, 2010 5:19 am
Create a file named "printer-applet.desktop" in ~/.config/autostart with the following content:
Code: Select all
[Desktop Entry]
Hidden=true


System Settings and Device Actions KCM maintainer
Image
User avatar Vortex375
Registered Member
Posts
102
Karma
0
OS

Re: Getting rid of printer-applet

Mon Aug 16, 2010 9:18 pm
That worked, thanks - but how do you know this? It doesn't seem straight-forward to me...
User avatar bcooksley
Administrator
Posts
18586
Karma
83
OS

Re: Getting rid of printer-applet

Tue Aug 17, 2010 5:15 am
If the Hidden property is set on a *.desktop file, then the Menu will not show it, and applications shouldn't detect it either. As a result, auto started applications follow this rule also.


System Settings and Device Actions KCM maintainer
Image
User avatar Vortex375
Registered Member
Posts
102
Karma
0
OS

Re: Getting rid of printer-applet

Tue Aug 17, 2010 5:10 pm
This is interesting.

So basically the system scans the .desktop files located in /usr/share/autostart/ and then those in ~/.config/autostart and merges options from both locations together.

Thus by creating a printer-applet.desktop in ~/.config/autostart and adding options to it I can overwrite or extend the .desktop entry from /usr/share/autostart/.

Umm, is that about right? ;D
User avatar bcooksley
Administrator
Posts
18586
Karma
83
OS

Re: Getting rid of printer-applet

Wed Aug 18, 2010 5:35 am
Yes, that is correct.


System Settings and Device Actions KCM maintainer
Image
User avatar RangerGR
Registered Member
Posts
8
Karma
0
OS

Re: Getting rid of printer-applet

Wed Aug 25, 2010 10:32 pm
This trick prevents printer-applet from startig or it just hides it?
Is there any way to simple don't start it at all?
User avatar bcooksley
Administrator
Posts
18586
Karma
83
OS

Re: Getting rid of printer-applet

Thu Aug 26, 2010 5:42 am
It stops it from starting altogether as far as I know.


System Settings and Device Actions KCM maintainer
Image
User avatar whashnez
Registered Member
Posts
88
Karma
0
OS

Re: Getting rid of printer-applet

Mon Aug 30, 2010 8:00 am
If I just delete printer-applet.desktop from /usr/share/autostart won't be an easier solution?


Well good job Einstein, why don't we build a rocket in the meantime...
User avatar bcooksley
Administrator
Posts
18586
Karma
83
OS

Re: Getting rid of printer-applet

Mon Aug 30, 2010 8:32 am
That will apply to all users, and will be undone automatically by your package manager when you update / upgrade. In addition, it needs root access. The above solution is the most portable and reliable in the long term.


System Settings and Device Actions KCM maintainer
Image
User avatar whashnez
Registered Member
Posts
88
Karma
0
OS

Re: Getting rid of printer-applet

Mon Aug 30, 2010 8:35 am
You' re right! Thanks for your reply!


Well good job Einstein, why don't we build a rocket in the meantime...
User avatar RangerGR
Registered Member
Posts
8
Karma
0
OS

Re: Getting rid of printer-applet

Tue Aug 31, 2010 6:46 pm
bcooksley wrote:The above solution is the most portable and reliable in the long term.


You are right, this solution is the most portable and reliable, right now.
But the proper way should be adding "printer-applet" in "Applications to be excluded from sessions" section is system settings.
Unfortunately, this doesn't works for now (KDE 4.5.1)
Kryten2X4B
Registered Member
Posts
911
Karma
4
OS

Re: Getting rid of printer-applet

Tue Aug 31, 2010 6:55 pm
RangerGR wrote:But the proper way should be adding "printer-applet" in "Applications to be excluded from sessions" section is system settings.
Unfortunately, this doesn't works for now (KDE 4.5.1)


If so (I don't even have it installed myself) it should be considered a bug and as such a bug-report should be filed - preferably by someone affected by the bug. Not sure if the bug is in the applet or in the sessions management system though.


OpenSUSE 11.4, 64-bit with KDE 4.6.4
Proud to be a member of KDE forums since 2008-Oct.
User avatar RangerGR
Registered Member
Posts
8
Karma
0
OS

Re: Getting rid of printer-applet

Tue Aug 31, 2010 7:09 pm
Kryten2X4B wrote:
RangerGR wrote:But the proper way should be adding "printer-applet" in "Applications to be excluded from sessions" section is system settings.
Unfortunately, this doesn't works for now (KDE 4.5.1)

Not sure if the bug is in the applet or in the sessions management system though.


The bug (not sure if this is a bug) is in the sessions management system. You can add any application, lets say konsole. Start konsole and logout without closing it. In your next login, konsole will start.
Kryten2X4B
Registered Member
Posts
911
Karma
4
OS

Re: Getting rid of printer-applet

Tue Aug 31, 2010 7:22 pm
RangerGR wrote:The bug (not sure if this is a bug) is in the sessions management system. You can add any application, lets say konsole. Start konsole and logout without closing it. In your next login, konsole will start.


I think it might be a bit more complicated than that. I have a few apps listed there, and they are never started on login no matter if they were running when I logged out or not. For Kontact I needed a bit of a workaround though: adding the full path rather than just the program name.


OpenSUSE 11.4, 64-bit with KDE 4.6.4
Proud to be a member of KDE forums since 2008-Oct.

 
Reply to topic

Bookmarks



Who is online

Registered users: alexweb, Baidu [Spider], Bing [Bot], dgraf, Exabot [Bot], ggael, Google [Bot], GreatEmerald, ken300, koriun, lazyit, netpalantir, numbchild, paulus3005, pbCyanide, rulet111, Tsukasa Buddha, valoriez, vascobasque, wolfi323, Yahoo [Bot], Zagupi