Reply to topic

KDE not initializing after logging in

dan0512
Registered Member
Posts
7
Karma
0
OS
Greetings

I found myself some spare time this sunday to play around with some settings, but it seems that something's gone wrong.

Specifically, I changed the default blue "theme" of the login prompt (not the splash) to the black official oxygen version, that's it. I remember when I clicked on "apply" that the system gave me a warning about not being able to set a background image, to which I didn't pay much attention.

Now, after rebooting, I arrive at the login prompt which looks very generic and dull. Probably due to the mentioned warning, but the real problem is that when I log myself in, KDE won't initialize, I just get a blue background and a generic X console at the top left of my screen.

I've tried changing the login options, i.e. choosing KDE-failsafe, and all the other options, but I still have the same result.

Can someone help me get KDE back? :-)

I'm running KDE 4.5 and arch.
User avatar bcooksley
Administrator
Posts
18586
Karma
83
OS
In the terminal that opens when you login, please run "startkde"


System Settings and Device Actions KCM maintainer
Image
dan0512
Registered Member
Posts
7
Karma
0
OS
Executing startkde initializes KDE fine (though the console is still open, can't close it otherwise I will be logged out). Good to know this command starts KDE up ;-)

I took a look at /usr/share/config/kdm/Xsession , I can't say whether it's intact or not, but from a quick glance it seems to be O.K. (i.e. default) exec /usr/bin/startkde)
User avatar bcooksley
Administrator
Posts
18586
Karma
83
OS
Not sure what is wrong then. Maybe check ~/.xinitrc or the session selected to be started on the login screen?


System Settings and Device Actions KCM maintainer
Image
dan0512
Registered Member
Posts
7
Karma
0
OS
Hmm, I couldn't find a .xinitrc file in my home directory.

KDM won't start KDE regardless of which session I choose.

Here is my kdmrc file though. Do you think anything is missing?
Code: Select all
[Shutdown]
BootManager=None
HaltCmd=/sbin/halt
RebootCmd=/sbin/reboot

[X-*-Core]
AllowShutdown=Root
AutoReLogin=false

[X-*-Greeter]
AntiAliasing=false
ColorScheme=
FaceSource=AdminOnly
FailFont=Sans Serif,10,-1,5,75,0,0,0,0,0
GUIStyle=
GreetFont=Serif,20,-1,5,50,0,0,0,0,0
GreetString=Willkommen zu %s auf %n
GreeterPos=50,50
HiddenUsers=
Language=en_US
LogoArea=Logo
LogoPixmap=
MaxShowUID=65000
MinShowUID=500
SelectedUsers=
ShowUsers=NotHidden
SortUsers=true
StdFont=Sans Serif,10,-1,5,50,0,0,0,0,0
Theme=/usr/share/apps/kdm/themes/oxygen-air
UseBackground=true
UseTheme=true
UserCompletion=false
UserList=false

[X-:*-Core]
AllowShutdown=All
NoPassEnable=false
NoPassUsers=

[X-:*-Greeter]
DefaultUser=daniel
FocusPasswd=false
PreselectUser=None

[X-:0-Core]
AutoLoginEnable=false
AutoLoginLocked=false
AutoLoginUser=



regards
User avatar bcooksley
Administrator
Posts
18586
Karma
83
OS
If you move that file elsewhere, and restart KDM ( run "service xdm restart" in a virtual terminal ) does it work?


System Settings and Device Actions KCM maintainer
Image
dan0512
Registered Member
Posts
7
Karma
0
OS
The xdm service in my machine is not present, did you mean kdm?

Anyways, I moved the kdmrc file and restarted the kdm service, but it didn't help with the login problem. The only noticeable difference is that it changed the login theme back to the generic one again (after I had changed it to the original oxygen theme by starting KDE via startkde) ...

Thanks for your help up to here, I hope I can find a solution soon.
User avatar bcooksley
Administrator
Posts
18586
Karma
83
OS
Is any error message given out when KDE startup fails? It certainly seems like you have the wrong session type selected ( or the session files are corrupt, they are somewhere under /usr I believe )


System Settings and Device Actions KCM maintainer
Image
dan0512
Registered Member
Posts
7
Karma
0
OS
bcooksley wrote:Is any error message given out when KDE startup fails?


Nope, I don't get any errors. After typing in my password and clicking on "login" it just drops me directly to the screen with the console and generic background, I think it's the failsafe session.

Then, when I type startkde and initialize KDE, I don't get any errors either.

It certainly seems like you have the wrong session type selected ( or the session files are corrupt, they are somewhere under /usr I believe )


Do you mean that I have the wrong session selected in a config file? As I said, regardless of which session I choose in the login screen, it just drops me to this session with the console.

regards
dan0512
Registered Member
Posts
7
Karma
0
OS
Ok, it seems I was able to get it back to work.

Running genkdmconf as root fixed the problem ;-)

Regards

 
Reply to topic

Bookmarks



Who is online

Registered users: airdrik, Alexa [Bot], Baidu [Spider], Bing [Bot], edmael, Exabot [Bot], garthecho, Google [Bot], Google Adsense [Bot], google01103, Hans, igorm, jgrulich, kde-deshmukh, koriun, La Ninje, metalbrick, mixoff, MrGlaceon, numbchild, ooker, pinguin74, private_lock, psbot [Picsearch], scummos, SecretCode, Steve Guilford, TheraHedwig, Yahoo [Bot]