Reply to topic

brightness control failed in user profile

Olaf35
Registered Member
Posts
8
Karma
0
OS
Hello,

I have a problem with brightness control in my user profile. In my root profile it works very well. If I start kde (version 4.6.1 on slackware linux) with my user profile I get an error:

kded(2090) PowerDevilUPowerBackend::brightness: org.kde.powerdevil.backlighthelper.brightness failed
kded(2090) PowerDevilUPowerBackend::setBrightness: org.kde.powerdevil.backlighthelper.setbrightness failed

Both services fails. With my root profile it shows:

QDBusConnection: name 'org.kde.kglobalaccel' had owner '' but we thought it was ':1.5'
Debug message from helper: brightness: 7
Debug message from helper: max brightness: 7
Debug message from helper: data contains: QVariant(int, 100)
Debug message from helper: max brightness: 7
Debug message from helper: setting brightness: 7
Debug message from helper: brightness: 7
Debug message from helper: max brightness: 7
Debug message from helper: data contains: QVariant(int, 100)
OpenGL vendor string: NVIDIA Corporation

I think this is a permission problem, but I can't solve it. I guess the services does not start with root privileges. Has anyone experience to show me what I have to do to get it working? How can I control that the brightness services started with root privileges?

Thank you for your help.
Olaf
Olaf35
Registered Member
Posts
8
Karma
0
OS
@Administrator

Hello,

why was it moved to a dead area, I think it's a workspace issue?
Please move it back to the KDE workspace area.

Thank you
User avatar bcooksley
Administrator
Posts
18657
Karma
83
OS
According to our logs, this post was moved from the Forum Feedback area, to the KDE Workspace area to better match what it requires help with. No other movements or changes have been made.

The messages:
kded(2090) PowerDevilUPowerBackend::brightness: org.kde.powerdevil.backlighthelper.brightness failed

indicate that you likely don't have the appropriate permissions on either D-Bus or PolicyKit, to make the brightness change. Please contact your distribution, as they are responsible for ensuring that is in place.


System Settings and Device Actions KCM maintainer
Image
Olaf35
Registered Member
Posts
8
Karma
0
OS
Thank you for your answer.

In my slackware 13.1 KDE 4.5.5 environment the tip with the DBus config helps me. In the /etc/dbus-1/system.d/hal.conf i've seen, that i've to be a member of the haldaemon group. After a reboot I could control the brightness and the power management in my user profile. But in this environment I dont use the backlighthelper.

In my slackware-current KDE 4.6.1 environment I use the new backlighthelper. This backlighthelper has an own dbus configuration file in /etc/dbus-1/system.d/org.kde.powerdevil.backlighthelper.conf and I don't know the entries that are missing. I've tried something in the hal.conf, org.kde.powerdevil.backlighthelper.conf and in the org.freedesktop.UPower.conf but after reboot nothing works. I don't know which module wants to communicate with the backlighthelper and fails.
I guess, my system distributor can't help me, not even google can help me in this case and this disappoint me.

The file /etc/dbus-1/system.d/org.kde.powerdevil.backlighthelper.conf has the following content:

<!DOCTYPE busconfig PUBLIC
"-//freedesktop//DTD D-BUS Bus Configuration 1.0//EN"
"http://www.freedesktop.org/standards/dbus/1.0/busconfig.dtd">
<busconfig>

<!-- Only user root can own the foo helper -->
<policy user="root">
<allow own="org.kde.powerdevil.backlighthelper"/>
</policy>

</busconfig>

The file /usr/share/polkit-1/action/org.kde.powerdevil.backlighthelper.policy also exists.

Notice, in my root profile of the slackware-current KDE 4.6.1 environment everything works very well. In the user profile I can control the brightness with the function keys of the laptop.

Has anybody experience with the DBus and Polkit stuff and can help me?

Thank you
Olaf
User avatar bcooksley
Administrator
Posts
18657
Karma
83
OS
In this case, it is the /usr/share/polkit-1/action/org.kde.powerdevil.backlighthelper.policy file which is important. Unfortunately, I don't know how to alter these files, although I can refer you to the polkit-1 documentation on policy files: http://hal.freedesktop.org/docs/polkit/

Hopefully those are the right ones...


System Settings and Device Actions KCM maintainer
Image
Olaf35
Registered Member
Posts
8
Karma
0
OS
Thank you very much.

That was it. I added the entry

<action id="org.kde.powerdevil.backlighthelper.brightness">
...
<defaults>
<allow_any>yes</allow_any>
...
</defaults>
</action>
<action id="org.kde.powerdevil.backlighthelper.setbrightness">
...
<defaults>
<allow_any>yes</allow_any>
...
</defaults>
</action>

to the /usr/share/polkit-1/action/org.kde.powerdevil.backlighthelper.policy
and it works.

Greetings from Germany to Newseeland!
Olaf
molecule-eye
Registered Member
Posts
277
Karma
0
OS
Olaf35 wrote:Thank you very much.

That was it. I added the entry

<action id="org.kde.powerdevil.backlighthelper.brightness">
...
<defaults>
<allow_any>yes</allow_any>
...
</defaults>
</action>
<action id="org.kde.powerdevil.backlighthelper.setbrightness">
...
<defaults>
<allow_any>yes</allow_any>
...
</defaults>
</action>

to the /usr/share/polkit-1/action/org.kde.powerdevil.backlighthelper.policy
and it works.
Olaf


Unfortunately this didn't work for me. My ~/.xsession-errors also shows "org.kde.powerdevil.backlighthelper.brightness failed". I'm using the latest Catalyst blobs (13.3 beta 3) with a 7600D (APU graphics). Display dimming and brightness controls do not work. Since this isn't a laptop, I don't have dedicated brightness controls to check, so I'm just using the slider in the Energy Saving KDE module.
User avatar bcooksley
Administrator
Posts
18657
Karma
83
OS
Does your screen physically support changing brightness?
It is quite possible that the helper is failing because physical hardware support is missing.

Running the following command may indicate if the drivers expose support for changing brightness:
Code: Select all
find /sys/devices/ | grep -i brightness


System Settings and Device Actions KCM maintainer
Image
molecule-eye
Registered Member
Posts
277
Karma
0
OS
It supports changing brightness using hardware controls (it's a new 21.5" LCD, Philips 227ELH). find /sys/devices/ | grep -i brightness returns

/sys/devices/pci0000:00/0000:00:15.0/0000:02:00.0/leds/ath9k-phy0/brightness
/sys/devices/pci0000:00/0000:00:15.0/0000:02:00.0/leds/ath9k-phy0/max_brightness

which is alien to me.
User avatar bcooksley
Administrator
Posts
18657
Karma
83
OS
Those brightness controls are for the LED which is attached to your wireless network card unfortunately - and are not attached to your screen.
This is indicated by the "ath9k" which is the driver for Atheros wireless network cards of a certain generation (which are usually 802.11n capable).

If your Philips monitor is supposed to support changing it's brightness via instructions from the computer, then you'll need to ask them if any special software is needed to support this arrangement (DVI and VGA don't support this sort of arrangement, so it would require a separate cable).


System Settings and Device Actions KCM maintainer
Image
molecule-eye
Registered Member
Posts
277
Karma
0
OS
Oh really? I didn't know that DVI doesn't support that. I'm running off an HDMI cable but I wouldn't be surprised if it doesn't support it either then. So on laptops, they use some sort of non-DVI connection between the LCD and video card? Interesting.
User avatar bcooksley
Administrator
Posts
18657
Karma
83
OS
Yes, most current generation systems use a "LVDS" connection between the screen and physical system, with newer machines switching to "eDP" or embedded displayport. I'm not sure how involved they are with screen brightness however, or if it works through another sort of arrangement involving separate hardware instead.


System Settings and Device Actions KCM maintainer
Image

 
Reply to topic

Bookmarks



Who is online

Registered users: adabrowski, Alexa [Bot], Baidu [Spider], Bing [Bot], bjoernbalazs, CyberAngel, edmael, Exabot [Bot], Felix VI, firewalker, Google [Bot], gp[], jensreuterberg, lazyit, maggy, MSNbot Media, nezumi, orbmiser, pbCyanide, salvochea, sebas, stavallo, TheraHedwig, Uri_Herrera, Yahoo [Bot]