Reply to topic

Applications opening on the wrong monitor

tnt533
Registered Member
Posts
4
Karma
0
OS
I am currently running Linux Mint 10 with KDE 4.6 using a nVidia 8800 GTX with two LCD monitors. I have them defined with my main monitor on the left as absolute and my secondary display on the right as "right of". My primary display is also defined as primary by putting a check in the box which says "Make this the primary display for the X screen". I'm using twinview.

When I open up most applications they always default to opening on my secondary display instead of my main display. This isn't a game changer or deal killer but annoying just the same and I can't seem to figure out how to change the behaviour. I would really like applications to open on my primary display and then, if I so choose, drag them to the right to my secondary display. I end up dragging 90% of windows that open to the left and see that as a total waste of productivity.

Does anyone have any insight into how I could change the configuration to make the x server behave the way I desire?
User avatar einar
Administrator
Posts
2268
Karma
5
OS
I've seen this bug, and I'm not sure there's a fix for it yet. I know however that substantial work is planned for multi-monitor fixes for the next release (4.8, although smaller fixes have found their way already for 4.7.1).


"Violence is the last refuge of the incompetent."
Image
Plasma FAQ maintainer - Plasma programming with Python
tnt533
Registered Member
Posts
4
Karma
0
OS
einar wrote:I've seen this bug, and I'm not sure there's a fix for it yet. I know however that substantial work is planned for multi-monitor fixes for the next release (4.8, although smaller fixes have found their way already for 4.7.1).


I appreciate your response. I know that the lack of good multi-head support in KDE is one of the reasons why I decided on gnome years ago. I made the switch to KDE a few weeks ago because of the impending death of Gnome 2.x and I really can't stand Gnome3/Unity.

So far KDE 4.6 is rockin' my world but I notice little issues here and there that really don't make sense as to why they have not been addressed. The right click menu on the desktop for instance. I have to do it twice every time for it to come up. They are far enough into releases for KDE that the small usability stuff should have either been addressed already or should be on their hot-sheet.

I hope you're right about multi-head support being refined in 4.8.
tnt533
Registered Member
Posts
4
Karma
0
OS
I wonder if simply switching the physical outputs on the video adapter would make a difference.
PeteAsdf
Registered Member
Posts
1
Karma
0
OS
Hi, have you found a solution to this? I'm having the same problem with my setup (KDE 4.6 on nVidia 8800 GT). What is even more annoying on my setup is that my secondary screen is a TV that is usually switched off and some apps keep on opening there. Sometimes I need to switch the TV on just to be able to drag the windows to my monitor.

Thanks
wes33
Registered Member
Posts
100
Karma
1
Sometimes I need to switch the TV on just to be able to drag the windows to my monitor.


this is a real pain which I suffer from - after unpluggin my projector,
kde still thinks the desktop is "double sized"

a pathetic workaround: using the pager you can drag the tiny
windows to put them on the visible part of the screen ...
User avatar waldelf
Registered Member
Posts
333
Karma
0
OS
i think i solved this problem by switching primary output from dvi1 to dvi2 (and then back to dvi1).. first the taskbar moved to the right and all programs still opened on dvi2 instead of dvi1 (what would be correct because it's now the primary output device

but when i switched back to the previous configuration (set dvi-1 as primary) it suddenly worked as expected.. all programs now open on dvi-1 the primary output..

it would be really nice to be able to configure which program should open on which screen


Kubuntu 12.04 x64 | KDE SC 4.8
Nvidia 8800 GTS | Core2Duo E6600 | 4 GB RAM
User avatar bcooksley
Administrator
Posts
18556
Karma
83
OS
Have you tried the "Active screen follows mouse" option in System Settings > Window Behaviour > Window Behaviour?


System Settings and Device Actions KCM maintainer
Image
User avatar waldelf
Registered Member
Posts
333
Karma
0
OS
ah.. no i didn't ... seems like a solution for now... thx..

but a better one is coming.. i just read that this bug https://bugs.kde.org/show_bug.cgi?id=183996
is "fixed" in 4.10
http://techbase.kde.org/Schedules/KDE4/ ... ature_Plan


Kubuntu 12.04 x64 | KDE SC 4.8
Nvidia 8800 GTS | Core2Duo E6600 | 4 GB RAM

 
Reply to topic

Bookmarks



Who is online

Registered users: AGB, Baidu [Spider], Bing [Bot], boudewijn, colomar, Cris70, einar, Exabot [Bot], gldvorak, Google [Bot], GreatEmerald, jstaniek, ken300, khsien, koriun, Majestic-12 [Bot], metzman, MSN [Bot], odysseus-art, pbCyanide, r2rStep, scummos, seal20, sir_herrbatka, TheraHedwig, Tuukka, Yahoo [Bot]