Reply to topic

KDE 4.7 - Removing the autostart launchers from the panel

Dastingo
Registered Member
Posts
2
Karma
0
OS
Hello everyone,

First thanks for the awesome KDE, I've been using it since 4.6 and I really love it, awesome job. :)

I use Arch Linux and since the update to KDE 4.7 I started seeing two launchers in the panel (Dolphin and Firefox), every time I remove them they keep coming back when I re-login and can't get rid of them.

I use the Lancelot menu so all my launchers are there. Is there a way to completely prevent those launchers from appearing in the panel?

Sorry if it has been posted before but I searched a lot and found no answer.

Thanks.
User avatar google01103
Manager
Posts
4965
Karma
17
OS
not normal behavior, does your panel exhibit any other unusual behavior? if you add a new different launcher (say Kate) does it appear after a restart? are all changes to the panel retained after a restart?


OpenSuse 13.1 x64, KDE 4.12.x

Problem solved? Please click on Image below the post with the best answer to mark your topic as solved.
Dastingo
Registered Member
Posts
2
Karma
0
OS
Other panel settings are retained no issues there.

I found out how to fix it:

In ~/.kde4/share/config/plasma-desktop-appletsrc find and delete (or comment out)

Code: Select all
browser=preferred://browser, , ,\s
filemanager=preferred://filemanager, , ,\s


This will prevent the launchers from appearing when I login.

So, marking it [SOLVED] i guess. ;)
User avatar google01103
Manager
Posts
4965
Karma
17
OS


OpenSuse 13.1 x64, KDE 4.12.x

Problem solved? Please click on Image below the post with the best answer to mark your topic as solved.
asdx
Registered Member
Posts
1
Karma
0
Dastingo wrote:Other panel settings are retained no issues there.

I found out how to fix it:

In ~/.kde4/share/config/plasma-desktop-appletsrc find and delete (or comment out)

Code: Select all
browser=preferred://browser, , ,\s
filemanager=preferred://filemanager, , ,\s


This will prevent the launchers from appearing when I login.

So, marking it [SOLVED] i guess. ;)


Thanks but no thanks. I would have to disagree in marking this issue as [SOLVED]. I hate workarounds like this, they are NOT fixes and they prevent the real issue from being fixed.

I don't think this issue is fixed UNTIL I can right click (with the click of my mouse) over the icon launchers and remove them (with the click of the mouse) and never see the icon again. This of course WITHOUT starting a terminal or a text editor to edit that config file.

Until this issue isn't fixed with a real fix in upstream and until we can test that the issue is solved with a fresh KDE install, or that the launchers don't repear after a few restarts, I would recommend abstaining from closing the forum or bug thread as solved.

We need to do things the right way.
User avatar bcooksley
Administrator
Posts
18657
Karma
83
OS
If the manual fix is required to fix this, then the issue still exists. Please file a bug at bugs.kde.org regarding that, as this is not the correct behaviour of the system.


System Settings and Device Actions KCM maintainer
Image

 
Reply to topic

Bookmarks



Who is online

Registered users: Alexa [Bot], Baidu [Spider], Bing [Bot], bshah, Exabot [Bot], Google [Bot], grubaugh, Hans, Naver Yeti [Spider], onesandzeros, orbmiser, pedrorodriguez, pvonz, qwach, searchfgold6789, Uri_Herrera, Yahoo [Bot]