Reply to topic

[SOLVED] Krunner doesn't auto launch

hypertyper
Registered Member
Posts
6
Karma
0
OS

[SOLVED] Krunner doesn't auto launch

Sat Nov 12, 2011 10:26 am
I've just started using KDE and love it. I have a problem with Nepomuk though that I don't understand. On my secondary monitor, when I start typing while I'm on the desktop, the Launch Command Dialog automatically opens (I assume that's part of Nepomuk?). On my primary monitor, it doesn't work the same way. I have to press ALT + F2 to open it. I love the feature where the dialog opens automatically. Any ideas how I can get it to work on my main monitor? It worked when I live booted from USB, it stopped when I installed it...

Thanks

Last edited by hypertyper on Wed Nov 16, 2011 8:08 pm, edited 1 time in total.
User avatar Hans
Administrator
Posts
3120
Karma
20
OS
Actually it's just KRunner, Nepomuk is something else (related to desktop search and metadata). :)

What kind of desktop layout do you use on your primary monitor (see Layout in Desktop Settings)? Some, for example "Folder View", will grab the keyboard input. Which widgets do you have?


Problem solved? Please click on "Accept this answer" below the post with the best answer to mark your topic as solved.

Image
10 things you might want to do in KDE | Open menu with Super key | Mouse shortcuts
hypertyper
Registered Member
Posts
6
Karma
0
OS
I can't find the Desktop settings, nothing that has a Layout option. Where can I find it?

I've moved all widgets to the secondary screen. Krunner still pops up on the secondary, not the primary. I even tried moving my main pannel to the secondary screen but even that didn't change anything. It seems so odd. Especially because it worked fine when I live booted of USB.
User avatar Hans
Administrator
Posts
3120
Karma
20
OS
Right click on the desktop -> Desktop Settings.


Problem solved? Please click on "Accept this answer" below the post with the best answer to mark your topic as solved.

Image
10 things you might want to do in KDE | Open menu with Super key | Mouse shortcuts
hypertyper
Registered Member
Posts
6
Karma
0
OS
When I right click into Desktop I only get "Folder View Settings". I get the Desktop Settings option on my secondary screen so this must be the problem.

I can't figure out how and where to change to something other than Folder View. How do I do that?

I've looked through various options in the System Settings and couldn't find anything.

There isn't a visible widget on my screen. I do have a folder view widget on the secondary screen but that's only part of the screen so it's fine. It must be some global setting I can't find for the primary screen. Grrr.

edit: I managed to change what gets displayed so it definitely is a folder view across the whole desktop. If I could disable it that would be great. I am in the "Desktop Icons" Activity though, so it makes sense it works this way :|

Thanks
User avatar Hans
Administrator
Posts
3120
Karma
20
OS
OK, that's the problem. Folder View displays icons on your desktop, but as said before, it also grabs the keyboard input. If you want to change it to a normal desktop, right click on the desktop you want to change -> Folder View Settings -> change "Layout" to "Desktop" (unlock widgets if necessary).


Problem solved? Please click on "Accept this answer" below the post with the best answer to mark your topic as solved.

Image
10 things you might want to do in KDE | Open menu with Super key | Mouse shortcuts
hypertyper
Registered Member
Posts
6
Karma
0
OS
Unlocking the widgets was the missing step for me.

Thanks for your time, problem solved!

 
Reply to topic

Bookmarks



Who is online

Registered users: alake, Baidu [Spider], bcooksley, Bing [Bot], colomar, dehnhardt, einar, Exabot [Bot], garthecho, Google [Bot], google01103, GreatEmerald, industrie13, inhiway, ivan, jensreuterberg, koriun, lazyit, Majestic-12 [Bot], nezumi, private_lock, SecretCode, tknight, urgo, valoriez, wolfi323, Yahoo [Bot]