Reply to topic

Incoming message widget not working

yonne
Registered Member
Posts
3
Karma
0
OS

Incoming message widget not working

Thu Nov 08, 2012 10:01 am
Dear Plasma forum,

recently I added the "incoming message" widget to my main panel, mostly to get updates about new e-mails. Even though kmail (kontact) is running (and I steadily get new mails) the widget absolutely insists on kmail not having any new mail. Is there anything I forgot to set? Could my deactivated kwallet be the reason?

thanks already for your help
User avatar bcooksley
Administrator
Posts
18688
Karma
83
OS
I've checked the source code of the "Incoming message" applet and determined that it uses an interface which is only available in KMail 1 - the pre-Akonadi version. It seems that the applet has not yet been adapted to listen to Akonadi notifications unfortunately.


System Settings and Device Actions KCM maintainer
Image
yonne
Registered Member
Posts
3
Karma
0
OS
Ok, thanks for the effort! Then I will practice myself to be patient and wait for an update.
User avatar bcooksley
Administrator
Posts
18688
Karma
83
OS
You may wish to file this as a bug report as the Incoming message widget developers may not be aware of this - especially if they are not a KMail user.


System Settings and Device Actions KCM maintainer
Image
yonne
Registered Member
Posts
3
Karma
0
OS
Thank you for the hint. While checking (for the 1st time ever) how to submit a bug report I noticed that the lacking akondi support was already reported in 2011 (https://bugs.kde.org/show_bug.cgi?id=288163). At least I submitted all my votes for this bug ;)

 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], bcooksley, Bing [Bot], claydoh, Deusdies, Exabot [Bot], garthecho, Google [Bot], Hans, jpwhiting, La Ninje, Majestic-12 [Bot], Mamarok, MetaNova, MSN [Bot], renatoatilio, rossdv8, Uri_Herrera, Yahoo [Bot], šumski