Reply to topic

Icons change or go blank - Mozilla Icons all the same

TonyW
Registered Member
Posts
3
Karma
0
OS
First I wanted to say HELLO everyone! New to forum, used KDE in past and perhaps was on old forums. Really enjoying getting back to Linux and KDE. Had enough of that 'other' OS ;D Hope to be spending some time here reading and learning.

Ok, to my point. Searched first on google, then searched a little here but couldn't find answer. If you know where answer might be just point me to thread. Two things, both with icons on desktop as widget.

I have put a few icons on desktop that I use very often. 3 are Mozilla. I have Firefox, Thunderbird, and Filezilla on desktop. If I log out of desktop, or restart my icons always change for those 3 to one icon. What I mean is, I have the 3 separate icons when I log out, but when I log in all 3 programs show the firefox icon. or next time they all show the filezilla icon. I change each one back to what it should be, and it's fine while I stay logged in. Can't find reason for this. Is there something in an icon cache that makes these appear to be common or?

Other question is sometimes icons on desktop or in menu suddenly lose their picture. Icon just displays a question mark. I am running the latest Debian 6.0.6, clean install. Just need some ideas on what to do so I can learn. Thanks much! :)
User avatar bcooksley
Administrator
Posts
18642
Karma
83
OS
Icons showing up as just question marks indicates that KDE was not able to find the correct icon. Do you have any information on what causes this to occur, if it will disappear by itself (ie. will just reopening the application fix it), etc?

As for the Mozilla icons, how are you selecting them? Using a file picker, or using the grid display of icons?


System Settings and Device Actions KCM maintainer
Image
TonyW
Registered Member
Posts
3
Karma
0
OS
Ok, I can understand Kde not knowing the correct icons, not sure how it happened though. I did a clean install (twice) of Debian from the ISO DVD. I downloaded all 10 dvd's, told it to do full install of Kde. Each time there were several icons with question mark, and ALL of the debian icons in Kickoff launcher. Debian has its own heading there and all have question marks. Don't know why it loaded that way.

As for the Mozilla icons, I just un-tarred the binaries and put in '.programs' folder in my home folder, each in its own folder that it was saved to when tarred. I then used the icon settings dialog from the shortcut I created and pointed to the icons with the file picker. (Dolphin?). They stay just fine as long as I'm logged in, but change to one type when I log out. And they always change to whatever was the last icon I fixed. I also see now it's not just on desktop. It's also doing it on the panel I created for shortcuts.

Thanks for the reply!
User avatar bcooksley
Administrator
Posts
18642
Karma
83
OS
This is extremely odd behaviour. Can you please erase /var/tmp/kdecache-$USER/ outside KDE and see what impact that has?
Also, can you please state what type of shortcuts you have created on the desktop for the Mozilla applications? Are they full *.desktop files, or are they Plasma shortcuts?


System Settings and Device Actions KCM maintainer
Image
TonyW
Registered Member
Posts
3
Karma
0
OS
Hi,

Just wanted to let you know I read this, and will try it as soon as I can. Haven't had much chance to do anything as I'm busy on a couple projects. Couple things I can add for now is they are plasma shortcuts, not .desktop files. Other thing I see is I don't get the bouncing icon launch notification for those shortcuts if that means anything. I'm wondering if part of this comes from Debians 'central' file system that tries to control all the apps and icons, etc. Just started reading that a little too.

Soon as I get a chance I will try the other things and then post back here. Just didn't want you to think I'm wasting your time and not replying :)
User avatar bcooksley
Administrator
Posts
18642
Karma
83
OS
I am assuming you dragged these entries to the Desktop from the menu? If so, what happens if you use the menu editor directly to make the appropriate changes?


System Settings and Device Actions KCM maintainer
Image

 
Reply to topic

Bookmarks



Who is online

Registered users: afiestas, avishekk, Baidu [Spider], bcooksley, Bing [Bot], bjoernbalazs, brankko, colomar, Cris70, david_edmundson, einar, Exabot [Bot], ggael, Google [Bot], Heiko Tietze, joshaughnessy, ken300, koriun, La Ninje, Majestic-12 [Bot], metalbrick, mmagnusson, ooker, ozim, paulus3005, rossdv8, seal20, starbuck, stavallo, steltsop, steph, SysGhost, valoriez, vHanda, Yahoo [Bot]