Reply to topic

Where is the KDE screen saver?

User avatar Joseppi
Registered Member
Posts
79
Karma
0
OS

Where is the KDE screen saver?

Sat Nov 10, 2012 6:04 pm
Where is the KDE screen saver?
It used to be here:
System Settings > Look & Feel > Desktop > Screen Saver
But now I can't find it anywhere?
Here's a screenshot of what I used to see:
http://www.upquick.com/temp/screensaver.jpg

Why do you keep changing KDE to make it more cluttered,
more confusing, and with reduced functionality?

Now, I can't even find the former "look & feel" options.
Minio
Registered Member
Posts
177
Karma
1
OS
It's System Settings → Display and Monitor → Screen Saver

If you open System Settings, you can search with input box in upper right corner.


Best regards
Mirosław Zalewski
Using KDE 4.11.3 on Debian testing amd64.
User avatar Joseppi
Registered Member
Posts
79
Karma
0
OS
Thanks very much!
Is there a way to modify the transition,
i.e. to either have a simple fade,
or at least to eliminate the ever-changing mix of transition styles?
User avatar bcooksley
Administrator
Posts
18642
Karma
83
OS

Re: Where is the KDE screen saver?

Mon Nov 12, 2012 6:25 am
Unfortunately it appears that the transitions it uses cannot be configured at this time.
Given that the current breed of screensavers will need to be completely rewritten for Wayland (and at the same time overhauled to allow KDE and screen locking to work better with the screen saver), i'm not sure if this will be added to the current screensavers.


System Settings and Device Actions KCM maintainer
Image
User avatar Joseppi
Registered Member
Posts
79
Karma
0
OS

Re: Where is the KDE screen saver?

Thu Nov 15, 2012 12:11 am
Surely there must be some way to entirely turn off the goofy, randomly changing "transitions."

The transitions are terribly slow and annoying and every time the screen-saver slide-show starts, it takes several seconds to for the system to "recover" to a working state.

Surely there must at least be some way to just turn off these annoying "transitions" entirely, so that slides can just switch from each image to the next without any needless transition at all.
User avatar cfeck
KDE Developer
Posts
44
Karma
2

Re: Where is the KDE screen saver?

Thu Nov 15, 2012 12:52 pm
https://bugs.kde.org/show_bug.cgi?id=298018 has a link that explains how to disable the animations.


Christoph Feck
User avatar Joseppi
Registered Member
Posts
79
Karma
0
OS

Re: Where is the KDE screen saver?

Thu Nov 15, 2012 6:53 pm
cfeck wrote:https://bugs.kde.org/show_bug.cgi?id=298018 has a link that explains how to disable the animations.


Thanks, but but this link that you provided does not seem to provide any explanation of how to disable this slide transition problem. The above link refers to another link -- https://bugs.kde.org/show_bug.cgi?id=182104 -- wherein I found the proposed solution shown below, which I implemented, but it also does not work.

Paul Lemmons 2011-12-16 wrote: to disable all transition effects, go to this file:
~/.kde/share/config/kslideshow.kssrc -- and add the following line:
EffectsEnabled=false to the end of the file:

On my systems, I found this file in .kde4 (not in .kde). But adding the suggested line does not correct the problem. Transitions still take 6 to 8 seconds and another 6 to 8 seconds to exit and get out of the screen saver.
User avatar bcooksley
Administrator
Posts
18642
Karma
83
OS

Re: Where is the KDE screen saver?

Fri Nov 16, 2012 12:26 am
Make sure that you add "EffectsEnabled" into the [Settings] section of the file, rather than any other section.
If you have any doubts, please paste the full content of the file here.


System Settings and Device Actions KCM maintainer
Image
User avatar Joseppi
Registered Member
Posts
79
Karma
0
OS

Re: Where is the KDE screen saver?

Fri Nov 16, 2012 12:37 am
It seems that something is causing 'kscreensaverrc' to be overwritten.
I had added "EffectsEnabled=false" to 'kscreensaverrc' this morning,
and made a copy of the resulting file in my notes on this problem.
But when I went back to look at that file again moments ago, the
"EffectsEnabled=false" line that I had added was gone - vanished.
What would cause that? I have not rebooted or restarted.

------------------------------------
Nov 15 17:31 kscreensaverrc

$ cat kscreensaverrc
[ScreenSaver]
ActionBottomLeft=0
ActionBottomRight=0
ActionTopLeft=0
ActionTopRight=0
Enabled=true
Lock=false
LockGrace=60000
PlasmaEnabled=false
Saver=KSlideshow.desktop
Timeout=420
EffectsEnabled=false
User avatar bcooksley
Administrator
Posts
18642
Karma
83
OS

Re: Where is the KDE screen saver?

Fri Nov 16, 2012 1:16 am
If you had System Settings or a screensaver running in the background at the time you altered the file, they could have overwritten your changes.
I would suggest making the change outside KDE.

Also - kscreensaverrc is the wrong file - you need to edit kslideshow.kssrc.
If kslideshow.kssrc is not present, create it with the following contents:
Code: Select all
[Settings]
EffectsEnabled=false


System Settings and Device Actions KCM maintainer
Image
User avatar Joseppi
Registered Member
Posts
79
Karma
0
OS

Re: Where is the KDE screen saver?

Fri Nov 16, 2012 2:01 am
I just checked kslideshow.kssrc and it already had "EffectsEnabled=false" in the file as shown below. So both kslideshow and kscreensaver have "effectsenabled=false" set, but the problem still continues and it takes 6 to 7 seconds to change images and another 6 to 7 seconds to break free of the slide show.

[Settings]
Delay=10
Directory[$e]=$HOME/mydata/scenery
PrintName=false
RandomPosition=false
ShowRandom=true
SubDirectory=false
ZoomImages=true
EffectsEnabled=false
User avatar bcooksley
Administrator
Posts
18642
Karma
83
OS

Re: Where is the KDE screen saver?

Fri Nov 16, 2012 2:12 am
Are you able to access the computer running the screensaver from another machine to determine what exactly it is trying to do when transitioning / exiting the screensaver?


System Settings and Device Actions KCM maintainer
Image
User avatar Joseppi
Registered Member
Posts
79
Karma
0
OS

Re: Where is the KDE screen saver?

Wed Nov 21, 2012 10:43 pm
bcooksley last wrote:
> Are you able to access the computer running the screensaver
> from another machine to determine what exactly it is trying
> to do when transitioning / exiting the screensaver?

I don't know how to do that.

I think I can ssh login from one of my computers into another one, but if I did that, I don't know how I would proceed to try to figure out what the problem is.

Since my last message on this subject, the screen-saver quit working entirely for a while.

Transitions were getting slower and slower with the images on the screen taking 10 seconds or even much longer to transition from one to another; but then the screensaver wouldn't even start at all. I checked to see if it was still set to run, and it is set to start after 7 minutes, but it did not start, even after 10 or 20 minutes. I also checked both the kscreensaver and kslideshow files and both have the "false" setting added as previously suggested. After restarting it (with the exact same settings), it did start to work again, but still with the annoyingly slow transition problem.

So please advise what you recommend to get this thing to work again and to work correctly?
User avatar bcooksley
Administrator
Posts
18642
Karma
83
OS

Re: Where is the KDE screen saver?

Sat Nov 24, 2012 8:43 pm
One thing you could do is ssh in remotely and run a program such as "top" or "htop" to see if excessive CPU usage is causing the slow transition - 10 seconds definitely seems too long.


System Settings and Device Actions KCM maintainer
Image

 
Reply to topic

Bookmarks



Who is online

Registered users: afiestas, avishekk, Baidu [Spider], bcooksley, Bing [Bot], bjoernbalazs, brankko, colomar, Cris70, david_edmundson, einar, Exabot [Bot], ggael, Google [Bot], Heiko Tietze, joshaughnessy, ken300, koriun, La Ninje, lueck, Majestic-12 [Bot], metalbrick, mmagnusson, ooker, rossdv8, scummos, seal20, starbuck, stavallo, steltsop, steph, SysGhost, valoriez, vHanda, Yahoo [Bot]