Reply to topic

[Solved] How do I disable my mouse pad?

frankr
Registered Member
Posts
3
Karma
0
I am using KDE 4.8.5 and I cannot find a way to disable the mouse pad. I am using a laptop and the mouse pad is flush with the typing area, as a consequence it is almost impossible to type without activating the mouse pad causing all kinds of bizarre behavior. I can turn it off by session by using a function key combination. However, I would like to turn if off permanently or at least until I decide to activate it again. I have gone over the system settings numerous times but I have not been able to locate a way to disable the pad.

Any help or advice greatly appreciated.

Last edited by frankr on Wed Feb 13, 2013 6:22 pm, edited 1 time in total.
User avatar google01103
Manager
Posts
4960
Karma
17
OS

Re: How do I disable my mouse pad?

Mon Feb 11, 2013 8:29 pm
systemsettings -> input devices -> touchpad ->

do you have package synaptiks installed? https://synaptiks.readthedocs.org/en/latest/

you could also try the command
Code: Select all
synclient TouchpadOff=1


OpenSuse 13.1 x64, KDE 4.12.x

Problem solved? Please click on Image below the post with the best answer to mark your topic as solved.
frankr
Registered Member
Posts
3
Karma
0

Re: How do I disable my mouse pad?

Mon Feb 11, 2013 11:31 pm
systemsettings -> input devices -> touchpad ->

systemsetting -> input devices -> yields -. keyboard, mouse, joystick and remote controls, the touch pad option is not listed on 4.8.5 or at least not in my system.

do you have package synaptiks installed?

Unfortunately no, and the repositories for my system (Slackware 14.0) do not carry several of the dependencies. Searching
package providers like Slackbuild.org I was not able to find them either. I went ahead and attempted an install using pip but I was unable to install successfully.

synclient TouchpadOff=1


This works fine for the current session, but I was hoping to be able to disable the mouse pad permanently. Looks like I may have to wait until
Slackware updates KDE to 4.9 or 4.10.

I appreciate your help :) but it doesn't look like there is an easy fix to the problem.
User avatar google01103
Manager
Posts
4960
Karma
17
OS

Re: How do I disable my mouse pad?

Mon Feb 11, 2013 11:47 pm
try placing the command in ~/.kde[4]/env/myenv.sh if the folder/file does not exist create it, make it executable and add as the first line
Code: Select all
 #!/bin/bash


restart KDE and see if it works

might also work in your .login file


OpenSuse 13.1 x64, KDE 4.12.x

Problem solved? Please click on Image below the post with the best answer to mark your topic as solved.
User avatar bcooksley
Administrator
Posts
18614
Karma
83
OS

Re: How do I disable my mouse pad?

Tue Feb 12, 2013 5:55 am
The Touchpad control module is part of Synaptiks to the best of my knowledge, and is not part of the KDE 4.10 or earlier releases to the best of my knowledge.


System Settings and Device Actions KCM maintainer
Image
frankr
Registered Member
Posts
3
Karma
0

Re: How do I disable my mouse pad?

Tue Feb 12, 2013 12:34 pm
try placing the command in ~/.kde[4]/env/myenv.sh if the folder/file does not exist create it, make it executable and add as the first line


Works like a charm! ;D

It may seem a simple thing but it was a constant annoyance for me, and I had spent considerable time, trying to find a solution previously - So, many thanks my friend!
User avatar toad
Global Moderator
Posts
876
Karma
6
OS

Re: How do I disable my mouse pad?

Tue Feb 12, 2013 5:11 pm
Yep, our very own google is always a great source of all sorts of info :)

Could you mark this topic as solved so that people who are looking for a solution will find this thread and look at it?

Cheers :)


Sid
rcaveney
Registered Member
Posts
2
Karma
0
A handy script for "mousepad on ! off". Alt-F2 opens a line which enables one run "mousepad on | off".
#!/usr/bin/ruby

on_or_off = ARGV[0].to_s
if on_or_off.downcase == "on"
puts "Turning on mousepad"
`synclient TouchpadOff=0`
else
puts "Turning off mousepad"
`synclient TouchpadOff=1`
end
User avatar bcooksley
Administrator
Posts
18614
Karma
83
OS
You might want to post that in the Tutorial & Tips forum as others may find it helpful.
As a further note - you could configure a keyboard shortcut (using Custom Shortcuts in System Settings > Shortcuts & Gestures) to execute either command as well.


System Settings and Device Actions KCM maintainer
Image

 
Reply to topic

Bookmarks



Who is online

Registered users: Alexa [Bot], asevens, Baidu [Spider], Bing [Bot], binro, brand, doublerainbow64, Exabot [Bot], Google [Bot], google01103, inksi, jgrulich, koriun, lazyit, Majestic-12 [Bot], metzman, Murz, random_fan, rfinley, Sentynel, toad, Vindex17, whatthefunk, Yahoo [Bot], yurchor, zhou13