Reply to topic

Lancelot is showing duplicate entries of applications

User avatar joon
Registered Member
Posts
19
Karma
0
Hi,

I am not exactly sure when this started, (I think it was when I upgraded to KDE 4.10) but Lancelot yields duplicate entries for applications whenever I search for one. I'm guessing some kind of cache messed up, and I was wondering what are the ways to "clean" this?

Best,
Joon
User avatar google01103
Manager
Posts
4960
Karma
17
OS
I can confirm this, and note that the standard Kmenu does not exhibit this issue


OpenSuse 13.1 x64, KDE 4.12.x

Problem solved? Please click on Image below the post with the best answer to mark your topic as solved.
User avatar google01103
Manager
Posts
4960
Karma
17
OS
I created a bug report https://bugs.kde.org/show_bug.cgi?id=315757

be helpful if you confirm it there


OpenSuse 13.1 x64, KDE 4.12.x

Problem solved? Please click on Image below the post with the best answer to mark your topic as solved.
User avatar joon
Registered Member
Posts
19
Karma
0
google01103 wrote:I created a bug report https://bugs.kde.org/show_bug.cgi?id=315757

be helpful if you confirm it there


I just did. As you said, kickoff menu does not show any duplicates.
Strange thing is that I also have an laptop with the same openSUSE 12.3 with KDE 4.10 (hardware specs are different) and there lancelot does not show duplicates. That's why I did not think it was a bug.
User avatar google01103
Manager
Posts
4960
Karma
17
OS
was one a new install and the other an upgrade?


OpenSuse 13.1 x64, KDE 4.12.x

Problem solved? Please click on Image below the post with the best answer to mark your topic as solved.
User avatar ivan
KDE Developer
Posts
771
Karma
13
OS
Nothing has been changed in the lancelot's code for 4.10 so I have no clue why that could have happened after the upgrade. Do you have anything differently set in those two installs?

When that happens, does choosing the items below the duplicated ones start the chosen one properly, or does it start the item below/above the selected one?

(another interesting point is that I ported the search from Lancelot to Kickoff, so it really should function the same :) )


Image
User avatar google01103
Manager
Posts
4960
Karma
17
OS
- I tried with a newly created user and the same
- both results open the app

note: both of us run openSuse


OpenSuse 13.1 x64, KDE 4.12.x

Problem solved? Please click on Image below the post with the best answer to mark your topic as solved.
sir_herrbatka
Registered Member
Posts
188
Karma
0
I had the same problem with krunner (i think it's valid).

The problem was simple: I have two application searching runners for some reasone. After disabling one of those everything went back to normal.

http://wstaw.org/m/2013/02/25/zrzut_ekranu23.png
User avatar šumski
Registered Member
Posts
99
Karma
1
OS
I had that also, untile i disable Active app lister, would be a good idea to check which runners you have installed:
Code: Select all
ls /usr/lib64/kde4/ | grep runner

for a 64bit system (location is as shown at least in openSUSE)
User avatar google01103
Manager
Posts
4960
Karma
17
OS
sir_herrbatka wrote:I had the same problem with krunner (i think it's valid).

The problem was simple: I have two application searching runners for some reasone. After disabling one of those everything went back to normal.

http://wstaw.org/m/2013/02/25/zrzut_ekranu23.png


I had 2 app runners but disabling 1 did not fix it


OpenSuse 13.1 x64, KDE 4.12.x

Problem solved? Please click on Image below the post with the best answer to mark your topic as solved.
sir_herrbatka
Registered Member
Posts
188
Karma
0
No? Strange. I had to try lancelot.

After turning off doubled runner in lancelot config menu… uh the same.

Funny but after disabling BOTH krunners i still get two applications, even though i would expect to get none. Another test showed that even after turning off nepomuk search in lancelot lancelot still brings me nepomuk full text searches.

So, I would say that the reason is there, but the problem is a little bigger then it look at first.

PS
Krunner works as intended.

Last edited by sir_herrbatka on Mon Feb 25, 2013 7:55 pm, edited 1 time in total.
User avatar šumski
Registered Member
Posts
99
Karma
1
OS
But have you both restarted lancelot after disabling the second one?
sir_herrbatka
Registered Member
Posts
188
Karma
0
after restarting lancelot changes were applied. I get correct search results.
User avatar google01103
Manager
Posts
4960
Karma
17
OS
I'm also good

will note on bko

What causes the 2nd occurrence of the applications runner? seems to be an openSUSE issue as all 3 experiencing it use it


OpenSuse 13.1 x64, KDE 4.12.x

Problem solved? Please click on Image below the post with the best answer to mark your topic as solved.
User avatar šumski
Registered Member
Posts
99
Karma
1
OS
google01103 wrote:What causes the 2nd occurrence of the applications runner? seems to be an openSUSE issue as all 3 experiencing it use it

One is a default one, another is from ROSA laucher, and the 3rd came with plasma-mobile. Only the first one comes within official oS repos, so i think it was just by chance all users that wrote here, are using oS.
At least in my case where the 3 mentioned ones.

 
Reply to topic

Bookmarks



Who is online

Registered users: alake, anditosan, apater, Baidu [Spider], Bing [Bot], einar, Exabot [Bot], Google [Bot], google01103, koriun, La Ninje, lazyit, Majestic-12 [Bot], Mechatronic, mmistretta, paulus3005, pbCyanide, pedrorodriguez, random_fan, Robert Leleu, SeaJey, Sentynel, Sogatori, vascobasque, whatthefunk, Yahoo [Bot]