Reply to topic

When I Add Widgets, none are displayed

Andrew Keenan Richardson
Registered Member
Posts
5
Karma
0
I'm unable to Add Widgets to my task bar or my desktop because the list of widgets appears empty. The problem happens no matter where I Add Widgets from, the desktop or a panel, and it occurs across all workspaces.

I've tried restarting, but I'm not sure what else might help.

Any ideas how to fix it?

This is how it looks:
Image
User avatar google01103
Manager
Posts
4959
Karma
17
OS
distro & KDE versions ?

this is a new issue, previously it worked ?

recently do an upgrade ?


OpenSuse 13.1 x64, KDE 4.12.x

Problem solved? Please click on Image below the post with the best answer to mark your topic as solved.
Andrew Keenan Richardson
Registered Member
Posts
5
Karma
0
Kubuntu 12.10. This is a new issue; I don't know what happened to cause it, but it was working after I upgraded from 12.4.
User avatar google01103
Manager
Posts
4959
Karma
17
OS

Sat Mar 09, 2013 8:54 pm
I think your widgets should be in /usr/lib[64]/kde/ and they would be named plasma_applet_*.so and there should be a bunch

what is:
for 64 bit ls -l /usr/lib64/kde4plasma_applet_binaryclock.so
for 32 bit ls -l /usr/lib/kde4/plasma_applet_binaryclock.so


OpenSuse 13.1 x64, KDE 4.12.x

Problem solved? Please click on Image below the post with the best answer to mark your topic as solved.
Andrew Keenan Richardson
Registered Member
Posts
5
Karma
0
I've got this:

ls -l /usr/lib/kde4/plasma_applet_binaryclock.so
-rw-r--r-- 1 root root 52144 01.02.2013 04:30 /usr/lib/kde4/plasma_applet_binaryclock.so

I have 64 bit kubuntu with KDE Version 4.10.

Thanks for the help!
User avatar google01103
Manager
Posts
4959
Karma
17
OS
on my system these files are executable, though I don't now if that matters on .so files - outside my knowledge base

try making it executable then see if it appears in add widgets
as root
Code: Select all
chmod uog+x /usr/lib/kde4/plasma_applet_binaryclock.so


OpenSuse 13.1 x64, KDE 4.12.x

Problem solved? Please click on Image below the post with the best answer to mark your topic as solved.
User avatar einar
Administrator
Posts
2270
Karma
5
OS
Do you have any third party plasmoids installed as user? Look under KDEHOME/share/apps/plasma/plasmoids (KDEHOME is .kde or .kde4 depending on your distribution).

Also try to see if a new user account has the same issue.


"Violence is the last refuge of the incompetent."
Image
Plasma FAQ maintainer - Plasma programming with Python
Andrew Keenan Richardson
Registered Member
Posts
5
Karma
0
For the record, I never fixed the problem, I just upgraded to Kubuntu 13.04 and it got resolved.
User avatar bcooksley
Administrator
Posts
18586
Karma
83
OS
Marked as solved.
I suspect it may have been caused by certain directories existing in your home directory, which exposed a bug in Plasma.
Upgrading appears to have fixed this in this instance.


System Settings and Device Actions KCM maintainer
Image

 
Reply to topic

Bookmarks



Who is online

Registered users: 16777216, alake, Baidu [Spider], Bing [Bot], Exabot [Bot], garthecho, Google [Bot], GordieGii, Hans, koriun, Majestic-12 [Bot], mmistretta, nezumi, onesandzeros, Yahoo [Bot]