Reply to topic

krunner needs ENTER key 3 times to execute a program

Sebastian M??ller
Registered Member
Posts
5
Karma
0
hi there :)

there is one more problem that makes working on KDE really hard.

krunner sometimes only needs 1x ENTER to execute a program,
sometimes 2x ENTER,
and most of the time (in 90% of all cases) it needs 3x ENTER !

The behaviour seems to be the same with all tested desktop themes and also with all the applications tried out to run.

System: Kubuntu 12.10
KDE Version: 4.9.95

To describe the problem, I made a really nice picture of the whole process.
(The image is posted below the posting!)

I would be very glad if you could look at the picture.

By the way: (offtopic)
I am going to reply at the answers of my other (first) posting (totally different questions in there), but this will take one or two more days, since I need to test out the answers received first. Thank you very much in the meantime.


Thank you very much! (image below!)
Image
User avatar bcooksley
Administrator
Posts
18657
Karma
83
OS
Does the number of times you need to hit the enter key correspond with how long you wait after entering in text?
With regards to autocomplete, that does not look like the traditional KRunner autocompletion.

Which user interface settings are you using?


System Settings and Device Actions KCM maintainer
Image
Sebastian M??ller
Registered Member
Posts
5
Karma
0
hi bcooksley,

thank you for replying to my question!

I played around a bit, and can now tell you a little more, but the problem is still NOT solved.

Answer: It is a little hard to say "yes" or "no" definitly, but yes, I think this bug really corresponds a little with how long I wait until I press the ENTER key.
If I really wait for 5 seconds, it seems to become a little better.

A command that helped me a lot is this:
qdbus org.kde.krunner /MainApplication clearHistory

After clearing krunner's history, ENTER works at the very first time in over 70% of times.

I still think nether 70% of the time nor clearing the history once a day is a good result.

What can I do?

Important information:

After resizing the krunner window manually, step 5 (from above) now looks like this: (but did not change the ENTER problem)
Image

Yours
Sebastian
User avatar bcooksley
Administrator
Posts
18657
Karma
83
OS
Okay, this is probably due to the amount of time needed by the runners to generate the appropriate results.
I would recommend disabling the runners which you do not use. If you seek only to use KRunner to execute applications, it would probably be best to only leave the "Applications" and "Command" runners enabled.

In particular, runners which access the internet, Nepomuk or Akonadi may be more subject to causing slow downs than the other runners due to their inherent nature.


System Settings and Device Actions KCM maintainer
Image

 
Reply to topic

Bookmarks



Who is online

Registered users: alake, Alexa [Bot], Baidu [Spider], Bing [Bot], bobo01, einar, Exabot [Bot], Google [Bot], Hei Ku, joshaughnessy, Marand, mgraesslin, nezumi, orbmiser, TheraHedwig, Yahoo [Bot]