Reply to topic

Plasmoid don't remains at the same place after reboot

wotan
Registered Member
Posts
130
Karma
-2
OS
Hello

I have noticed that recently installed plasmoid appear to loose their configurations when I restart computer:
I have a label plasmoid that loose its text when the activity it is in is not started at computer start up
I have a konsole plasmoid which forget its size and coordinate every time I reboot the computer (It goes back to the up left of the screen)

Are those problems plasmoids related stuff, or is it plasma related, and is there a way I can fix this?

Thanks
User avatar einar
Administrator
Posts
2285
Karma
5
OS
What version of Plasma are you using? Do you have a "traditional" (folder view) or default desktop?


"Violence is the last refuge of the incompetent."
Image
Plasma FAQ maintainer - Plasma programming with Python
wotan
Registered Member
Posts
130
Karma
-2
OS
I am using Kubuntu 12.04 KDE 4.10.4
It is set as "Standard-Arbeitflaeche" so I believe "default desktop"
User avatar einar
Administrator
Posts
2285
Karma
5
OS
Do you see the same issue if you create a new user account with fresh configuration?
Can you also check that all your KDE software packages are up to date with your distribution's package manager?


"Violence is the last refuge of the incompetent."
Image
Plasma FAQ maintainer - Plasma programming with Python
User avatar bcooksley
Administrator
Posts
18657
Karma
83
OS
Another thing you could also check is if other newly placed applets are retained - or if they disappear entirely / are reset to their defaults as well. If this is the case, then Plasma Desktop might be crashing on logout / reboot, preventing the settings from being saved.


System Settings and Device Actions KCM maintainer
Image
wotan
Registered Member
Posts
130
Karma
-2
OS
I have tried to create a new user:
impossible to login:
No matter wether I select "Last session" or "KDE desktop", screens become black and it goes back to the login screen....
Since then In my own user session the clock is buggy, It will always want to go back to UTC time...

Newly place plasmoids do not disapeara, labels plasmoids just forget their content if their activity is not started at plasma start up
a konsole plasmoids always go back to top left of the screen with nominal size...
User avatar einar
Administrator
Posts
2285
Karma
5
OS
This looks like a severe system misconfiguration. Please check with your package manager if there are any unmet depenencies / mixed versions installed.


"Violence is the last refuge of the incompetent."
Image
Plasma FAQ maintainer - Plasma programming with Python
wotan
Registered Member
Posts
130
Karma
-2
OS
apt-get doesnot say anythings when I apt-get update... The problem of plasmoids moving after reboot, is here since several version of kde now
User avatar bcooksley
Administrator
Posts
18657
Karma
83
OS
The failure of KDE to start successfully for the new user indicates that the problem may in fact be more serious than your normal's users inability to save applet position. Can you reposition the applet, then restart Plasma Desktop? You can do this in a Konsole window by running the following two commands. You will need to wait approximately 30 seconds between them.
Code: Select all
kquitapp plasma-desktop
plasma-desktop &

Is the size saved successfully now, and does the crash assistant open?


System Settings and Device Actions KCM maintainer
Image
wotan
Registered Member
Posts
130
Karma
-2
OS
Hello

So the plasma destkop automatically reappear a few seconds after I type kquitapp plasma , without that I type plasma-desktop &
The widgets does not remain at the same place (except for those that are here since ages now).

When I kquitapp plasma-desktop the first time, there was a window popping up saying that the programm has crashed etc (the typical window one see, when a kde application crash) The second time, it was the ubuntu window (the one with an explosion symbol and "!") and it sayed that

Code: Select all
The crashed program seems to use third-party or local libraries:

/usr/local/lib/kde4/plasma_engine_stock_quote.so
/usr/local/lib/kde4/plasma_applet_stock_quote.so

It is highly recommended to check if the problem persists without those first.

Do you want to continue the report process anyway?
User avatar bcooksley
Administrator
Posts
18657
Karma
83
OS
Hm - /usr/local/ is not a normal location for packages to install themselves. Have you previously self compiled applets, etc for Plasma Desktop?
If so, please remove them - they are likely the cause of the crash (which is why applets are not saving their position).


System Settings and Device Actions KCM maintainer
Image
wotan
Registered Member
Posts
130
Karma
-2
OS
I have
Code: Select all
make uninstall
a plasmoid that was installed in /usr/local
But the problems remains. The other plasmoid (a so called KonsoleWidget) still does not remains at its place and i still can not log in with another user account
Note that plasmoid for which I have problem, like size and position going forgotten or content (label plasmoid) are installed in
Code: Select all
~/.kde/share/apps/plasma/plasmoids/
User avatar bcooksley
Administrator
Posts
18657
Karma
83
OS
Can you confirm that both the applet and engine were uninstalled?
Also, do you have any other binary applets installed outside your package manager (Scripted applets can be ignored)?


System Settings and Device Actions KCM maintainer
Image
wotan
Registered Member
Posts
130
Karma
-2
OS
Yes both engine and applet removed
I have also removed an applet that i have coded by my own. Also right now there is no more plasmoid in /usr/local
(There some programm like kbibtex but no plasmoids)

I stil have the problem though.
Also when I try to change the clock and select automatic update, through a server on internet. Apply and okay it says:

Authentification not possible. Action can not be proceeded: 6 (or something like that, my kde is in German)
Do you think it is related to those problem of plasmoids and session login ?
User avatar bcooksley
Administrator
Posts
18657
Karma
83
OS
The automatic clock issue is totally separate in this case. Now that the other applets have been removed, can you try generating a backtrace again please?


System Settings and Device Actions KCM maintainer
Image

 
Reply to topic

Bookmarks



Who is online

Registered users: afiestas, arojas, avishekk, Baidu [Spider], Bing [Bot], bjoernbalazs, Cris70, edmael, einar, epsi1on, Exabot [Bot], ggael, Google [Bot], google01103, Hans, ivan, jgrulich, joshaughnessy, jstaniek, koriun, La Ninje, Majestic-12 [Bot], MSNbot Media, ooker, progdan, scummos, sinclair, Sogou [Bot], TheraHedwig, Tioz, Yahoo [Bot]