Reply to topic

Contacts runner doesn't work. How can I debug it?

jcromero
Registered Member
Posts
14
Karma
0
OS
bcooksley wrote:Unfortunately I have very little information on this - I can suggest that you make sure only one Akonadi bridge has been added in the kresources settings though, or try removing it and adding it back again.


Yes, I am sure about that. I have even created a new user an started from scratch. I have added only one Akonadi "Google Contacts" resource and the bridge you said. And I get multiple entries (some contacts twice, some contacts three times, I don't know why). In KDE 4.10.x it is working fine, in KDE 4.11.3 it is not. The contacts runner has not changed between these two versions, so I suppose the problem is the Akonadi Google Contacts resource, that has changed.

Thanks for your support.
wolfi323
Registered Member
Posts
230
Karma
0
OS
The Akonadi bridge should not be needed.
I don't have one, and the contacts krunner does show search results here (but I do not use "Google Contacts", just a standard "Personal Contacts" resource).

But, your contacts have to be indexed by nepomuk.
You already said that you have Desktop Search enabled, but do you also have the EMail indexer enabled? That one indexes the contacts as well.
And what's its status?
Check in akonadiconsole that it is online.
jcromero
Registered Member
Posts
14
Karma
0
OS
wolfi323 wrote:The Akonadi bridge should not be needed.
I don't have one, and the contacts krunner does show search results here (but I do not use "Google Contacts", just a standard "Personal Contacts" resource).

That's one thing. It seems that I I need to have the Akonadi bridge enabled to be able to feed the contacts runner, when using only a Google Contacts Resource. I think that we can catalogue this as a bug.

wolfi323 wrote:But, your contacts have to be indexed by nepomuk.

Yes, I have "Nepomuk Desktop Search" enabled in both machines (KDE 4.10/KDE 4.11)

wolfi323 wrote:You already said that you have Desktop Search enabled, but do you also have the EMail indexer enabled? That one indexes the contacts as well.
And what's its status?

I have Nepomuk "Email indexer" and Nepomuk "FIle indexer" disabled in both machines.

wolfi323 wrote:Check in akonadiconsole that it is online.

I suppose you refer to "Akonadi Nepomuk Feeder" agent in Akonadi console. It is offline in both cases.
wolfi323
Registered Member
Posts
230
Karma
0
OS
jcromero wrote:
wolfi323 wrote:You already said that you have Desktop Search enabled, but do you also have the EMail indexer enabled? That one indexes the contacts as well.
And what's its status?

I have Nepomuk "Email indexer" and Nepomuk "FIle indexer" disabled in both machines.

wolfi323 wrote:Check in akonadiconsole that it is online.

I suppose you refer to "Akonadi Nepomuk Feeder" agent in Akonadi console. It is offline in both cases.

Yes.

Again, it has to be online and has to have indexed your contacts so that the contacts runner can find them.
So enable the "Email Indexer" in Systemsettings->Desktop Search.

If you don't want to index all your mails, you can disable indexing per mail folder in KMail. Right-click on a folder, select "Folder Properties" and switch to the Maintenance tab.
jcromero
Registered Member
Posts
14
Karma
0
OS
wolfi323 wrote:Again, it has to be online and has to have indexed your contacts so that the contacts runner can find them.
So enable the "Email Indexer" in Systemsettings->Desktop Search.


I have my contacts indexed and they are appearing in krunner when I type some letters. Why do you say I have to enable email Indexer? I don't see the need for that.
wolfi323
Registered Member
Posts
230
Karma
0
OS
jcromero wrote:
wolfi323 wrote:Again, it has to be online and has to have indexed your contacts so that the contacts runner can find them.
So enable the "Email Indexer" in Systemsettings->Desktop Search.


I have my contacts indexed and they are appearing in krunner when I type some letters. Why do you say I have to enable email Indexer? I don't see the need for that.

The Email Indexer should actually be called "PIM Indexer", it indexes the contacts and calendars as well (and IIANM it has also been renamed in 4.12's nepomuk configuration dialog).

But I mixed up the contacts krunner with the nepomuksearch krunner, which shows contacts as well.
The contacts krunner works fine here even with Nepomuk completely disabled (and without an Akonadi bridge).

I have no idea then, sorry.
jcromero
Registered Member
Posts
14
Karma
0
OS
wolfi323 wrote:The Email Indexer should actually be called "PIM Indexer", it indexes the contacts and calendars as well (and IIANM it has also been renamed in 4.12's nepomuk configuration dialog).


I repeat, Email Indexer or PIM Indexer (the name you like it more) is not needed here to access my Google Contacts. The thing I need to do to access to my contacts in krunner is to enable the Akonadi bridge. If I don't enable it, I can not access to them from krunner.

And with the same configuration, in KDE 4.10.5 it shows only one entry per contact, and in KDE 4.11.3 it shows two or three entries per contact.
wolfi323
Registered Member
Posts
230
Karma
0
OS
jcromero wrote:
wolfi323 wrote:The Email Indexer should actually be called "PIM Indexer", it indexes the contacts and calendars as well (and IIANM it has also been renamed in 4.12's nepomuk configuration dialog).


I repeat, Email Indexer or PIM Indexer (the name you like it more) is not needed here to access my Google Contacts.

I don't care how it is called actually.
But I repeat as well: to have your contacts indexed in Nepomuk, you have to have the "EMail Indexer" enabled.

And again, this is not necessary for the contacts krunner to work, I just mixed it up with the nepomuksearch krunner (which also shows contacts).

The thing I need to do to access to my contacts in krunner is to enable the Akonadi bridge. If I don't enable it, I can not access to them from krunner.

And with the same configuration, in KDE 4.10.5 it shows only one entry per contact, and in KDE 4.11.3 it shows two or three entries per contact.

Well, as I already said, I don't use Google contacts. I only have a "Personal Contacts" resource and the contacts krunner works fine without any Akonadi bridge.

So I would think the "Google Contacts" resource should not need a bridge as well.
Apparently you are seeing entries from the "Google Contacts" resource _and_ the Akonadi bridge.
It's the same here, I even see everything three times if I enable the bridge, because I have an older vcf resource with the same entries as well (disabled in KAddressbook).

On the other hand, do you have other Akonadi contacts resources as well? (Sounds like that, if you see some entries three times)
The bridge takes contacts from _all_ your contacts resources by default.
You can change that in "kcmshell4 kresources". Select the bridge and click on "Edit", there click on "Manage Address Book Sources" and remove all but your "Google Contacts" resource.
jcromero
Registered Member
Posts
14
Karma
0
OS
wolfi323 wrote:So I would think the "Google Contacts" resource should not need a bridge as well.

If I don't enable the bridge, I don't get any contacts in krunner.

wolfi323 wrote:Apparently you are seeing entries from the "Google Contacts" resource _and_ the Akonadi bridge.
It's the same here, I even see everything three times if I enable the bridge, because I have an older vcf resource with the same entries as well (disabled in KAddressbook).

In KDE 4.10.5 I'm seeing only one entry per contact. In KDE 4.11.3 I see two or three entries per contact.

wolfi323 wrote:On the other hand, do you have other Akonadi contacts resources as well? (Sounds like that, if you see some entries three times)
The bridge takes contacts from _all_ your contacts resources by default.

No, I only have the Google Contacts resource and the bridge (in both versions).

wolfi323 wrote:You can change that in "kcmshell4 kresources". Select the bridge and click on "Edit", there click on "Manage Address Book Sources" and remove all but your "Google Contacts" resource.

I have only a "Google Contacts" resource here (in both versions)
User avatar bcooksley
Administrator
Posts
18614
Karma
83
OS
I can explain why it works without the bridge for wolfi323. If you check the settings in KResources and in the Akonadi settings (in KAddressBook) you will probably find that they are pointed to the same location for contact information. The result of this is that you don't need the Akonadi bridge - as it can access the data natively.

As the legacy KResources system doesn't have any support for Google based contacts, the only way to support showing them in the Contacts runner is through the Akonadi bridge - which I suspect has a few issues of it's own, hence the duplication of results.


System Settings and Device Actions KCM maintainer
Image
jcromero
Registered Member
Posts
14
Karma
0
OS
bcooksley wrote:As the legacy KResources system doesn't have any support for Google based contacts, the only way to support showing them in the Contacts runner is through the Akonadi bridge - which I suspect has a few issues of it's own, hence the duplication of results.

In KDE 4.10.5, it seems there are no issues. So, I think this is a regression in the Akonadi Google Conctacts resource.
wolfi323
Registered Member
Posts
230
Karma
0
OS
bcooksley wrote:I can explain why it works without the bridge for wolfi323. If you check the settings in KResources and in the Akonadi settings (in KAddressBook) you will probably find that they are pointed to the same location for contact information. The result of this is that you don't need the Akonadi bridge - as it can access the data natively.

Ah, that's right of course, didn't think of that.
If I point the standard kresource to an empty file I don't see any contacts from the contacts runner any more even though the Akonadi resources are still in place.

But as I said, I don't get any (unexpected) duplicates with the Akonadi bridge. I see every contact three times because there are three identical addressbooks (the vcf file as kresource, and via the Akonadi bridge the vcf file as Akonadi resource and a "Personal Contacts" resource which I keep in sync).
So this seems to be a specific problem with the Google Contacts resource.

Have you checked "Manage Address Book Sources" in the Akonadi bridge settings as I already suggested?
Maybe the Google Contacts resource is listed more than once there?

 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], Bing [Bot], Dimitrios, drnn1076, Exabot [Bot], Google [Bot], google01103, Hans, Horus, koriun, Majestic-12 [Bot], pbCyanide, pedrorodriguez, random_fan, scummos, SeaJey, Sogatori, Sogou [Bot], TheraHedwig, vascobasque, whatthefunk, Yahoo [Bot], yurchor, z-uo