Reply to topic

Comic-widget won't list the installed comics

Luda
Registered Member
Posts
19
Karma
0
OS
Hi.
Since KDE 4.3 I can't select installed comics anymore.
Using the widget I have installed a random set of comics,
proof:
luda@sad ~/.kde4/share/apps/plasma/comics $ ls -lah
total 184K
drwx------ 2 luda luda 4.0K Sep 4 22:55 .
drwx------ 3 luda luda 4.0K Sep 4 22:51 ..
-rw-r--r-- 1 luda luda 2.4K Sep 4 22:55 105507-fonflatter.comic
-rw-r--r-- 1 luda luda 27K Sep 4 22:55 105727-megatokyofr.comic
-rw-r--r-- 1 luda luda 4.2K Sep 4 22:55 106642-lovieII.comic
-rw-r--r-- 1 luda luda 2.7K Sep 4 22:55 107670-saturday_morning_breakfast_cereal.comic
-rw-r--r-- 1 luda luda 5.5K Sep 4 22:55 108582-poochcafe.comic
-rw-r--r-- 1 luda luda 2.2K Sep 4 22:55 109961-MortenM_nb.comic
-rw-r--r-- 1 luda luda 111K Sep 4 22:52 110267-megatokyo.comic
-rw-r--r-- 1 luda luda 1.9K Sep 4 22:51 91803-xkcd.comic
-rw-r--r-- 1 luda luda 2.5K Sep 4 22:55 93134-general_protection_fault.comic
luda@sad ~/.kde4/share/apps/plasma/comics $

When i hover the mousepointer over the dropdown-box it highlights (glowing blue), just as you'd expect, but it won't open, neither by clicking, nor by using the keyboard, so I guess it's just empty.

Any ideas why the widget might not find the installed comics?
User avatar bcooksley
Administrator
Posts
18607
Karma
83
OS
Try running "kbuildsycoca4 --noincremental"


System Settings and Device Actions KCM maintainer
Image
Luda
Registered Member
Posts
19
Karma
0
OS
Thank you for your quick response.

Sadly running kbuildsycoca didn't change anything. :(
User avatar bcooksley
Administrator
Posts
18607
Karma
83
OS
Can you please try installing a new comic and see if that works?


System Settings and Device Actions KCM maintainer
Image
Luda
Registered Member
Posts
19
Karma
0
OS
I have already tried that, just tried it again.. doesn't work.

Is there a way to get some output from the widget, maybe via a logfile or by starting plasma in a terminal?

/e: Just did a "killall plasma-desktop; plasma-desktop --nofork" and when installing a comic I get "/bin/sh: plasmapkg: command not found"

I wonder which package this belongs to....

And the winner is.....


kde-base/plasma-runtime
Available versions: (4.3) (~)4.3.0 (~)4.3.1
{aqua debug kdeprefix}
Homepage: http://www.kde.org/
Description: Script engine and package tool for plasma


Comic applet works, thanks bcooksley.

/e: filed a bug report: http://bugs.gentoo.org/show_bug.cgi?id=283738
User avatar bcooksley
Administrator
Posts
18607
Karma
83
OS
Thanks for filing the bug report with the Gentoo packagers. There have been other incidents where applications not installed by default in Gentoo caused breakages.


System Settings and Device Actions KCM maintainer
Image
User avatar ssri
Registered Member
Posts
47
Karma
0
OS
try:

~$plasmapkg -t comic -l

 
Reply to topic

Bookmarks



Who is online

Registered users: alake, Alex_Perry, Baidu [Spider], Bing [Bot], brand, colomar, eticre, Exabot [Bot], garthecho, Google [Bot], google01103, Hans, ken300, koriun, La Ninje, Majestic-12 [Bot], nerdopolis, pedrorodriguez, rulet111, SecretCode, Sentynel, Sogatori, Sogou [Bot], Steve Guilford, vascobasque, vgezer, Yahoo [Bot], z-uo, šumski