Reply to topic

SOLVED plasma-desktop crashes on startup

bas
Registered Member
Posts
5
Karma
0
OS
hello,

plasma-desktop crashes on startup. for a moment i can see a desktop which disappears then appears again as if it would try a restart and then goes away again.
i'm left with a black screen, no panels, no right-click menu, only a message window that informs of the crash of plasma-desktop.
krunner and other apps are working fine.

i just reinstalled my system for other reasons but still the same problem with plasma-desktop.

i also tried to move my .kde and .kde4 folder away but still the same behaviour (although different error messages).

i checked forums and lists but nothing helped

this is the terminal output (with .kde and .kde4 folder moved back to home):

Code: Select all
bas@bas:~$ plasma-desktop                               
QDBusObjectPath: invalid path ""                         
QLayout: Attempting to add QLayout "" to QWidget "", which already has a layout
Invalid D-BUS interface name 'org.kde.plasma-desktop.PlasmaApp' found while parsing introspection
bas@bas:~$ findServiceByDesktopPath: /usr/share/applications/kde/amarok.desktop not found       
findServiceByDesktopPath: /usr/share/applications/kde4/ktorrent.desktop not found               
findServiceByDesktopPath: /usr/share/applications/kde4/kopete.desktop not found                 
findServiceByDesktopPath: /usr/share/applications/skype.desktop not found                       
findServiceByDesktopPath: /usr/share/applications/ooo-writer.desktop not found                   
findServiceByDesktopPath: /usr/share/applications/kde/kdissert.desktop not found                 
findServiceByDesktopPath: systemsettings not found                                               
findServiceByDesktopPath: ffado.org-ffadomixer.desktop not found                                 
findServiceByDesktopPath: kde4-kpackage.desktop not found                                       
findServiceByDesktopPath: wicd.desktop not found                                                 
findServiceByDesktopPath: kde-knetworkmanager.desktop not found                                 
findServiceByDesktopPath: wifi-radar.desktop not found                                           
findServiceByDesktopPath: /home/bas/.kde/share/apps/RecentDocuments/108,20100210,1.html.desktop not found
findServiceByDesktopPath: /home/bas/.kde/share/apps/RecentDocuments/signup.php.desktop not found         
findServiceByDesktopPath: /home/bas/.kde/share/apps/RecentDocuments/3188253.desktop not found           
findServiceByDesktopPath: /home/bas/.kde/share/apps/RecentDocuments/hl.exe.desktop not found             
findServiceByDesktopPath: /home/bas/.kde/share/apps/RecentDocuments/.update-timestamp.desktop not found 
findServiceByDesktopPath: /home/bas/.kde/share/apps/RecentDocuments/visit-theaojj.avi.desktop not found 
findServiceByDesktopPath: /home/bas/.kde/share/apps/RecentDocuments/bomba_hotel_vela_II.m3u.desktop not found
findServiceByDesktopPath: /home/bas/.kde/share/apps/RecentDocuments/cumple_carbo.m3u.desktop not found       
findServiceByDesktopPath: /home/bas/.kde/share/apps/RecentDocuments/rc.local.desktop not found               
Object::connect: No such signal SystemTray::Manager::jobStateChanged(SystemTray::Job*)                       
QGraphicsGridLayout::itemAt: invalid index 0                                                                 
KCrash: Application 'plasma-desktop' crashing...                                                             
sock_file=/home/bas/.kde/socket-bas/kdeinit4__0                                                             
bas@bas:~$ QDBusObjectPath: invalid path ""                                                                 
QLayout: Attempting to add QLayout "" to QWidget "", which already has a layout                                                             
Invalid D-BUS interface name 'org.kde.plasma-desktop.PlasmaApp' found while parsing introspection                                           
findServiceByDesktopPath: /usr/share/applications/kde/amarok.desktop not found                                                               
findServiceByDesktopPath: /usr/share/applications/kde4/ktorrent.desktop not found                                                           
findServiceByDesktopPath: /usr/share/applications/kde4/kopete.desktop not found                                                             
findServiceByDesktopPath: /usr/share/applications/skype.desktop not found
findServiceByDesktopPath: /usr/share/applications/ooo-writer.desktop not found
findServiceByDesktopPath: /usr/share/applications/kde/kdissert.desktop not found
findServiceByDesktopPath: systemsettings not found
findServiceByDesktopPath: ffado.org-ffadomixer.desktop not found
findServiceByDesktopPath: kde4-kpackage.desktop not found
findServiceByDesktopPath: wicd.desktop not found
findServiceByDesktopPath: kde-knetworkmanager.desktop not found
findServiceByDesktopPath: wifi-radar.desktop not found
findServiceByDesktopPath: /home/bas/.kde/share/apps/RecentDocuments/108,20100210,1.html.desktop not found
findServiceByDesktopPath: /home/bas/.kde/share/apps/RecentDocuments/signup.php.desktop not found
findServiceByDesktopPath: /home/bas/.kde/share/apps/RecentDocuments/3188253.desktop not found
findServiceByDesktopPath: /home/bas/.kde/share/apps/RecentDocuments/hl.exe.desktop not found
findServiceByDesktopPath: /home/bas/.kde/share/apps/RecentDocuments/.update-timestamp.desktop not found
findServiceByDesktopPath: /home/bas/.kde/share/apps/RecentDocuments/visit-theaojj.avi.desktop not found
findServiceByDesktopPath: /home/bas/.kde/share/apps/RecentDocuments/bomba_hotel_vela_II.m3u.desktop not found
findServiceByDesktopPath: /home/bas/.kde/share/apps/RecentDocuments/cumple_carbo.m3u.desktop not found
findServiceByDesktopPath: /home/bas/.kde/share/apps/RecentDocuments/rc.local.desktop not found
Object::connect: No such signal SystemTray::Manager::jobStateChanged(SystemTray::Job*)
QGraphicsGridLayout::itemAt: invalid index 0


thank you for your help!
bas

Last edited by bas on Mon Jun 20, 2011 1:27 pm, edited 1 time in total.
User avatar moofang
Registered Member
Posts
41
Karma
1
Does running plasma-desktop manually on krunner work?
Try moving just ~/.kde4/share/config/plasma* instead of the whole ~/.kde4 folder?

If that doesn't help you'll want to provide the following info:

Your KDE version and distro (and whether you're using any non-default repos)
The crash trace (you can find it in the message window reporting the crash)


User avatar bcooksley
Administrator
Posts
18556
Karma
83
OS
If you are using Qt 4.6.0, please upgrade to Qt 4.6.2.

Which widgets did you use prior to the upgrade, and can you reproduce under a new user?


System Settings and Device Actions KCM maintainer
Image
bas
Registered Member
Posts
5
Karma
0
OS

Re: plasma-desktop crashes on startup

Tue Feb 23, 2010 12:38 pm
hello,

so far, no luck

-running plasma-desktop from krunner does the same thing as atrting it from a terminal or at startup.

-moving ~/.kde4/share/config/plasma* does not change anything

-i made a new user and get the same results with this terminal output:

Code: Select all
$ plasma-desktop
QDBusObjectPath: invalid path ""
QLayout: Attempting to add QLayout "" to QWidget "", which already has a layout
Invalid D-BUS interface name 'org.kde.plasma-desktop.PlasmaApp' found while parsing introspection
$ findServiceByDesktopPath: systemsettings not found
Object::connect: No such signal SystemTray::Manager::jobStateChanged(SystemTray::Job*)
QGraphicsGridLayout::itemAt: invalid index 0
KCrash: Application 'plasma-desktop' crashing...
sock_file=/home/test/.kde/socket-bas/kdeinit4__0
QDBusObjectPath: invalid path ""
QLayout: Attempting to add QLayout "" to QWidget "", which already has a layout
Invalid D-BUS interface name 'org.kde.plasma-desktop.PlasmaApp' found while parsing introspection
findServiceByDesktopPath: systemsettings not found
Object::connect: No such signal SystemTray::Manager::jobStateChanged(SystemTray::Job*)
QGraphicsGridLayout::itemAt: invalid index 0


i remember that i had installed three widgets before my reinstall: one where you can see the moon phases, another which shows fotos of the sun and a third which can control amarok.
i had more installed but i removed them.

i use debian testing with the default and multimedia repositories

the next thing i will try is to create a crash trace but i think i have to install some things before that

bye
bas
bas
Registered Member
Posts
5
Karma
0
OS
before i forgot to post my qt version; it is 4.5.3
do you think an upgrade would help?

here is my crash trace (where there are question marks i did not find out which debug packages to install.)

Code: Select all
Application: Plasma Workspace (plasma-desktop), signal: Segmentation fault
[Current thread is 1 (Thread 0x7fd062218770 (LWP 3490))]

Thread 2 (Thread 0x7fd0433da910 (LWP 3491)):
#0  0x00007fd0592d1f89 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#1  0x00007fd05ec95499 in QWaitConditionPrivate::wait (this=0x28a4600, mutex=0x28a45f8, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:87
#2  QWaitCondition::wait (this=0x28a4600, mutex=0x28a45f8, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:159
#3  0x00007fd05b9e73b4 in QHostInfoAgent::run (this=0x28a45e0) at kernel/qhostinfo.cpp:260
#4  0x00007fd05ec944a5 in QThreadPrivate::start (arg=0x28a45e0) at thread/qthread_unix.cpp:188
#5  0x00007fd0592cd73a in start_thread () from /lib/libpthread.so.0
#6  0x00007fd061b1a69d in clone () from /lib/libc.so.6
#7  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fd062218770 (LWP 3490)):
[KCrash Handler]
#5  0x00007fd05ece1cbe in QtPrivate::QStringList_contains (that=0x7fff4b7584d0, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#6  0x00007fd043e4fa76 in HalPower::brightness(QString const&) () from /usr/lib/kde4/solid_hal_power.so
#7  0x00007fd0455abca4 in Solid::Control::PowerManager::brightness(QString const&) () from /usr/lib/libsolidcontrol.so.4
#8  0x00007fd043c3d806 in ?? () from /usr/lib/kde4/plasma_applet_battery.so
#9  0x00007fd043c40ee8 in ?? () from /usr/lib/kde4/plasma_applet_battery.so
#10 0x00007fd061dd99bb in ?? () from /usr/lib/libkdeinit4_plasma-desktop.so
#11 0x00007fd061ddad11 in ?? () from /usr/lib/libkdeinit4_plasma-desktop.so
#12 0x00007fd05ed8edf2 in QMetaObject::activate (sender=0x26cdff0, from_signal_index=<value optimized out>, to_signal_index=4, argv=0x0) at kernel/qobject.cpp:3112
#13 0x00007fd05ed93f5f in QSingleShotTimer::timerEvent (this=0x26cdff0) at kernel/qtimer.cpp:298
#14 0x00007fd05ed89353 in QObject::event (this=0x26cdff0, e=0x2a26398) at kernel/qobject.cpp:1074
#15 0x00007fd05f4bd01d in QApplicationPrivate::notify_helper (this=0x20340f0, receiver=0x26cdff0, e=0x7fff4b759510) at kernel/qapplication.cpp:4065
#16 0x00007fd05f4c507a in QApplication::notify (this=0x202a050, receiver=0x26cdff0, e=0x7fff4b759510) at kernel/qapplication.cpp:4030
#17 0x00007fd0605a1e06 in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#18 0x00007fd05ed79c9c in QCoreApplication::notifyInternal (this=0x202a050, receiver=0x26cdff0, event=0x7fff4b759510) at kernel/qcoreapplication.cpp:610
#19 0x00007fd05eda62c6 in QCoreApplication::sendEvent (this=0x204eb20) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:213
#20 QTimerInfoList::activateTimers (this=0x204eb20) at kernel/qeventdispatcher_unix.cpp:580
#21 0x00007fd05eda2658 in timerSourceDispatch (source=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:184
#22 idleTimerSourceDispatch (source=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:231
#23 0x00007fd05951e90e in g_main_dispatch (context=0x2036830) at /tmp/buildd/glib2.0-2.22.4/glib/gmain.c:1960
#24 IA__g_main_context_dispatch (context=0x2036830) at /tmp/buildd/glib2.0-2.22.4/glib/gmain.c:2513
#25 0x00007fd0595222c8 in g_main_context_iterate (context=0x2036830, block=<value optimized out>, dispatch=<value optimized out>, self=<value optimized out>)
    at /tmp/buildd/glib2.0-2.22.4/glib/gmain.c:2591
#26 0x00007fd0595223f0 in IA__g_main_context_iteration (context=0x2036830, may_block=1) at /tmp/buildd/glib2.0-2.22.4/glib/gmain.c:2654
#27 0x00007fd05eda239c in QEventDispatcherGlib::processEvents (this=0x2011070, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:407
#28 0x00007fd05f553f1f in QGuiEventDispatcherGlib::processEvents (this=0x2a26380, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:202
#29 0x00007fd05ed78562 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#30 0x00007fd05ed78934 in QEventLoop::exec (this=0x7fff4b7597c0, flags=...) at kernel/qeventloop.cpp:201
#31 0x00007fd05ed7aba4 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#32 0x00007fd061de02af in kdemain () from /usr/lib/libkdeinit4_plasma-desktop.so
#33 0x00007fd061a6dabd in __libc_start_main () from /lib/libc.so.6
#34 0x0000000000400649 in _start ()


thank you again
bas
User avatar bcooksley
Administrator
Posts
18556
Karma
83
OS
That problem is caused by either:

1) A failure of the system to be fully updated, please check your package manager
2) A failure of Solid, in that it cannot connect to HAL


System Settings and Device Actions KCM maintainer
Image
Kryten2X4B
Registered Member
Posts
911
Karma
4
OS
bas wrote:before i forgot to post my qt version; it is 4.5.3
do you think an upgrade would help?


That depends. Which version of KDE (couldn't see it mentioned)? If it's 4.4, it may be that Qt hasn't been updated as it should since 4.4 requires Qt 4.6.x.


OpenSUSE 11.4, 64-bit with KDE 4.6.4
Proud to be a member of KDE forums since 2008-Oct.
User avatar bcooksley
Administrator
Posts
18556
Karma
83
OS
KDE 4.4 shouldn't even be capable of starting without Qt 4.6, I would consider it a grave bug of any distro packages which didn't bump the dependency.


System Settings and Device Actions KCM maintainer
Image
User avatar Dario_Andres
Mentor
Posts
67
Karma
3
OS
If you are using Qt 4.5.x then you are using KDE SC 4.3

This reminds me of https://bugs.kde.org/show_bug.cgi?id=219333
The bug reappeared on Debian packages (it was supposed to be fixed in the 4.3.4-4 workspace package)
It should be properly fixed on KDE SC 4.4.x.

Regards
bas
Registered Member
Posts
5
Karma
0
OS
sorry i forget to mention that i use kde 4.3.4

my system is fully updated

as i don't really understand the workaround described in the bug report mentioned by Dario i think i will just wait for kde 4.4 being released in debian testing and post here then if it helps...

thank you very much for your help!

bas
bas
Registered Member
Posts
5
Karma
0
OS
ups i forgot about his post and never marked it as 'solved'

i don't if you saw the date, the last message is about one and a half year ago...

plasma-desktop does not crash anymore. i don't remember what it solved. sorry.

thank you anyway!

bas

 
Reply to topic

Bookmarks



Who is online

Registered users: AGB, Azzart, Baidu [Spider], Bing [Bot], Bingy, colomar, Exabot [Bot], garthecho, Google [Bot], google01103, GreatEmerald, jensreuterberg, jstaniek, kainz.a, koriun, Kver, La Ninje, lazyit, Majestic-12 [Bot], MSN [Bot], Nuc!eoN, psbot [Picsearch], rulet111, scummos, SecretCode, Tuukka, undoshmulhe, Uri_Herrera, Yahoo [Bot]