Reply to topic

How to disable volume indicator?

User avatar greatperson
Registered Member
Posts
75
Karma
0
OS

How to disable volume indicator?

Sat Feb 25, 2012 6:12 am
Is there a way to disable the Plasma's volume indicator? It appears when I increase or decrease volume — and some applications think that it's a new window. For example, if I watch a fullscreen YouTube video through flash — it disappears for a moment. And if I watch a fullscreen video through HTML5 player — it exists fullscreen mode. :( It's very annoying.

So, I think there are two ways to resolve it:
edit some settings of KWin to make volume indicator unfocusable
disable volume inicator

Which way is easier? Or, is any of them possible? :)
User avatar toad
Global Moderator
Posts
873
Karma
6
OS
Hm, I noticed that with HTML5 as well, very invasive behaviour and worth of a bug report methinks.


Sid
User avatar bcooksley
Administrator
Posts
18586
Karma
83
OS

Re: How to disable volume indicator?

Sun Feb 26, 2012 10:56 am
As a workaround you can close KMix - but that will disable your audio controls as well. Unfortunately I haven't seen a way to disable this behaviour.

If you are willing to do a one line edit to the KMix code base and self compile it you can disable this functionality - otherwise you'll need to ask for a feature to be implemented i'm afraid.


System Settings and Device Actions KCM maintainer
Image
molecule-eye
Registered Member
Posts
277
Karma
0
OS
Even when I disable KWin's OSD, adjusting the volume using hotkeys still causes HTML5 video to drop out of fullscreen. That's super strange, isn't it?
User avatar bcooksley
Administrator
Posts
18586
Karma
83
OS
If no OSD popup is being shown, then this is probably a bug in Flash itself. You'll need to get Adobe to fix it.


System Settings and Device Actions KCM maintainer
Image
molecule-eye
Registered Member
Posts
277
Karma
0
OS

Re: How to disable volume indicator?

Fri Apr 26, 2013 11:48 am
I was talking about HTML5 video rather than flash. Fullscreen flash works fine when I adjust the volume, even with OSD enabled.
User avatar bcooksley
Administrator
Posts
18586
Karma
83
OS
In this case, you'll need to contact your browser vendor and report a bug to them.
There is nothing KDE can do here, particularly if we are not showing any form of OSD during this video playback. The application is likely being too sensitive with which keys will trigger it exiting full screen mode.


System Settings and Device Actions KCM maintainer
Image
molecule-eye
Registered Member
Posts
277
Karma
0
OS
Thanks. I see one's already been filed: https://bugzilla.mozilla.org/show_bug.cgi?id=578265

 
Reply to topic

Bookmarks



Who is online

Registered users: Abdelrahman Magdy, Baidu [Spider], Bing [Bot], colomar, cylverbak, edmael, Exabot [Bot], Google [Bot], google01103, jeanliu, ken300, koriun, Majestic-12 [Bot], MSNbot Media, navalgupte, paulus3005, psbot [Picsearch], robinh, scummos, Sentynel, TheraHedwig, tshearer, Uri_Herrera, vascobasque, wolfi323, Yahoo [Bot]