Reply to topic

Import qif file, account number detail

User avatar Dimitrios
Registered Member
Posts
637
Karma
0
OS
When i import the qif file from my bank, there is no account number detail in the file so kmymoney every time asks me in which account i want to import the qif file.
I'd like to not to have to indicate every time the account as i have only one.

Is any option that makes kmymoney remember the last choice?
or
any way to add the account number detail in the qif file so kmymoney be able to determine the account that i want to import the qif file to.

The qif file from my bank has this format:

!type:Bank
D19/03/2012
T-30.60
NChèque
PCHEQUE 697
MCHEQUE 697
^
D19/03/2012
T-70.00
NCarte
PCARTE X5107 17/03 REL.ELF 770
MCARTE X5107 17/03 REL.ELF 77012
^
D17/03/2012
T-0.50
NCarte
POPTION TRANQUILLITE
MOPTION TRANQUILLITE
^
D17/03/2012
T-7.70
NCarte
PCOTISATION JAZZ
MCOTISATION JAZZ
^


«The magic continues...»
http://www.mageia.org
Image
aga
Registered Member
Posts
82
Karma
0
OS
You s
Dimitrios wrote:When i import the qif file from my bank, there is no account number detail in the file so kmymoney every time asks me in which account i want to import the qif file.
I'd like to not to have to indicate every time the account as i have only one.

Is any option that makes kmymoney remember the last choice?
or
any way to add the account number detail in the qif file so kmymoney be able to determine the account that i want to import the qif file to.

The qif file from my bank has this format:

!type:Bank
D19/03/2012
T-30.60
NChèque
PCHEQUE 697
MCHEQUE 697
^
^


You should find that adding the following to the head of your file may help.
"
!Account
Nyouraccountname
TBank
^
"

Allan


aga, proud to be a member of KDE forums since 2008-Nov.
User avatar Dimitrios
Registered Member
Posts
637
Karma
0
OS
thanks but I would like to have this in an automatic way. If i have to add a line everytime, it would be better to just do two more clic inside kmymoney as i do now. I'd like to skip this step.


«The magic continues...»
http://www.mageia.org
Image
zebulon
Registered Member
Posts
264
Karma
2
OS
Is qif the only format offered by your bank? OFX and QFX will find the account. You will still asked to confirm though.
User avatar Dimitrios
Registered Member
Posts
637
Karma
0
OS
unfortunately i can only get the statement in qif, xls, cvs and tsv format

(Société générale France)


«The magic continues...»
http://www.mageia.org
Image
User avatar Dimitrios
Registered Member
Posts
637
Karma
0
OS
allana wrote:You s
Dimitrios wrote:When i import the qif file from my bank, there is no account number detail in the file so kmymoney every time asks me in which account i want to import the qif file.
I'd like to not to have to indicate every time the account as i have only one.

Is any option that makes kmymoney remember the last choice?
or
any way to add the account number detail in the qif file so kmymoney be able to determine the account that i want to import the qif file to.

The qif file from my bank has this format:

!type:Bank
D19/03/2012
T-30.60
NChèque
PCHEQUE 697
MCHEQUE 697
^
^


You should find that adding the following to the head of your file may help.
"
!Account
Nyouraccountname
TBank
^
"

Allan


If i add this on the top of the file, it creates a new account with the same name but with the type of 'Checking' and my account is 'Cash'
Is there any way to make kmymoney understand that is a 'Cash' account, so it can import the statement to my existing account?

My statement is this:

* I added this part manually:
!Account
NCourrant 12354569999
^


!Account
NCourrant 12354569999
^
!type:Bank
D10/05/2013
T-75.84
NPrélvmt
PPRELEVEMENT 9063451559 Free
MPRELEVEMENT 9063451559 Free Telecom Free HautDebit 6767675
^
D10/05/2013
T-55.89
NPrélvmt
PPRELEVEMENT 4063645754 OPC
MPRELEVEMENT 4063645754 OPCA *OPH03GL 00d3548901 E5400
^



If i could make it work i will find a way to do it automatically.


«The magic continues...»
http://www.mageia.org
Image
zebulon
Registered Member
Posts
264
Karma
2
OS
Have you tried a QIF filter? The following procedure works for me:

First, create a sed command file. Let's assume its path name is /home/dimitrios/qif_sed. Put the following line in this file:
Code: Select all
1i!Account\nNCourrant 12354569999\n^
If you need to change the account name, make sure to change only this part of the line:
    NCourrant 12354569999
Now, open the QIF import window (File->import->QIF) and enter the name of the QIF file you downloaded from your bank. Under "Import options", click the "New..." button. In the filter definition window, click again "new" and choose a name for the new filter. Leave the "General" tab as is, and open the "Filter" tab. On the first line, type
    sed -f /home/dimitrios/qif_sed
You need to put the full path name. I cleared the second line, but I don't know if that is necessary. Now click the "OK" button and click "Import." You may be asked for a date format; yours is %d/%m/%y. KMM should ask this only once.
User avatar Dimitrios
Registered Member
Posts
637
Karma
0
OS
I cannot make it work
I import the file and now it is like it is empty, nothing is imported
But even if i do manual the changes in the qif file, it does nt be imported in my main account but it creates a new one with the same name but the type is "Checking".
My account has the type of "Cash"


«The magic continues...»
http://www.mageia.org
Image
User avatar ipwizard
KDE Developer
Posts
370
Karma
1
OS
I don't understand how this should work: The file contains a hint that it is a checking account
Code: Select all
!type:Bank

Change that to
Code: Select all
!type:Cash

to match the account type.


ipwizard, proud to be a member of the KMyMoney forum since its beginning. :-D
openSuSE 11.1 32 bit, KDE 4.3.5 -- openSuSE 12.2 64bit, KDE 4.11.5 -- kubuntu 8.10 32bit KDE 4.3.2 via LTS
User avatar Dimitrios
Registered Member
Posts
637
Karma
0
OS
It does nt work, and i tried all categories from here:
http://www.respmech.com/mym2qifw/qif_new.htm
kmymoney understands the qif file as 'Account type: Checking'
whatever i put to the filed '!Type:' in the qif file.


«The magic continues...»
http://www.mageia.org
Image
User avatar Dimitrios
Registered Member
Posts
637
Karma
0
OS
It works if i change my account to 'Checking'.


«The magic continues...»
http://www.mageia.org
Image
User avatar Dimitrios
Registered Member
Posts
637
Karma
0
OS
And the filter with sed works fine now
Ok thanks i solved this :)


«The magic continues...»
http://www.mageia.org
Image

 
Reply to topic

Bookmarks



Who is online

Registered users: 16777216, alake, Baidu [Spider], Bing [Bot], edmael, Exabot [Bot], garthecho, Google [Bot], Hans, joshaughnessy, koriun, Majestic-12 [Bot], north, raymondsarver, urgo, verbalshadow, Yahoo [Bot]