Reply to topic

Lecture MP4

denebe
Registered Member
Posts
15
Karma
0
OS

Lecture MP4

Sat Jan 19, 2013 3:43 pm
Bonjour,

La lecture des mp4 avec Amarok 1.7 (idem avec la précédente) ne se lance pas chez moi. J'utilise le backend-phonon gstreamer, le paquet taglib-extra est en version 1.0.1 (la dernière dispo), et je suis avec Opensuse 12.2, KDE 4.10 (RC3).

Je mets le fichier radio.mp4 (un enregistrement numérique) en liste de lecture, je lance la lecture, mais ça ne part pas, le compteur reste à 0.

Dans en ligne de commande, ça donne:
Code: Select all
denebe@linux-7pxs:~/Musique> amarok monfichier.mp4
QWidget::insertAction: Attempt to insert null action
Trying to set an invalid MediaSource -> ignoring.
**********************************************************************************************
** AMAROK WAS STARTED IN NORMAL MODE. IF YOU WANT TO SEE DEBUGGING INFORMATION, PLEASE USE: **
** amarok --debug                                                                           **
**********************************************************************************************
denebe@linux-7pxs:~/Musique> TagLib: String::prepare() - Unicode conversion error.
TagLib: String::prepare() - Unicode conversion error.
TagLib: String::prepare() - Unicode conversion error.
TagLib: String::prepare() - Unicode conversion error.
TagLib: String::prepare() - Unicode conversion error.
TagLib: String::prepare() - Unicode conversion error.
TagLib: String::prepare() - Unicode conversion error.
TagLib: String::prepare() - Unicode conversion error.
TagLib: String::prepare() - Unicode conversion error.
TagLib: String::prepare() - Unicode conversion error.
TagLib: String::prepare() - Unicode conversion error.
TagLib: String::prepare() - Unicode conversion error.
TagLib: String::prepare() - Unicode conversion error.
TagLib: String::prepare() - Unicode conversion error.
X Error: BadWindow (invalid Window parameter) 3
  Major opcode: 20 (X_GetProperty)
  Resource id:  0x6000012
bool DBusMenuExporterDBus::AboutToShow(int): Condition failed: menu
bool DBusMenuExporterDBus::AboutToShow(int): Condition failed: menu
bool DBusMenuExporterDBus::AboutToShow(int): Condition failed: menu
bool DBusMenuExporterDBus::AboutToShow(int): Condition failed: menu
bool DBusMenuExporterDBus::AboutToShow(int): Condition failed: menu
bool DBusMenuExporterDBus::AboutToShow(int): Condition failed: menu
bool DBusMenuExporterDBus::AboutToShow(int): Condition failed: menu
bool DBusMenuExporterDBus::AboutToShow(int): Condition failed: menu
bool DBusMenuExporterDBus::AboutToShow(int): Condition failed: menu
denebe@linux-7pxs:~/Musique>


Vlc, Kaffeine, smplayer lisent tous le fichier, sauf Amarok, c'est dommage.

Merci de votre aide.
Denebe.

Last edited by denebe on Sat Jan 19, 2013 3:57 pm, edited 1 time in total.
User avatar Mamarok
Manager
Posts
2915
Karma
8
OS

Re: Lecture MP4

Sat Jan 19, 2013 3:52 pm
Amarok 2.7 j'assume? As-tu installé tous les plugins pour gstreamer?


Mamarok, hanging out in the Amarok forum since August, 2007
Currently running Kubuntu Trusty 14.04, KDE 4.12.95, Amarok 2.8-git of the day
denebe
Registered Member
Posts
15
Karma
0
OS

Re: Lecture MP4

Sat Jan 19, 2013 4:04 pm
Quand je fais une recherche avec 'gstreamer', ça donne ça:
Image
User avatar Mamarok
Manager
Posts
2915
Karma
8
OS

Re: Lecture MP4

Sat Jan 19, 2013 5:00 pm
Et si tu renommes le fichier avec l'extension mp4a?


Mamarok, hanging out in the Amarok forum since August, 2007
Currently running Kubuntu Trusty 14.04, KDE 4.12.95, Amarok 2.8-git of the day
denebe
Registered Member
Posts
15
Karma
0
OS

Re: Lecture MP4

Sat Jan 19, 2013 5:14 pm
Non lisible, comme mp4.

Si c'est nécessaire, j'ai la possibilité de poster un échantillon de 1 à 2 secondes. Mais pas plus car ma connexion est à 8kb/s. Dites-moi si ça peut aider je le fais naturellement.

edit: entre temps j'ai rajouté d'autres plugin, ceux pour gstreamer 1 (par exemple gstreamer-plugin-good...). Je ne gère pas du tout les codecs sous linux, j'y vais au flaire et à l'expérience, aussi petite soit-elle.

edit2: j'ai mis deux seconde d'enregistrement, en mp4 (le logiciel fait ça automatiquement). C'est ici:
Fichier : http://www.partage-fichiers.com/upload/1pgrw794
Taille du fichier : 50.88 KB
Utilisateur : p42rswrj
Mot de passe : 27u2jn3v
User avatar Mamarok
Manager
Posts
2915
Karma
8
OS

Re: Lecture MP4

Sat Jan 19, 2013 6:18 pm
gstreamer-good ne sert pas à grand chose, il faut le gstreamer-bad et peut-être même le gstreamer-ugly. Et bien entendu les dernières versions.


Mamarok, hanging out in the Amarok forum since August, 2007
Currently running Kubuntu Trusty 14.04, KDE 4.12.95, Amarok 2.8-git of the day
denebe
Registered Member
Posts
15
Karma
0
OS

Re: Lecture MP4

Sat Jan 19, 2013 6:20 pm
Merci, je regarde ça.

edit: j'ai rajouté ugly, sans succès.
User avatar Mamarok
Manager
Posts
2915
Karma
8
OS

Re: Lecture MP4

Sat Jan 19, 2013 7:39 pm
J'utilise le backend vlc de Phonon qui joue le fichier sans problem, essaye-le :) Le Fichier à installer s'appelle phonon-backend-vlc, tu peux changer le backend dans les réglages Amarok -> Configurer la lecture -> Configurer Phonon -> Moteur


Mamarok, hanging out in the Amarok forum since August, 2007
Currently running Kubuntu Trusty 14.04, KDE 4.12.95, Amarok 2.8-git of the day
denebe
Registered Member
Posts
15
Karma
0
OS

Re: Lecture MP4

Sat Jan 19, 2013 7:49 pm
J'ai déjà essayé, je recommence tout de même, avec le paquet ugly depuis, des fois que... C'est plutôt une bonne nouvelle que le fichier soit lu chez toi , il y a de l'espoir :)

et avec le backend-phonon gstreamer chez toi ?
denebe
Registered Member
Posts
15
Karma
0
OS

Re: Lecture MP4

Sat Jan 19, 2013 8:45 pm
Le fichier se lit, mais sans le son ! Ca avance, je peux bouger le curseur pour avancer ou reculer, mais sans son. Avec le phonon-vlc backend, le soucis n'est plus du côté d'Amarok, mais vers la config de mon système.

Merci pour ton aide. Je vais laisser un peu de temps, la solution va venir... Enfin sauf si tu as une autre piste.
User avatar Mamarok
Manager
Posts
2915
Karma
8
OS

Re: Lecture MP4

Sat Jan 19, 2013 9:11 pm
Toujours pas de son? Mais tu as du son pour d'autres fichiers? Sinon je chercherai dans la configuration de base, à commencer par Alsamixer (qu'il faut peut-etre installer d'abord) pour vérifier que rien n'est en mode silence, ensuite, si tu utilises pulseaudio, vérifie les divers canaux, et bien entendu KMix si rien n'est en mode silence.


Mamarok, hanging out in the Amarok forum since August, 2007
Currently running Kubuntu Trusty 14.04, KDE 4.12.95, Amarok 2.8-git of the day
denebe
Registered Member
Posts
15
Karma
0
OS

Re: Lecture MP4

Sat Jan 19, 2013 9:53 pm
C'est exactement ce que je cherchais depuis quelques demi-heures: alsamixer... J'avais "tout" testé, il me restait à voir alsamixer en console. Je m'en vais de ce pas voir ce que ça donne.
denebe
Registered Member
Posts
15
Karma
0
OS

Re: Lecture MP4

Sat Jan 19, 2013 10:25 pm
Je suis avec backend-vlc phonon;

J'ai lancé alsamixer, il y avait uniquement le canal principal de disponible, il était à 0. Je l'ai monté suffisamment. Je n'ai pas plus de son. j'ai tout de même le sentiment que ça ne venait pas de là, car j'ai du son avec vlc (et avec le backend-vlc), enfin sait-on jamais.

Dans l'immédiat, Amarok est lancé, comme tout à l'heure je peux bouger le curseur d'avance-recul, mais pas de son. D'autre part, dans le mixeur de KDE, je n'ai aucun flux de lecture Amarok, alors que d'après moi il devrait y en avoir un. C'est comme ça avec gstreamer (pour les MP3 ou les radios).

J'ai été voir dans la configuration du système / media / phonon, voilà ce que ça donne:
1) dans le menu préférence de périphérique, quand je teste mes périphériques (HD intel ou HDMI AMD), je n'ai aucun son;
2) dans le menu configuration des périphériques audio, quand je teste droite et gauche, j'ai du son;

J'ai aussi été voir dans ce qui est propre à Opensuse, dans Yast, mais tout semble correct.

Même si je préférerais que tout marche parfaitement, ce n'est quand même pas bien grave, sous gstreamer je peux lire les mp4 avec tous les autres logiciels que j'ai à disposition. Je pourrais aussi virer phonon, mais c'est quand même un gros bazar sachant ce que je viens préciser...

Toutefois, si tu as une autre piste :) , je consulte le forum encore un moment...
User avatar Mamarok
Manager
Posts
2915
Karma
8
OS

Re: Lecture MP4

Sat Jan 19, 2013 10:46 pm
Tu ne devrais pas virer Phonon, car là tu n'auras plus de son du tout sous KDE :)
Et Amarok utilise Phonon, comme d'ailleurs plein d'autres logiciels de KDE. Et si tu arrives à lire les mp4 avec les autres logiciels c'est parcequ'aucun de ceux-là n'utilise phonon à ce que je sache.
Il est donc important de configurer Phonon correctement si tu veux avoir du son dand KDE.
Puisqu'il ne s'agit pas d'un problème d'Amarok, je vais pousser ta question dans le forum francophone KDE général, peu-être que quelqu'un aura la solution.
Je n'ai aucun problème de mon côté, avec Amarok 2.7, KDE 4.9.97 sous Kubuntu, je soupçonne donc un problème de la distribution.


Mamarok, hanging out in the Amarok forum since August, 2007
Currently running Kubuntu Trusty 14.04, KDE 4.12.95, Amarok 2.8-git of the day
denebe
Registered Member
Posts
15
Karma
0
OS

Re: Lecture MP4

Sat Jan 19, 2013 11:29 pm
Oui c'est possible. De mon côté, je n'ai pas bricolé ma distribution, juste ajouté KDE 4.10, mis à jour le kernel et mesa (pour des raisons qui m'appartiennent), rien d'autre.

Quand j'ai écrit phonon, je voulais plutôt dire pulse-audio, mon vocabulaire a fourché ! Mais même, je n'ai pas l'intention de supprimer pulse-audio qui marche quand même plutôt bien.

Je te remercie pour cette aide.
Je surveille ce topic, s'il est souhaitable que je lance d'autres commandes ultérieurement, je le ferais. Et si je trouve une solution, je l'indiquerais aussi.

Bon week-end.

 
Reply to topic

Bookmarks



Who is online

Registered users: alake, Baidu [Spider], Bing [Bot], boudewijn, brandy_000, bshah, cristian.onet, Exabot [Bot], garthecho, Google [Bot], GreatEmerald, Horus, ken300, koriun, Majestic-12 [Bot], mgraesslin, parzt, peje, Tuukka, vomus, Yahoo [Bot]