Reply to topic

Super key to load Application Menu

132

Votes
155
23
pedroworcel
Registered Member
Posts
6
Karma
0
google01103 wrote:re: package - if you go to the kde-apps.org page for the app you will find some packages, as this is not an official app it would be up to your distro or a 3rd party to package it


Tried compiling it and couldn't, and tried the deb too, but failed as well.

So, the functionality this package gives will never be in KDE by default as it stands?
User avatar Hans
Administrator
Posts
3118
Karma
20
OS
pedroworcel wrote:Awesome! thought that solution wasn't a permanent one. Will investigate and see if I can do some testing.


It's "permanent" if you add ksuperkey to autostart. It may not be the best solution, but it should work just fine and not cause any problems.

Sorry, I am quite new, will this be in when I install next version of KDE?


No. If you want to vote to make this behavior the default, http://bugs.kde.org may be the best place to discuss this (first search if it's been posted before). Note that many are against this feature since it breaks the regular behavior of modifier keys, so it may directly be marked as WONTFIX.

EDIT: is there any way to install this without having to compile anything? reason is I'm trying to keep my desktop pristine!


As google01103 pointed out, you can see if a package is available for your distro on kde-apps. Not sure what you mean by "keep my desktop pristine" - the application installs into one directory, it won't put any files anywhere else. To "uninstall" it you just have to remove the directory. You can put this directory anywhere you want.

Thanks for all the hard work. It's the first time I am using KDE, and I love it so far. It is, IMHO, the best desktop solution there is. ;D


Glad to hear that you enjoy KDE, hopefully you'll also soon discover that it's one of the best communities out there. ;)

EDIT: What distro do you use and what error messages did you get when you tried to compile it? Did you install all dependencies?


Problem solved? Please click on "Accept this answer" below the post with the best answer to mark your topic as solved.

Image
10 things you might want to do in KDE | Open menu with Super key | Mouse shortcuts
pedroworcel
Registered Member
Posts
6
Karma
0
Hans wrote:
pedroworcel wrote:Awesome! thought that solution wasn't a permanent one. Will investigate and see if I can do some testing.


No. If you want to vote to make this behavior the default, http://bugs.kde.org may be the best place to discuss this (first search if it's been posted before). Note that many are against this feature since it breaks the regular behavior of modifier keys, so it may directly be marked as WONTFIX.


Sounds sweet! There's gotta be a way of implementing it in a way that doesn't break the rest of the things though, right? Though I am sure I don't understand the complexity of the application.

Glad to hear that you enjoy KDE, hopefully you'll also soon discover that it's one of the best communities out there. ;)

Great! Feeling welcome already :P

EDIT: What distro do you use and what error messages did you get when you tried to compile it? Did you install all dependencies?


Yeah! did, I get the following error:

Code: Select all
smartphone tmp # tar xf 154569-ksuperkey-0.3.tar.gz
smartphone tmp # cd ksuperkey-0.3/
smartphone ksuperkey-0.3 # make
cc -Wall `pkg-config --cflags xtst x11` -o ksuperkey xcape.c `pkg-config --libs xtst x11` -pthread
xcape.c:22:20: fatal error: stdlib.h: No such file or directory
compilation terminated.
make: *** [ksuperkey] Error 1


I am using the latest linux mint. It's weird, it's as if it's not finding the standard libs. I also installed the deb file available there, but I get this error:

Code: Select all
smartphone ksuperkey-0.3 # ksuperkey
ksuperkey: error while loading shared libraries: libXtst.so.6: cannot open shared object file: No such file or directory


Suuper weird, because libxp is installed already. It's as if my OS wasn't being able to find the libs? and suuper annoying, because the libs are there if I do a find.

Anyway, I'm taking it as a sign! No more compiling or doing weird stuff on this os :)
User avatar Hans
Administrator
Posts
3118
Karma
20
OS
pedroworcel wrote:Sounds sweet! There's gotta be a way of implementing it in a way that doesn't break the rest of the things though, right? Though I am sure I don't understand the complexity of the application.


It's not that it breaks things per see, it's just that modifier keys aren't supposed to behave like this - they're meant for modifying other keys when held down, not acting as regular keys on release. That's the problem. Otherwise this should be fairly simple to implement in KDE Workspaces.

Yeah! did, I get the following error:

Code: Select all
smartphone tmp # tar xf 154569-ksuperkey-0.3.tar.gz
smartphone tmp # cd ksuperkey-0.3/
smartphone ksuperkey-0.3 # make
cc -Wall `pkg-config --cflags xtst x11` -o ksuperkey xcape.c `pkg-config --libs xtst x11` -pthread
xcape.c:22:20: fatal error: stdlib.h: No such file or directory
compilation terminated.
make: *** [ksuperkey] Error 1


I am using the latest linux mint. It's weird, it's as if it's not finding the standard libs.


Yeah that's pretty weird. I take it that you've installed the build-essential package? Try
Code: Select all
sudo apt-get install build-essential


Problem solved? Please click on "Accept this answer" below the post with the best answer to mark your topic as solved.

Image
10 things you might want to do in KDE | Open menu with Super key | Mouse shortcuts
User avatar google01103
Manager
Posts
4956
Karma
17
OS
do you have the libXtst6 and libXtst-devel packages installed?


OpenSuse 13.1 x64, KDE 4.12.x

Problem solved? Please click on Image below the post with the best answer to mark your topic as solved.
pedroworcel
Registered Member
Posts
6
Karma
0
Awesome, you are a genius! ;D

That fixed it, and also was able to run the binary. :)

I chipped in the conversation, kind of hoping to understand and see if I can help!
User avatar Hans
Administrator
Posts
3118
Karma
20
OS
pedroworcel wrote:Awesome, you are a genius! ;D

That fixed it, and also was able to run the binary. :)


Cool. Not sure if you mean me or google01103, but I'll take that as a compliment anyway. 8)


Problem solved? Please click on "Accept this answer" below the post with the best answer to mark your topic as solved.

Image
10 things you might want to do in KDE | Open menu with Super key | Mouse shortcuts
paulm
Registered Member
Posts
23
Karma
0
OS
Why on earth is this marked as "done", considering the ability to do this isn't in KDE by default?
User avatar Hans
Administrator
Posts
3118
Karma
20
OS
paulm wrote:Why on earth is this marked as "done", considering the ability to do this isn't in KDE by default?


Because Brainstorm is for brainstorming about ideas for KDE software. Once it's been implemented, whether in the library/workspace/application or by a third party application, it's marked as "Done". If you want to see this feature in KDE Workspaces, http://bugs.kde.org would be a more suitable place for discussion (as mentioned above).


Problem solved? Please click on "Accept this answer" below the post with the best answer to mark your topic as solved.

Image
10 things you might want to do in KDE | Open menu with Super key | Mouse shortcuts
gyges
Registered Member
Posts
5
Karma
0
Works great on Sabayon, thank you!
User avatar Hans
Administrator
Posts
3118
Karma
20
OS
gyges wrote:Works great on Sabayon, thank you!


You're welcome, and thanks for your comments!


Problem solved? Please click on "Accept this answer" below the post with the best answer to mark your topic as solved.

Image
10 things you might want to do in KDE | Open menu with Super key | Mouse shortcuts
User avatar undoIT
Registered Member
Posts
63
Karma
1
OS
+1 for a configuration option to use super key to activate Application Launcher. It doesn't look like I can install ksuperkey on Fedora 19:

Code: Select all
sudo yum install git gcc make libx11-dev libxtst-dev pkg-config

No package libx11-dev available.
No package libxtst-dev available.
No package pkg-config available.


Talkless
Registered Member
Posts
1
Karma
0
Will this ever be possible to do this without this ksuperkey third-party "hack"?

Maybe Qt5 will help to use more custom shortcuts? Or not..?
User avatar Hans
Administrator
Posts
3118
Karma
20
OS
undoIT wrote:+1 for a configuration option to use super key to activate Application Launcher. It doesn't look like I can install ksuperkey on Fedora 19:


Sorry about the late reply, I didn't see your comment until now. It should be possible to compile ksuperkey in Fedora 19, maybe the packages are just called something else. Can you see if you can find a package for ksuperkey or xcape?

Talkless wrote:Will this ever be possible to do this without this ksuperkey third-party "hack"?

Maybe Qt5 will help to use more custom shortcuts? Or not..?


May be possible on Wayland:
http://vizzzion.org/blog/2013/10/recons ... ment-22305
http://blog.martin-graesslin.com/blog/2 ... ment-64741


Problem solved? Please click on "Accept this answer" below the post with the best answer to mark your topic as solved.

Image
10 things you might want to do in KDE | Open menu with Super key | Mouse shortcuts

 
Reply to topic

Bookmarks



Who is online

Registered users: alake, Alexa [Bot], Baidu [Spider], Bing [Bot], Blingy, Deevad, edmael, einar, Exabot [Bot], garthecho, Google [Bot], google01103, haroldtejada, jfredrickson, koriun, lazyit, legnaVI, Majestic-12 [Bot], newtonnickel, parzt, pedrorodriguez, Tuukka, W3C [Validator], Yahoo [Bot]