Only forum.kde.org related discussions fall in the scope of the Forum Feedback area. Please take a minute to find the appropriate section for your query before posting here.
Topic locked

Upgrade - problems thread

User avatar einar
Administrator
Posts
2276
Karma
5
OS

Upgrade - problems thread

Sun Jun 28, 2009 7:24 am
Hello,

the maintenance is now over, and while we ensured that no major bugs crept in during our work, nevertheless there may be some minor problems or missing features. If you find any, please report them here, with a clear description of the problem and a link to show it, if applicable.

Thanks,
KDE Community Forums Staff
User avatar ivan
KDE Developer
Posts
771
Karma
13
OS

Re: Upgrade - problems thread

Sun Jun 28, 2009 8:54 am
Nice to have you back. And, as always, keep up the awesome work :)

There are a couple of complaints, though. (we need to put something in this thread, right? :) )

Issue 1.
The first issue I saw is on the search.php?search_id=newposts page
Image
(the Last post title, and pages switcher links)

Apart from that, I have two suggestions related to the pretty new theme:

Issue 2. - a small usability issue:
Image
the new avatar-name box visually separates the avatar and the name from other info about the post author (post number, karma, os...) while that /other info/ is not visually separated from the post. So, it appears as the /other info/ is not related to the author, but, rather, to the post itself.

Issue 3. - visual suggestion:
the shadows are (IMO) too strong and could/should be made more subtle.

Last edited by ivan on Sun Jun 28, 2009 9:01 am, edited 1 time in total.
User avatar neverendingo
Administrator
Posts
2076
Karma
16
OS

Re: Upgrade - problems thread

Sun Jun 28, 2009 8:59 am
Noted, thanks Ivan for the feedback. I will look into that.

And good to have you all back ;)
Lukas
Registered Member
Posts
427
Karma
0

Re: Upgrade - problems thread

Sun Jun 28, 2009 9:13 am
* Quote button doesn't work for me

* bbcode doesn't always works viewtopic.php?f=83&t=61954

Usability issues:

* Left sidebar (user info) in posts is more visible than the post itself

* Date of post is not shown - join date looks like post publish date

* Post id (#xy) is not show - impossible to hotlink to exact reply

* In Viewforum.php could show excerpt of last post

* Add link to next to last user has seen post, not only last thread post (what if there are 5 pages of replies and there are 10 replies since last time you visited it?)

* Infobox about last exit is too visible - steels attention from topic itself

* Could you float Options after reply (disable BBCode etc) - I think it takes too much of vertical space

* !!!! There is 1440px space between top of the page and the top of the first real tread in brainstorm. Its too much in at least 1000px - more height than my laptop display has.

* Why layout uses tables? It is KDE is breaking edge technology and its official forums, they cant use redundant technology :(
Tenno Seremel
Registered Member
Posts
94
Karma
0
OS

Re: Upgrade - problems thread

Sun Jun 28, 2009 9:18 am
It seems you cannot vote (in brainstorm section) without turning javascript on again.

Also grey color in comment writing text area is horrible. It should be normal #000 black.
Lukas
Registered Member
Posts
427
Karma
0

Re: Upgrade - problems thread

Sun Jun 28, 2009 9:21 am
Save or submit? I spent 3 mins just to find why save button doesn't publish reply. One of the most stupid things is using new words for rutine operations. Users never read they - they scan them, and in this case save is more attractive than submit (to what)

Either default button (submit) should he highlighted (120%font, green background etc) or all buttons renamed to something like "Submit reply" "Preview post", "Save draft"
User avatar mithras
Registered Member
Posts
31
Karma
0
OS

Re: Upgrade - problems thread

Sun Jun 28, 2009 9:38 am
The old brainstorm forum had in the overview already the number of votes displayed isn't it? I can't see it anymore:
Image
User avatar ivan
KDE Developer
Posts
771
Karma
13
OS

Re: Upgrade - problems thread

Sun Jun 28, 2009 9:49 am
@Lukas
Not counting the forum/topic listing, only a *very* small part of /UI/ is based on tables.

And when the forum/topic listing is concerned, it is tabular data, so it is normal to be shown in tables.
User avatar SeaJey
Registered Member
Posts
166
Karma
0
OS

Re: Upgrade - problems thread

Sun Jun 28, 2009 9:52 am
And please recreate a button to mark all post read in "New posts" view.

And what was the reason to switch forum engines?
Performance problems?
User avatar sayakb
Administrator
Posts
1957
Karma
12
OS

Re: Upgrade - problems thread

Sun Jun 28, 2009 10:36 am
Okay.. laying hands on neverendingo's fine work... :)
@ivan
The first issue I saw is on the search.php?search_id=newposts page


Fixed!

@Tenno Seremel
It seems you cannot vote (in brainstorm section) without turning javascript on again.

Also grey color in comment writing text area is horrible. It should be normal #000 black.


About the voting, the controls worked as dual mode earlier.. And I fully agree they should do that now. We will fix that asap.

About the box color, made it darker ;)
User avatar joethefox
Registered Member
Posts
122
Karma
0
OS

Re: Upgrade - problems thread

Sun Jun 28, 2009 10:45 am
I've found a problem if you set "prosilver" as board style: the theme seems to be missing:

Image

P.S. Prosilver theme fit the page to the screen width, essential for me that I've a 1920x1080 with zoomed fonts, much more readable than the new theme that has a fixed page width
User avatar sayakb
Administrator
Posts
1957
Karma
12
OS

Re: Upgrade - problems thread

Sun Jun 28, 2009 10:52 am
@Above

That is because prosilver isnt available anymore. I have deactivated the theme to solve the problem. Please switch back to KDEsign4 to fix it.

Thanks
User avatar Dante Ashton
Registered Member
Posts
525
Karma
3
OS

Re: Upgrade - problems thread

Sun Jun 28, 2009 11:16 am
First off, nice work! New theme is very attractive!

However, I have noticed a few problems;

Warning level has disappeared.


The 'line' between posts needs to be a little more opaque (kinda hard to see where the posts start/stop when scanning)

Quote tags used in forum before are now borked.

Would be nice to have dividing lines between name/post count etc.
User avatar joethefox
Registered Member
Posts
122
Karma
0
OS

Re: Upgrade - problems thread

Sun Jun 28, 2009 11:22 am
I've set KDEsign4 but :/ ... the new theme will never be able to expand to the whole width of the screen? at the moment I've a lot of white space...

Image
NeoThermic
Registered Member
Posts
1
Karma
0

Re: Upgrade - problems thread

Sun Jun 28, 2009 11:48 am
Lukas wrote:* bbcode doesn't always works viewtopic.php?f=83&t=61954


Quote BBCode is different in phpBB; you use the syntax:
Code: Select all
[quote="USERNAME"] [/quote]



Lukas wrote:* Post id (#xy) is not show - impossible to hotlink to exact reply


The subject at the top of each post is the post hotlink. Your reply, for example is this link:

viewtopic.php?f=9&t=62056#p81275


Hope these help :)

NeoThermic

 
Topic locked

Bookmarks



Who is online

Registered users: Baidu [Spider], Bing [Bot], Exabot [Bot], Google [Bot], google01103, Hans, koriun, La Ninje, MSNbot Media, north, odysseus-art, pesto, SecretCode, Sentynel, Yahoo [Bot], z-uo