Reply to topic

[SOLVED] KDE4.1 Display Settings not saved in Kubuntu

futurefreak
Registered Member
Posts
13
Karma
0
OS
Hi

First let me say I'm glad to be a new member that has recently made the switch from Ubuntu 8.04 with Gnome to KDE4.1 with (K)Ubuntu 8.10. I was a casual and happy Gnome user for years who didn't used to like the feel of KDE. However, after trying the live CD I'm proud to say that I'm now a convert - or would that be konvert? ;) Great work on the interface! It feels like OSX, looks better than any other OS out there imho and is a nice step up from Gnome in terms of flexibility and configurability.

Now for the problem:
I found that the display settings would not stay at 1280x1024@85Hz after either logging out or rebooting and would revert to 1600x1200 with each log in.

That was driving me nuts so after some reading on various forums a couple of things came to light:
1/ xorg.conf was empty so no solution based on editing that would work
2/ opening 'system settings > display' would set correct resolution so it seems like the settings 'are' saved, just not applied at startup.

The solution:
Confirmedd to work with Kubuntu 10.04
khamil8686 wrote:I had this problem and was googling for a solution and came across this thread. I hope to help out other googlers who come across this page, including the threads creators if they still need the help. I found that adding this line
xrandr --output DVI-0 --mode 1440x900
where DVI-0 is the name of your monitor output (VGA-0, VGA-1, DVI-1) and 1440x900 is the resolution you would like to start up your computer with, to the file /etc/kde4/kdm/Xsetup
hope this helps :) this setting persists through reboots:-)


Hope that helps and saves some people from having a few headaches. Imho KDE4.1 isn't ready for terminal shy users like me but when it is it will be quite possibly the best OS frontend/user interface to date. This is a VERY good start!!

Last edited by futurefreak on Thu May 27, 2010 3:50 pm, edited 3 times in total.


futurefreak, proud to be a member of KDE forums since 2008-Dec.
User avatar bcooksley
Administrator
Posts
18657
Karma
83
OS
For anyone else who experiences this problem and is not running Kubuntu, please exchange ".kde" for ".kde4" when looking for the required files.


System Settings and Device Actions KCM maintainer
Image
futurefreak
Registered Member
Posts
13
Karma
0
OS
Unfortunately this problem isn't quite solved yet. The solution only works for one of three users on the geforce2 machine and doesn't work at all for the only user on the gma3100 machine. Strange goings on! I must have done something else that caused it to work for that one user.

I'll keep looking for a solution and if I find one, will post it here.


futurefreak, proud to be a member of KDE forums since 2008-Dec.
hari_hopes
Registered Member
Posts
2
Karma
0
futurefreak wrote:Hi

First let me say I'm glad to be a new member that has recently made the switch from Ubuntu 8.04 with Gnome to KDE4.1 with (K)Ubuntu 8.10. I was a casual and happy Gnome user for years who didn't used to like the feel of KDE. However, after trying the live CD I'm proud to say that I'm now a convert - or would that be konvert? ;) Great work on the interface! It feels like OSX, looks better than any other OS out there imho and is a nice step up from Gnome in terms of flexibility and configurability.

Now for the problem:
I found that the display settings would not stay at 1280x1024@85Hz after either logging out or rebooting and would revert to 1600x1200 with each log in.

That was driving me nuts so after some reading on various forums a couple of things came to light:
1/ xorg.conf was empty so no solution based on editing that would work
2/ opening 'system settings > display' would set correct resolution so it seems like the settings 'are' saved, just not applied at startup.

The solution:
Adding these few lines (shown in bold below) to the /home/user/.kde/share/config/krandrrc solved it thanks to the second post by ranacc here http://ubuntuforums.org/archive/index.php/t-358236.html.

[Display]
ApplyOnStartup=true
SyncTrayApp=true


[Screen_0]
OutputsUnified=false
UnifiedRect=0,0,0,0
UnifiedRotation=1

[Screen_0_Output_default]
Active=true
Rect=0,0,1280,1024
RefreshRate=85
Rotation=1

That would explain the kcmrandrrc_display_applyonstartup="false" line in the startupconfig file in the same directory. Should it be "true"? Any edits to that file would get overwritten with each boot. The same thing happened when editing the systemsettingsrc file. This problem was present on two systems. One with the intel gma3100 and one with a very old but still capable gefore2mx 100/200 with 64MB.

Hopefully there will be a better solution somewhere down the road but this will do for now. The side effect of this is that my panel size gets reset but I can deal with that. The upshot is that after being lulled into a false sense of security I'm once again far more familiar with Linux than intended but so far have managed to get away with not having to compile anything. Any bets that won't last long. No pain no gain right? :)

Hope that helps and saves some people from having a few headaches. Imho KDE4.1 isn't ready for terminal shy users like me but when it is it will be quite possibly the best OS frontend/user interface to date. This is a VERY good start!!
hari_hopes
Registered Member
Posts
2
Karma
0
please help me, I have edited the "krandrrc" file so that it has the header to apply on startup... but it is not being applied... still I have the same issue with the Resolution settings.
I need to click on 'Display Settings' to get the 1280X1024 resolution.
khamil8686
Registered Member
Posts
2
Karma
0
I had this problem and was googling for a solution and came across this thread. I hope to help out other googlers who come across this page, including the threads creators if they still need the help. I found that adding this line
xrandr --output DVI-0 --mode 1440x900
where DVI-0 is the name of your monitor output (VGA-0, VGA-1, DVI-1) and 1440x900 is the resolution you would like to start up your computer with, to the file /etc/kde4/kdm/Xsetup
hope this helps :) this setting persists through reboots:-)
justus87
Registered Member
Posts
1
Karma
0
khamil8686 wrote:I had this problem and was googling for a solution and came across this thread. I hope to help out other googlers who come across this page, including the threads creators if they still need the help. I found that adding this line
xrandr --output DVI-0 --mode 1440x900
where DVI-0 is the name of your monitor output (VGA-0, VGA-1, DVI-1) and 1440x900 is the resolution you would like to start up your computer with, to the file /etc/kde4/kdm/Xsetup
hope this helps :) this setting persists through reboots:-)


I was having a similar issue as the others in this thread. The above solution worked for me.

It was helpful to test out the "xrandr --output DVI-0 --mode 1440x900" in a terminal before editing the Xsetup file. Running xrandr with no arguments displays the current configuration. This helped me discover that my monitor output was "default".

Thus, the line I added to Xsetup was:

xrandr --output default --mode 1024x768
futurefreak
Registered Member
Posts
13
Karma
0
OS
You are stars!! Sorry for my absence by the way. I had given up on KDE for a while but would REALLY like it to be my window manager sooner rather than later. I'm waiting for an upload to finish but after that I'll will install KDE desktop and see if that works.

Ed: It works!! Big thanks for this khamil8686. ;)

Have been using KDE4.2 all day now. It's good have the two managers installed as this way there is a safe Gnome install waiting in the wings just in case things goes belly up. KDE is pretty zippy now as a matter of face. Even with this dodgy GMA3100 pushing pixels around it feels better than anything I've used before including OSX. Nice!

Last edited by futurefreak on Fri May 29, 2009 6:25 pm, edited 1 time in total.


futurefreak, proud to be a member of KDE forums since 2008-Dec.
peppergrower
Registered Member
Posts
25
Karma
0
OS
I realize this has already been solved, but I wanted to add another solution that I found to the same problem. The root of the problem, it turned out, was that I didn't have the resolution I wanted properly set up in xorg.conf. After I got that working, I didn't need a workaround and everything was smooth as can be. I did a longer description of exactly what I did over on Launchpad; see that comment for more details. Anyway, hopefully this ends up helping someone.
futurefreak
Registered Member
Posts
13
Karma
0
OS
Xsetup workaround confirmed to work with Kubuntu 9.10 (still needed here with GMA3100).
KDE 4.3 is sweet. Cleaner, sharper, nicer, better. Is it a keeper? I think so!


futurefreak, proud to be a member of KDE forums since 2008-Dec.
Photon Blizzard
Registered Member
Posts
1
Karma
0
Greetings,

I don't see that anything is solved. It's an active bug in KDE that needs a fix. If you set the screen resolution in any application in any OS and you have to reset it every time it loads, it's 100% broken. Dead, bad code. Raghh!! :-)

I am running Slackware 13.0 with KDE 4 and I tried all of the listed scenarios. The only on that actually did anything was (xrandr --output default --mode 1024x768). And it only worked once!

Seriously, I made the change as above, rebooted and when KDE started it showed the wrong resolution, then blip! it changed to 1024x768.. Great! But when I again rebooted, no change, back to the same tiny default resolution.

I really, really like KDE and don't intend to give it up, but Geez!

[Rant mode disengaged].

If anyone has any workaround to this Broken piece of code that hasn't been posted yet, please let me give it try! :-)

Thanks to all!

PB

P.S. I just tested this in FreeBSD 7.2 / KDE with the same result.
User avatar bcooksley
Administrator
Posts
18657
Karma
83
OS
You need to make sure "krandrtray" runs on startup.


System Settings and Device Actions KCM maintainer
Image
User avatar vbatts
Moderator
Posts
102
Karma
0
OS
additionally xrandr does not commit to the xorg configuration. so X is not going to persist with these changes.


vbatts, proud to be a member of KDE forums since 2008-Sep.

http://hashbangbash.com/
mertress
Registered Member
Posts
6
Karma
0
OS
Just installed KDE 4.3. Bug is still present :)
Krandrtray autostart solves the problem but only after user logged in. And for logon screen KDE uses Xorg resolution settings.
So, is there any right way to change logon screen resolution from KDE settings except adding "xrandr .. " string to Xsetup file?
User avatar bcooksley
Administrator
Posts
18657
Karma
83
OS
At this time, adding xrandr with the manually entered resolution to Xsetup is the only way other than editing xorg.conf to change resolution at the login screen.


System Settings and Device Actions KCM maintainer
Image

 
Reply to topic

Bookmarks



Who is online

Registered users: alake, Alexa [Bot], Baidu [Spider], Bing [Bot], bobo01, einar, Exabot [Bot], Google [Bot], Hei Ku, joshaughnessy, Marand, mgraesslin, nezumi, orbmiser, TheraHedwig, Yahoo [Bot]