Reply to topic

[SOLVED] Please Help How to restore kde4 taskbar to default?

mumrah
Registered Member
Posts
15
Karma
0
Hello all,
I was attempting to move my taskbar to the top of my screen.
Now my taskbar looks terrible. somehow my system tray got moved from the taskbar on to the desktop. The clock/calendar has gotten deleted how can i get them back? All other icons that were on the right are move over to the left.
Is there away to restore my taskbar back to how it was after install? Please help.
Attached is a screenshot of how my desktop looks.

Image
User avatar Hans
Administrator
Posts
3125
Karma
20
OS
From the Plasma FAQ:
Q: My panel is gone, how do I get it back?
A: [font=Courier]kquitapp plasma; rm $KDEHOME/share/config/plasma-appletsrc; plasma[/font]

This deletes your plasma settings, so you'll get the default configuration back. If running all the 3 commands at once doesn't work, try typing them in manually and wait a few seconds before running the next command.

(Note that the $KDEHOME environment variable may not be set. Try ~/.kde (Fedora, Kubuntu Intrepid, Debian, upstream default) or ~/.kde4 (OpenSUSE, Kubuntu Hardy and several others).)


Note that this restores your whole desktop to default, not only the panel ("taskbar" is just a widget that shows your tasks - might be good to know :-)).


Problem solved? Please click on "Accept this answer" below the post with the best answer to mark your topic as solved.

Image
10 things you might want to do in KDE | Open menu with Super key | Mouse shortcuts
mumrah
Registered Member
Posts
15
Karma
0
Thanks Hans,
That worked perfect my taskbar is restored to default.
Now how can i move it from the bottom to the top of screen?
mumrah,



Hans wrote:From the Plasma FAQ:
Q: My panel is gone, how do I get it back?
A: [font=Courier]kquitapp plasma; rm $KDEHOME/share/config/plasma-appletsrc; plasma[/font]

This deletes your plasma settings, so you'll get the default configuration back. If running all the 3 commands at once doesn't work, try typing them in manually and wait a few seconds before running the next command.

(Note that the $KDEHOME environment variable may not be set. Try ~/.kde (Fedora, Kubuntu Intrepid, Debian, upstream default) or ~/.kde4 (OpenSUSE, Kubuntu Hardy and several others).)


Note that this restores your whole desktop to default, not only the panel ("taskbar" is just a widget that shows your tasks - might be good to know :-)).

Last edited by mumrah on Thu Mar 26, 2009 12:34 pm, edited 1 time in total.
User avatar Hans
Administrator
Posts
3125
Karma
20
OS
Click on the cashew Image on the panel, and you should see some configuration options. Move your mouse pointer above the button that says "Screen Edge", hold down the left mouse button and drag the panel to the top.

If you're satisfied with the answer, please mark the thread as solved by clicking on
Image
which makes it easier for people with the same problem to find the thread.


Problem solved? Please click on "Accept this answer" below the post with the best answer to mark your topic as solved.

Image
10 things you might want to do in KDE | Open menu with Super key | Mouse shortcuts
mumrah
Registered Member
Posts
15
Karma
0
That worked, Awesome.
Thanks again Hans,
ddoucette
Registered Member
Posts
2
Karma
0
Hi, I'm not sure how to enter the commands you suggested below. I opened a terminal and pasted the commands. They didn't seem to work until I prefixed "sudo" to the commands. Then, my desktop disappeared (windows remained) and came back as it was before. As though no affect had taken.

Sorry if this is too simple a question...

Hans wrote:From the Plasma FAQ:
Q: My panel is gone, how do I get it back?
A: [font=Courier]kquitapp plasma; rm $KDEHOME/share/config/plasma-appletsrc; plasma[/font]

This deletes your plasma settings, so you'll get the default configuration back. If running all the 3 commands at once doesn't work, try typing them in manually and wait a few seconds before running the next command.

(Note that the $KDEHOME environment variable may not be set. Try ~/.kde (Fedora, Kubuntu Intrepid, Debian, upstream default) or ~/.kde4 (OpenSUSE, Kubuntu Hardy and several others).)


Note that this restores your whole desktop to default, not only the panel ("taskbar" is just a widget that shows your tasks - might be good to know :-)).
User avatar bcooksley
Administrator
Posts
18669
Karma
83
OS
You did not need to prefix "sudo" to the commands. That could have done more damage possibly. Try these commands:
Code: Select all
kquitapp plasma; rm $(kde4-config --localprefix)/share/config/plasma-appletsrc; plasma

Last edited by bcooksley on Wed May 13, 2009 5:41 am, edited 1 time in total.


System Settings and Device Actions KCM maintainer
Image
ddoucette
Registered Member
Posts
2
Karma
0
bcooksley wrote:You did not need to prefix "sudo" to the commands. That could have done more damage possibly. Try these commands:
Code: Select all
kquitapp plasma; rm $(kde4-config --localprefix)/share/config/plasma-appletsrc; plasma



Thanks! Yes, I'm now in good shape. Appreciate the assist.

Cheers,
D

 
Reply to topic

Bookmarks



Who is online

Registered users: apater, areid, Baidu [Spider], Bing [Bot], braystacey, edmael, einar, Exabot [Bot], garthecho, Google [Bot], google01103, ivan, jensreuterberg, joaob, jpwhiting, jstaniek, La Ninje, lazyit, Majestic-12 [Bot], mmistretta, MSN [Bot], pedrorodriguez, salvochea, scottpetrovic, scummos, SeaJey, SecretCode, slangkamp, slawekk, Sogou [Bot], SysGhost, TheraHedwig, tienhung, Tioz, VP1986, Yahoo [Bot], šumski