Reply to topic

Cannot enable invert effect

ztrange
Registered Member
Posts
5
Karma
0

Cannot enable invert effect

Sat Aug 01, 2009 10:44 pm
I've been wanting to enable the invert effect; it's very useful to read large text...

Well, Whenever I try to enable it, kde only notifies me saying that it could not be enabled.

I'm using arch with kde 4.3. Before, I was using kubuntu 9.04 and neither there I could enable the effect.

I've used compiz invert effect in this pc with gnome. But I want to use kde and well, Invert is really useful.
ztrange
Registered Member
Posts
5
Karma
0

Re: Cannot enable invert effect

Tue Aug 04, 2009 12:17 am
Hey!!

Am I the only one with the issue??

Bump...
Kryten2X4B
Registered Member
Posts
911
Karma
4
OS

Re: Cannot enable invert effect

Tue Aug 04, 2009 12:29 am
Which driver are you using? Can you enable other Kwin-effects?

FWIW, it works for me using KDE 4.3RC3 (AKA 4.2.98) and the nvidia-driver (currently 190.18 but worked using the 185.x series as well).


OpenSUSE 11.4, 64-bit with KDE 4.6.4
Proud to be a member of KDE forums since 2008-Oct.
ztrange
Registered Member
Posts
5
Karma
0

Re: Cannot enable invert effect

Tue Aug 04, 2009 12:36 am
using intel driver.
Yes, Im using other effects:

login, logout, minimize application, shadow, taskbar thumbnails, traslucency, dialog parent, dim screen for administrator mode, slide back, cover switch, desktop cube animation, present windows
Kryten2X4B
Registered Member
Posts
911
Karma
4
OS

Re: Cannot enable invert effect

Tue Aug 04, 2009 12:58 am
I wonder if it can be related to https://bugs.kde.org/show_bug.cgi?id=200878


OpenSUSE 11.4, 64-bit with KDE 4.6.4
Proud to be a member of KDE forums since 2008-Oct.
User avatar Zarin
KDE Developer
Posts
345
Karma
8
OS

Re: Cannot enable invert effect

Wed Aug 05, 2009 12:18 pm
The invert effect requires fragment shaders to work. Please copy/paste the output of the following:

Code: Select all
glxinfo | grep -iE '(shad)|(string)'


If you cannot see GL_ARB_fragment_shader and GL_ARB_shading_language_100 then your system doesn't support the required functionality.
kernelOfTruth
Registered Member
Posts
3
Karma
0
OS

Re: Cannot enable invert effect

Mon Aug 24, 2009 9:15 am
I got the same problem

I've never been able to enable the invert effect with my ATI-card (radeon 4850 HD):

glxinfo | grep -iE '(GL_ARB_fragment_shader)|(GL_ARB_shading_language_100)|(string)|shad'
server glx vendor string: ATI
server glx version string: 1.4
client glx vendor string: ATI
client glx version string: 1.4
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: ATI Radeon HD 4800 Series
OpenGL version string: 2.1.8870
OpenGL shading language version string: 1.40
GL_AMDX_vertex_shader_tessellator, GL_AMD_draw_buffers_blend,
GL_AMD_vertex_shader_tessellator, GL_ARB_color_buffer_float,
GL_ARB_fragment_program_shadow, GL_ARB_fragment_shader,
GL_ARB_geometry_shader4, GL_ARB_half_float_pixel,
GL_ARB_point_parameters, GL_ARB_point_sprite, GL_ARB_shader_objects,
GL_ARB_shader_texture_lod, GL_ARB_shading_language_100, GL_ARB_shadow,
GL_ARB_shadow_ambient, GL_ARB_texture_border_clamp,
GL_ARB_vertex_buffer_object, GL_ARB_vertex_program, GL_ARB_vertex_shader,
GL_ATI_fragment_shader, GL_ATI_meminfo, GL_ATI_separate_stencil,
GL_EXT_geometry_shader4, GL_EXT_gpu_program_parameters,
GL_EXT_gpu_shader4, GL_EXT_multi_draw_arrays, GL_EXT_packed_depth_stencil,
GL_EXT_shadow_funcs, GL_EXT_stencil_wrap, GL_EXT_subtexture,


and I believe I'm not the only one suffering from this "bug"

when I still had my nvidia-card (7600 GT) it worked fine but now I can't get it to work - it seems to be the only effect it can't enable: "the following effects could not be activated" Invert

any ideas how to get it running ?

I mean - is it supposed to work at all with the fglrx driver ?

many thanks in advance

your help is highly appreciated
User avatar Zarin
KDE Developer
Posts
345
Karma
8
OS

Re: Cannot enable invert effect

Mon Aug 24, 2009 9:33 am
Does running KWin in forced direct rendering work?

Code: Select all
KWIN_DIRECT_GL=1 kwin --replace &


I don't think the variable affects fglrx but you never know...
kernelOfTruth
Registered Member
Posts
3
Karma
0
OS

Re: Cannot enable invert effect

Mon Aug 24, 2009 10:02 am
thanks for your quick answer ! :)

the problem is if enter this command the whole screen "freezes"

this means it's NOT causing a hardlock but I can't enter anything or interact with the screen anymore

I can still change to the VT and kill kwin and relaunch it from there though

fglrx still looks old compared to nvidia drivers *sigh* :(


"Enable direct rendering" is enabled in the section "Desktop Effects" (System Settings)

kde-version is 4.3.00

installation via kde-4.3.9999 ebuilds from kde-testing overlay
kernelOfTruth
Registered Member
Posts
3
Karma
0
OS

Re: Cannot enable invert effect

Mon Aug 24, 2009 9:07 pm
do you have any other suggestions to force it to enable the invert effect or direct rendering ?
User avatar handheldcar
Registered Member
Posts
32
Karma
0

Invert turns things black.

Fri Jul 09, 2010 3:55 am
Invert turns my screen or application black instead of inverting the colors. Is there a fix for this? I'm using the 173 NVIDIA driver. Shadow and transparency are working well.
Code: Select all
$ glxinfo | grep "direct"
direct rendering: Yes
Code: Select all
$ glxinfo | grep -iE '(shad)|(string)'
server glx vendor string: NVIDIA Corporation
server glx version string: 1.4
client glx vendor string: NVIDIA Corporation
client glx version string: 1.4
OpenGL vendor string: NVIDIA Corporation
OpenGL renderer string: GeForce FX 5200/AGP/SSE2
OpenGL version string: 2.1.2 NVIDIA 173.14.25
OpenGL shading language version string: 1.20 NVIDIA via Cg compiler
GL_ARB_fragment_program_shadow, GL_ARB_fragment_shader,
GL_ARB_point_parameters, GL_ARB_point_sprite, GL_ARB_shadow,
GL_ARB_shader_objects, GL_ARB_shading_language_100,
GL_ARB_vertex_program, GL_ARB_vertex_shader, GL_ARB_window_pos,
GL_EXT_blend_subtract, GL_EXT_compiled_vertex_array, GL_EXT_Cg_shader,
GL_EXT_separate_specular_color, GL_EXT_shadow_funcs,
GL_NV_texture_shader, GL_NV_texture_shader2, GL_NV_texture_shader3,
GL_SGIS_texture_lod, GL_SGIX_depth_texture, GL_SGIX_shadow,
Code: Select all
$ KWIN_DIRECT_GL=1 kwin --replace &
kwin(9613) KWin::InvertEffect::drawWindow: NPOT textures not supported, wasting some memory
kwin(9613) KWin::SceneOpenGL::Window::paintDecoration: NPOT textures not supported, wasting some memory
This last command also slowed down my mouse pointer, so I restarted kdm.
fast_rizwaan
Registered Member
Posts
25
Karma
0
OS
Actually, I removed my nvidia and used onboard intel gpu, for a while, intel i915 does not support invert (as kwin was not allowing it). Before using intel, nvidia was working very fine with invert and other effects. Now after replacing 'nvidia' and installing nvidia drivers and all... all other effects work except 'invert' which is the one i like the most.

The Invert effect should be supported using XRender, so that all people could benefit 'text reading' for 'long hours'.

thanks.

here's kwin output from shell (konsole)
--------------
[rizvan@chakra-desktop ~]$ KWIN_DIRECT_GL=1 kwin --replace &
[1] 3005
[rizvan@chakra-desktop ~]$ kwin(3005) KWin::CompositingPrefs::detectDriverAndVersion: GL vendor is "NVIDIA Corporation"
kwin(3005) KWin::CompositingPrefs::detectDriverAndVersion: GL renderer is "GeForce 8400 GS/PCI/SSE2"
kwin(3005) KWin::CompositingPrefs::detectDriverAndVersion: GL version is "3.3.0 NVIDIA 256.53"
kwin(3005) KWin::CompositingPrefs::detectDriverAndVersion: Detected driver "nvidia" , version "256.53"
kwin(3005) KWin::EffectsHandlerImpl::loadEffect: EffectsHandler::loadEffect : Effect "kwin4_effect_invert" is not supported
kwin(3005) KWin::CompositingPrefs::detectDriverAndVersion: GL vendor is "NVIDIA Corporation"
kwin(3005) KWin::CompositingPrefs::detectDriverAndVersion: GL renderer is "GeForce 8400 GS/PCI/SSE2"
kwin(3005) KWin::CompositingPrefs::detectDriverAndVersion: GL version is "3.3.0 NVIDIA 256.53"
kwin(3005) KWin::CompositingPrefs::detectDriverAndVersion: Detected driver "nvidia" , version "256.53"
kwin(3005) KWin::EffectsHandlerImpl::loadEffect: EffectsHandler::loadEffect : Effect "kwin4_effect_invert" is not supported
fast_rizwaan
Registered Member
Posts
25
Karma
0
OS

Re: Cannot enable invert effect

Mon Jan 10, 2011 2:04 am
try xcalib to get invert without kwin compositing and without opengl on any display card

Code: Select all
xcalib -i -a


See :
http://forum.kde.org/viewtopic.php?f=111&t=92432

http://xcalib.sourceforge.net/

Hope it helps. Thanks.

 
Reply to topic

Bookmarks



Who is online

Registered users: alake, Artmessiah, Baidu [Spider], Bing [Bot], bjoernbalazs, blue_bullet, Charblaze, dniitall, edmael, Exabot [Bot], franku, GentooSimon, Google [Bot], google01103, jensreuterberg, jgrulich, jitseniesen, ken300, koriun, La Ninje, lazyit, lucyandfatty, Majestic-12 [Bot], Mamarok, MiceAreVeryNice, odysseus-art, okias, robinh, Steve Guilford, urgo, wes33, Yahoo [Bot]