Reply to topic

Graphics tablet - Sensitivity gone?

User avatar neverendingo
Administrator
Posts
2076
Karma
16
OS

Graphics tablet - Sensitivity gone?

Thu Oct 08, 2009 3:35 pm
Dear awesome Krita guys,

played around with krita now. Great app. But i noticed my grafics tablet doesn't give any pressure sensitivity. It works in gimp though, and i remember it being working in an older version of krita, too.

I am currently running the BETA 2 packages by kubuntu, my graphics tablet uses the Wacom drivers (though it isn't, it's an Aiptek).

Is there any hidden setting that i am just too stupid to see? Or is it just broken for the BETA2 release?

Any hints appreciated.

(can't wait to make the switch from gimp ;) )


New to KDE Software? - get help from Userbase or ask questions on the Forums
Communicate.
Image
slangkamp
KDE Developer
Posts
439
Karma
2
User avatar neverendingo
Administrator
Posts
2076
Karma
16
OS
Thanks for the link, i will see if i can get it to work. But it looks like it falls into the "not supported" category...
(Earlier this day the wiki wasn't working for me)


New to KDE Software? - get help from Userbase or ask questions on the Forums
Communicate.
Image
User avatar cyrille
Moderator
Posts
110
Karma
1
If it works in gimp, it should work in Krita, the problem is that with Qt 4.5 the name of the tablets input devices are hard coded to "stylus" and "eraser", this means that if your computer isn't configured then Qt 4.5 (and krita) can't find your tablet, this should be fixed in 4.6. In the meantime, you can either check that /etc/X11/xorg.conf or that /etc/hal/fdi/policy/10-wacom.fdi contains the correct name. In your fdi, you should have something like:
Code: Select all
<match key="input.x11_options.Type" contains="stylus">
  <merge key="info.product" type="string">stylus</merge>
</match>


Cyrille Berger
Krita developer and Calligra release coordinator
blog
User avatar Kubuntiac
Registered Member
Posts
769
Karma
2
OS
I've been waiting since 2006 (with a bunch of bug reports filed) for my tablet to be supported. Glad to hear that QT4.6 should fix this. It's been a long time coming!


Krita - All the cool kids are painting with it!
User avatar Kubuntiac
Registered Member
Posts
769
Karma
2
OS


I looked at the "solution" listed at that link, and it seems to be to do with installing xserver-xorg-input-wacom and wacom-tools. Is this solution still valid if your tablet isn't a Wacom (ie mine's an Aiptek 12000U).


Krita - All the cool kids are painting with it!
slangkamp
KDE Developer
Posts
439
Karma
2
Aiptek 12000U is on the list for non-working hardware:
http://wiki.koffice.org/index.php?title ... g_hardware
User avatar Kubuntiac
Registered Member
Posts
769
Karma
2
OS
:(

So is the Aiptek 1200U likely to work with QT 4.6? I miss using a tablet, sorely.

EDIT: Johnathon Riddel also just posted that there's an experimental PPA for QT 4.6 at https://launchpad.net/~kubuntu-ppa/+arc ... perimental Could this be the answer...?

Last edited by Kubuntiac on Fri Oct 09, 2009 1:49 pm, edited 1 time in total.


Krita - All the cool kids are painting with it!
User avatar neverendingo
Administrator
Posts
2076
Karma
16
OS
@cyrille:

Awesome! That was it, the file didn't even exist, created it and works now like a charm in krita!
(For the record, it's an Aiptek 600U)

Back to experiments in Krita.


New to KDE Software? - get help from Userbase or ask questions on the Forums
Communicate.
Image
User avatar Cezzare
Registered Member
Posts
48
Karma
0
OS
Hello! a newbie here. It seems this thread is a bit old. Anyway, I found something curious while working with krita using a genius G-pen. As some might know, these tablets can be used under linux with the wizardpen driver, and I'm using mine that way. The tablet works great with GIMP, Inkscape and krita 1.6.3; I have pressure sensitivity and stuff, but when I installed krita 2.0.2 the tablet stopped having pressure sensitivity. In the 1.6.3 version I just had to go to settings > configure krita > tablet and enable the device, but in version 2.0.2 there's seemingly no way to configure the tablet. I checked all the menus, but didn't find anything. I simply went back to 1.6.3. and the tablet worked again. I'm not quite sure of the reason for this behaviour, but does anyone have and idea of why is this happening? I know I'm not giving much details about the "problem" but I can give the necessary info. I'm using ubuntu karmic by the way (used kubuntu for a while but had some "funny problems" with it).


User avatar Kubuntiac
Registered Member
Posts
769
Karma
2
OS
Hi Cezzare,

I'm sure one of the devs can answer this much better, but I took a look at the current SVN version and you're right that there isn't anything to configure tablets. This is rather odd, as I know quite a bit of work went into improving tablet support (which should improve even more with QT 4.6) and I'm pretty sure there actually *used to be* a tablet config section in Krita 2 in settings > Configure Krita.

It seems that often, you'll need to add a .fdi file to /etc/hal/fdi/policy to get things named correctly. Exactly what needs to be in the file varies, I think, depending on your tablet maker, but I would imagine Googling for .fdi + kubuntu + your-tablet-maker-or-model would help here.


Krita - All the cool kids are painting with it!
User avatar Cezzare
Registered Member
Posts
48
Karma
0
OS
Kubuntiac wrote:
It seems that often, you'll need to add a .fdi file to /etc/hal/fdi/policy to get things named correctly. Exactly what needs to be in the file varies, I think, depending on your tablet maker, but I would imagine Googling for .fdi + kubuntu + your-tablet-maker-or-model would help here.


Firstly ... thanks! :P . Actually the driver for genius pen tablets needs this type of file, after you compile the driver and install it, you have to create a .fdi file in the /etc/hal/fdi/policy/ directory, the file must contain the name of the tablet and parameters such as X and Y axis top and bottom values. However this one doesn't contain references to "stylus" or "pointer" or any other names. A few months ago (3 I think) I had kubuntu 9.04 in my laptop, that time I also installed the driver for the tablet (creating the .fdi file) and had the thing working in krita 1.6.3, that time I also experienced the same behaviour; changing to 2.0.2 left me without pressure sensitivity and configuration options for the tablet.

It's quite strange I think. I've tried using the driver with Ubuntu (GNOME), Kubuntu (KDE) and Xubuntu (Xfce), and it always worked fine with GIMP, Inkscape, and the old krita version, the problem is with 2.0.2. I'll search some info about it, perharps I need to add another .fdi file aside from the one I already have, thanks again!


User avatar Kubuntiac
Registered Member
Posts
769
Karma
2
OS
Without input from one of the dev's, I'd suggest that your best chance is to try version 2.1 either when it goes final in the next couple of weeks, or that you compile it from SVN. Luckily, I noticed that you're on Ubuntu, so you can use the handy-dandy, step by step guide to compiling koffice on Ubuntu. I'm a compiling moron, but it was enough to get me going. This way, you also get to see the latest sexy features added into Krita and any bugfixes show up as soon as you update. Of course trunk SVN is never guaranteed stable! ;)

Oh, and for anyone reading not on *buntu, check out the distro agnostic version here.


Krita - All the cool kids are painting with it!
User avatar boudewijn
KDE Developer
Posts
1380
Karma
7
OS
Krita 2.0 can't have any tablet configuration anymore. An application cannot influence the way Qt looks for tablets, so we cannot offer the usual choices between enabling the stylus or not or which names to use,

With Qt 4.6, the actual name of the of pointer in X11 isn't important anymore, and everything should always on any OS work out of the box -- if you have a tablet that's supported by Qt, your tablet should work, instead of first having to go to settings to enable it.

If people are looking for pressure curve settings: we still should implement a master curve feature, but you can already set the curves for every individual feature for every brush engine.
User avatar Scnd101
Registered Member
Posts
34
Karma
0
OS
I know this thread is a bit old, but I'm experiencing the exact same problem with my wacom graphire 4. It works perfectly in gimp but I don't have any pressure sensitivity in krita/qt

I'm using archlinux and krita 2.2

/etc/hal/fdi/policy/10-wacom.fdi looks like this
Code: Select all
<?xml version="1.0" encoding="UTF-8"?> <!-- -*- SGML -*- -->
<deviceinfo version="0.2">
        <device>
                <match key="info.capabilities" contains="input">
                        <match key="input.x11_driver" contains="wacom">
                                <match key="input.x11_options.Type" contains="stylus">
                                        <merge key="info.product" type="string">stylus</merge>
                                </match>
                                <match key="info.product" contains="eraser">
                                        <merge key="info.product" type="string">eraser</merge>
                                </match>
                                <match key="info.product" contains="pad">
                                        <merge key="info.product" type="string">pad</merge>
                                </match>
                                <match key="info.product" contains="cursor">
                                        <merge key="info.product" type="string">cursor</merge>
                                </match>
                        </match>
                </match>
        </device>
</deviceinfo>

 
Reply to topic

Bookmarks



Who is online

Registered users: alake, Baidu [Spider], bcooksley, Bing [Bot], cylverbak, Exabot [Bot], garthecho, Google [Bot], ken300, koriun, lazyit, Majestic-12 [Bot], Naproxeno, nezumi, normcross, Sogou [Bot], valoriez, vascobasque, whatthefunk, Yahoo [Bot]