Reply to topic

Virtuoso -t takes 416MB from my RAM

warnec
Registered Member
Posts
96
Karma
0

Virtuoso -t takes 416MB from my RAM

Thu Feb 18, 2010 6:15 pm
Hi. First, I want to say that I generally consider these whines about KDE being bloatware and slow-working as something completely unproven and subjective, but this time I am not sure if some of them weren't right.

I always used KDE and had 3 GB of RAM, so didn't notice any great slowdowns. But recently, one of my 1GB units died and now it looks like My computer isn't able to handle KDE and VirtualBox simultaneously. (RAM gets completely filled, and VirtualBox closes)

Ok, enough rant. How I discovered that - I have Nepomuk and Semantic Desktop turned on, so I wasn't entirely surprised when I saw a process called "virtuoso -t" taking >400MB of memory. (Taken from KDE System Monitor) "Does it really need that much?" I asked myself. But I thought "Why should I care? I have 2 GB of RAM, and these tags and annotations thing is quite good, actually. And if I need more memory, I can disable Nepomuk and the memory gets freed."

Well, it isn't so great, as it turns out - even though I can disable Nepomuk and Semantic Desktop and nepomuk processes stop, the "virtuso -t" process still runs and takes ~416MB of memory.

Why does Virtuso takes so much RAM (more than my actual Nepomuk database size, which is 219MB!) and why doesn't it stop when Nepomuk is stopped?

PS.: KDE 4.4.
User avatar annew
Manager
Posts
1155
Karma
11
OS
I suspect there is a problem here that will be solved, in that it does seem to get worse with time. Try stopping nepomuk with
Code: Select all
qdbus org.kde.NepomukServer /nepomukserver org.kde.NepomukServer.quit
then restart it with
Code: Select all
nepomukserver
. I think it might help


annew, proud to be a member of KDE forums since 2008-Oct and a KDE user since 2002.
Join us on http://userbase.kde.org
warnec
Registered Member
Posts
96
Karma
0
Virtuoso -t uses 230MB of my RAM right now. Much better, but I still am not sure whether this is how it should work.

But disabling Semantic Desktop and Nepomuk now also stops Virtuoso. Glad it works now, thanks ;)
User avatar bcooksley
Administrator
Posts
18586
Karma
83
OS
Try changing the memory usage settings in System Settings > Advanced > Desktop Search.


System Settings and Device Actions KCM maintainer
Image
warnec
Registered Member
Posts
96
Karma
0
That helped. Thanks a lot 8)
rickard.von.essen
Registered Member
Posts
1
Karma
0
OS

 
Reply to topic

Bookmarks



Who is online

Registered users: alake, Baidu [Spider], Bing [Bot], Exabot [Bot], garthecho, Google [Bot], google01103, Hans, hmethorst, industrie13, jensreuterberg, koriun, l3u, La Ninje, Majestic-12 [Bot], mmistretta, nerdopolis, PaddyMac, pedrorodriguez, SecretCode, Sentynel, VictorL, Yahoo [Bot]