Reply to topic

Kile on Windows

pospiech
Registered Member
Posts
15
Karma
0

Kile on Windows

Sun Sep 12, 2010 9:27 am
Is there any chance we are going to see KDE 4.5.x or Kile shipped for windows ?

And if not, what are the reasons ?


pospiech, proud to be a member of KDE forums since 2008-Oct.
User avatar bcooksley
Administrator
Posts
18688
Karma
83
OS

Re: Kile on Windows

Mon Sep 13, 2010 6:15 am
You may wish to check with the primary mirror about this ( winkde.org ). You may also wish to contact the kde-windows team on their mailing list: kde-windows@kde.org


System Settings and Device Actions KCM maintainer
Image
panda84
Moderator
Posts
374
Karma
1
OS

Re: Kile on Windows

Sun Sep 19, 2010 1:14 pm
On kde-windows IRC the channel title is: "Release 4.5.0 will still need a bit, please be patient.".
And they told a HUGE announcement is near the door:
http://c2143.blogspot.com/2010/09/facel ... deorg.html

Regarding Kile: there has been a release packaged for Windows in the past, so I'd bet that sometime (when just depends on when someone will step up to do the work) we'll have a new Kile for Windows release.
http://saroengels.blogspot.com/2008/11/ ... dates.html
viewtopic.php?f=59&t=84424#p140740
Moreover, the first Kile for KDE 4 stable release is approaching (before the end of the year):
http://sourceforge.net/mailarchive/foru ... kile-devel

Regards,
Diego


Usate il pulsante Accept this answer per marcare una discussione come risolta!
Blog - LUG - KDE - Lavoro
P3t3r
Registered Member
Posts
33
Karma
0

Re: Kile on Windows

Sat Oct 16, 2010 4:27 pm
So if I want to use Kile on Windows now, which older version I should install? Kile seems to have disappeared from the installer, and when I add the kile archive linked above to my windows KDE, I get a "The procedure entry point _Z17qt_message_output9QtMsgTypePKc could not be located in the dynamic link library QtCore4.dll".

Kile is my most used program in KDE, since it's the best latex editor around. I'm having a hard time getting back used to other latex editors when I'm on windows.
panda84
Moderator
Posts
374
Karma
1
OS

Re: Kile on Windows

Sat Oct 16, 2010 5:46 pm
I think it's not really stable, however you can try installing it from kde-unstable 4.2.95:
http://www.latex-community.org/forum/vi ... =20&t=8212

The message you are reporting seems to be about missing Qt package or wrong Qt version. Try a clean installation, maybe it can help.

Regards,
Diego


Usate il pulsante Accept this answer per marcare una discussione come risolta!
Blog - LUG - KDE - Lavoro
john_hudson
Registered Member
Posts
547
Karma
2
OS

Re: Kile on Windows

Sun Oct 17, 2010 7:35 pm
You may not like the style but it is possible, depending on how far you deviate from the standard packages, that LyX may provide a temporary replacement. LyX doesn't allow you to edit the LaTeX code directly but you can view the LaTeX code at the same time as you enter the commands in LyX.

LyX requires a lot of work if you use unusual packages but, if you mainly use the standard packages, it may tide you over until Kile is available.

Choose Uwe Stohr's Altinstaller if you decide to try this out.


John Hudson, proud to be a member of KDE forums since 2008-Oct.
panda84
Moderator
Posts
374
Karma
1
OS

Re: Kile on Windows

Sun Oct 17, 2010 7:51 pm
Else way, while you wait for Kile to stabilize, you can use Texmaker:
http://www.xm1math.net/texmaker/
It uses Qt too, it's similar, and it's fully supported on Windows out of the box.


Usate il pulsante Accept this answer per marcare una discussione come risolta!
Blog - LUG - KDE - Lavoro
P3t3r
Registered Member
Posts
33
Karma
0

Re: Kile on Windows

Sun Oct 17, 2010 9:36 pm
Great, version 4.2.95 is now up and running. :-)

One problem though: write permissions. Kile claims that
Code: Select all
[PDFLaTeX] The folder C:/Documents and Settings/Peter/My Documents/My Dropbox" is not writable, therefore PDFLaTeX will not be able to save its results.


It's not a problem with texlive though: if I open cmd and manually execute the line there, it works without problem. Saving the file regularly also works. But apparently Kile has less permissions when executing pdflatex???
P3t3r
Registered Member
Posts
33
Karma
0

Re: Kile on Windows

Sun Oct 17, 2010 10:19 pm
And there is more: even the autosave fails:
Code: Select all
the file file:///C:/Documents and Settings/Peter/My Documents/My Dropbox/oefDW.tex.backup could not be saved, check the permissions and free disk space.


Free disk space is 121Gb so that shouldn't be the problem. There's a write permission problem. One that doesn't appear when I run pdflatex in cmd. ???

Kile itself is running flawlessly, so if this little permission problem could be solved then I'll be happy. :-)
It is truly just a permission problem, since in some other folders, everything runs flawlessly.
User avatar bcooksley
Administrator
Posts
18688
Karma
83
OS

Re: Kile on Windows

Mon Oct 18, 2010 4:20 am
Is it able to work with those files without issue? If it can, these may be harmless errors, although I suspect they may be a problem with the file:// KIO slave. I suggest asking the KDE Windows team for further information: kde-windows@kde.org


System Settings and Device Actions KCM maintainer
Image
P3t3r
Registered Member
Posts
33
Karma
0

Re: Kile on Windows

Sun Nov 14, 2010 4:55 pm
Well it's just the backup so it's not a big deal; I'm not going to bother them with it.

A more severe problem however is the following. Sometimes Kile and Okular (the only programs I have installed) just refuse to start. This happens at random times but I noticed today that if I start my laptop without internet connection, then Kile and Okular cannot be opened. Nothing happens when clicking the icon. If I start my computer with internet connection then it works -- but when closing Kile, it's not always possible to open it again afterwards.

This sounds like a very strange problem, and before I report this, I'd like some advice on further testing. I run KDE 4.2.95 with only Kile and Okular installed.

1) Does anyone have any idea where to start my search? I'm working on a Toshiba laptop (with various Toshiba drivers), and I use dropbox (to backup my tex files) and sandboxie. That are the only nontrivial programs I use so if there's any compatibility issue then it's probably one of these problems. I'm now on windows 7 but I had the same problem in XP.
2) Is there any way to see the error message or the logs? Would I see something extra if I install Konsole or some other software?
3) Can someone give me recommendations of what tests I should do before emailing the developers? I will test more elaborately how it's related to internet connection, but perhaps anyone has other recommendations.
P3t3r
Registered Member
Posts
33
Karma
0

Re: Kile on Windows

Thu Nov 18, 2010 6:56 pm
Loading Kile exactly at the time of connection seems to give a "the process for the file protocol died unexpectedly".

Also, I found out today that Kile cannot write to any shared folders in Dropbox, ever. Perhaps this could be an aid to finding the culprit.
User avatar bcooksley
Administrator
Posts
18688
Karma
83
OS

Re: Kile on Windows

Fri Nov 19, 2010 1:23 am
This likely means that there is a problem with the KDE install on your system, as the file:// protocol should always work...


System Settings and Device Actions KCM maintainer
Image
P3t3r
Registered Member
Posts
33
Karma
0

Re: Kile on Windows

Fri Nov 19, 2010 2:36 am
But the file:// protocol worked -- at least during that Kile session, as I had no problems during this session.

It just threw this strange error, and perhaps it is this that breaks something, so that Kile cannot load again once I quit it.

Would this be possible, Kile (or other apps) not loading because file:// is broken (or at least unavailable to KDE, I have not experienced windows problems)? Could it be that Dropbox causes this problem? Does anyone have experience with dropbox+kde4windows?
User avatar bcooksley
Administrator
Posts
18688
Karma
83
OS

Re: Kile on Windows

Fri Nov 19, 2010 10:10 am
I don't know about Dropbox specifically, but file:// is a protocol implemented seperately by KDE to interface with the file system on each Operating System. Try logging out and back in again ( or restart ) to try and fix this.


System Settings and Device Actions KCM maintainer
Image

 
Reply to topic

Bookmarks



Who is online

Registered users: apater, Baidu [Spider], bcooksley, Bing [Bot], Exabot [Bot], Google [Bot], Majestic-12 [Bot], mmistretta, MSNbot Media, onesandzeros, shmerl, Uri_Herrera, Yahoo [Bot]